aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2012-01-05 02:35:10 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2012-01-05 02:35:10 +0000
commit7ec767eacfcbce57510a9468b05bf43b2b2913fb (patch)
treef9069244f73ebe1650b600ba4e0f6b30c27c5866
parentec129af2cb87f7e48afb741faea20d72cc75d8d8 (diff)
downloadports-7ec767eacfcbce57510a9468b05bf43b2b2913fb.tar.gz
ports-7ec767eacfcbce57510a9468b05bf43b2b2913fb.zip
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/libflame/Makefile344
-rw-r--r--math/libflame/distinfo3
-rw-r--r--math/libflame/pkg-descr13
-rw-r--r--math/libflame/pkg-plist290
5 files changed, 651 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 7437a200ef99..395450bcdf66 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -185,6 +185,7 @@
SUBDIR += levmar
SUBDIR += libR
SUBDIR += libRmath
+ SUBDIR += libflame
SUBDIR += libjbigi
SUBDIR += liblbfgs
SUBDIR += libmath++
diff --git a/math/libflame/Makefile b/math/libflame/Makefile
new file mode 100644
index 000000000000..c868c0936546
--- /dev/null
+++ b/math/libflame/Makefile
@@ -0,0 +1,344 @@
+# ex:ts=8
+# Ports collection makefile for: libflame
+# Date created: 1 Jan 2012
+# Whom: bf@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= libflame
+DISTVERSION= r7421
+CATEGORIES= math
+MASTER_SITES= http://www.cs.utexas.edu/users/%SUBDIR%/:1,2 LOCAL/bf:3
+MASTER_SITE_SUBDIR= flame/snapshots/:1 field/docs/:2
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:1,3
+.if !defined(NOPORTDOCS) || make(makesum)
+DISTFILES+= libflame.pdf:2,3
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+.endif
+
+MAINTAINER= bf@FreeBSD.org
+COMMENT= FLAME dense linear algebra library
+
+LICENSE= LGPL21
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+GNU_CONFIGURE= yes
+USE_CSTD= c99
+USE_GMAKE= yes
+
+CONFIGURE_ARGS = --enable-dynamic-build --enable-static-build
+
+IGNOREFILES= libflame.pdf
+
+OPTIONS= BLAS3_CNTL "Set Level-3 BLAS variant and blocksize" on \
+ BUILTIN_BLAS "Build the (suboptimal) internal BLAS" off \
+ CBLAS "Build an interface to an external C BLAS" off \
+ EXTERNAL_LAPACK "Build an interface to an external LAPACK" off \
+ GOTOBLAS "Build a full GotoBLAS interface" off \
+ LAPACK2FLAME "Build a LAPACK compatibility layer" on \
+ LAPACK_SUBPROBLEMS "Use an external LAPACK for subproblems" off \
+ OPENMP "Use multithreading via OpenMP" off \
+ SHARED "Build a shared library and PIC archive" on \
+ STATIC "Build a non-PIC archive" off \
+ SUPERMATRIX "Task scheduling and parallel execution" on \
+ THREADS "Use multithreading via pthreads" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_BLAS3_CNTL)
+CONFIGURE_ARGS+= --enable-blas3-front-end-cntl-trees
+.else
+CONFIGURE_ARGS+= --disable-blas3-front-end-cntl-trees
+.endif
+
+.if defined(WITH_BUILTIN_BLAS)
+IGNORE = : WITH_BUILTIN_BLAS is an experimental option, for testing purposes only
+.if (defined(WITH_CBLAS) || defined(WITH_GOTOBLAS))
+IGNORE = : WITH_BUILTIN_BLAS is incompatible with WITH_CBLAS and WITH_GOTOBLAS
+.endif
+CONFIGURE_ARGS+= --enable-builtin-blas
+.else
+CONFIGURE_ARGS+= --disable-builtin-blas
+.endif
+
+.if defined(WITH_CBLAS)
+IGNORE = : WITH_CBLAS yields an incomplete library, and is for testing purposes only
+.if defined(WITH_GOTOBLAS)
+IGNORE = : WITH_CBLAS is incompatible with WITH_GOTOBLAS
+.endif
+CONFIGURE_ARGS+= --enable-cblas-interfaces
+.else
+CONFIGURE_ARGS+= --disable-cblas-interfaces
+.endif
+
+.if defined(WITH_EXTERNAL_LAPACK)
+CONFIGURE_ARGS+= --enable-external-lapack-interfaces
+.else
+CONFIGURE_ARGS+= --disable-external-lapack-interfaces
+.endif
+
+.if defined(WITH_GOTOBLAS)
+CONFIGURE_ARGS+= --enable-goto-interfaces
+WITH_BLAS= gotoblas
+.else
+CONFIGURE_ARGS+= --disable-goto-interfaces
+.for b in M K N
+.if defined(${b}_BLOCKSIZE)
+CONFIGURE_ARGS+= --enable-default-${b:L}-blocksize=${${b}_BLOCKSIZE}
+.endif
+.endfor
+.endif
+
+.if defined(WITH_LAPACK2FLAME)
+.if defined(WITH_LAPACK_SUBPROBLEMS)
+IGNORE = : WITH_LAPACK2FLAME is incompatible with WITH_LAPACK_SUBPROBLEMS
+.endif
+CONFIGURE_ARGS+= --enable-lapack2flame
+.else
+CONFIGURE_ARGS+= --disable-lapack2flame
+.endif
+
+.if defined(WITH_LAPACK_SUBPROBLEMS)
+.if !defined(WITH_EXTERNAL_LAPACK)
+IGNORE = : WITH_LAPACK_SUBPROBLEMS requires WITH_EXTERNAL_LAPACK
+.endif
+CONFIGURE_ARGS+= --enable-external-lapack-for-subproblems
+.else
+CONFIGURE_ARGS+= --disable-external-lapack-for-subproblems
+.endif
+
+.if defined(WITH_EXTERNAL_LAPACK) || !defined(WITH_BUILTIN_BLAS)
+.if defined(WITH_CBLAS)
+.if exists(${LOCALBASE}/lib/libatlas.so)
+WITH_BLAS?= atlas_c
+.else
+WITH_BLAS?= reference_c
+.endif
+.if !(${WITH_BLAS} == "atlas_c" || ${WITH_BLAS} == "reference_c")
+IGNORE = : WITH_CBLAS is incompatible with WITH_BLAS = ${WITH_BLAS}"
+.endif
+.elif exists(${LOCALBASE}/lib/libgoto2.so)
+WITH_BLAS?= gotoblas
+.elif exists(${LOCALBASE}/lib/libatlas.so)
+WITH_BLAS?= atlas
+.else
+WITH_BLAS?= reference
+.endif #WITH_CBLAS
+.endif #WITH_EXTERNAL_LAPACK or WITH_BUILTIN_BLAS
+
+.if !defined(WITH_BUILTIN_BLAS)
+.if ${WITH_BLAS} == atlas
+RUN_DEPENDS += ${LOCALBASE}/lib/libatlas.so:${PORTSDIR}/math/atlas
+BLAS= -lptf77blas
+.elif ${WITH_BLAS} == atlas_c
+RUN_DEPENDS += ${LOCALBASE}/lib/libatlas.so:${PORTSDIR}/math/atlas
+BLAS= -lptcblas
+.elif ${WITH_BLAS} == gotoblas
+RUN_DEPENDS += ${LOCALBASE}/lib/libgoto2p.so:${PORTSDIR}/math/gotoblas
+BLAS = -lgoto2p
+.elif ${WITH_BLAS} == reference
+RUN_DEPENDS += ${LOCALBASE}/lib/libblas.so:${PORTSDIR}/math/blas
+BLAS= -lblas
+.elif ${WITH_BLAS} == reference_c
+RUN_DEPENDS += ${LOCALBASE}/lib/libgslcblas.so:${PORTSDIR}/math/gsl
+BLAS= -lgslcblas
+.endif #WITH_BLAS
+.endif #WITH_BUILTIN_BLAS
+
+.if defined(WITH_EXTERNAL_LAPACK)
+.if !empty(WITH_BLAS:Matlas*)
+.if defined(WITH_BUILTIN_BLAS)
+RUN_DEPENDS += ${LOCALBASE}/lib/libatlas.so:${PORTSDIR}/math/atlas
+.endif
+LAPACK = -lalapack -lptcblas -lptf77blas
+.elif ${WITH_BLAS} == gotoblas
+.if defined(WITH_BUILTIN_BLAS)
+RUN_DEPENDS += ${LOCALBASE}/lib/libgoto2p.so:${PORTSDIR}/math/gotoblas
+.endif
+LAPACK = -lgoto2p
+.elif !empty(WITH_BLAS:Mreference*)
+RUN_DEPENDS += ${LOCALBASE}/lib/liblapack.so:${PORTSDIR}/math/lapack
+LAPACK = -llapack
+.if defined(WITH_BUILTIN_BLAS) || defined(WITH_CBLAS)
+RUN_DEPENDS += ${LOCALBASE}/lib/libblas.so:${PORTSDIR}/math/blas
+LAPACK+= -lblas
+.endif
+.endif #WITH_BLAS
+.endif #WITH_EXTERNAL_LAPACK
+
+.if defined(WITH_OPENMP)
+.if defined(WITH_THREADS)
+IGNORE = WITH_OPENMP is incompatible with WITH_THREADS
+.endif
+.if !empty(CC:M*clang*)
+IGNORE = clang does not support WITH_OPENMP, use WITH_THREADS instead
+.endif
+OPENMP_CFLAGS ?= -fopenmp
+CFLAGS+= ${OPENMP_CFLAGS}
+LDFLAGS+= ${OPENMP_CFLAGS}
+CONFIGURE_ARGS+= --enable-multithreading=openmp
+.elif defined(WITH_THREADS)
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ARGS+= --enable-multithreading=pthreads
+.else
+CONFIGURE_ARGS+= --enable-multithreading=no
+.endif
+
+.if defined(WITH_SHARED)
+USE_LDCONFIG= yes
+.endif
+
+.for o in SHARED STATIC
+.if defined(WITH_${o})
+PLIST_SUB+= ${o}=""
+.else
+PLIST_SUB+= ${o}="@comment "
+.endif
+.endfor
+
+.if defined(WITH_SUPERMATRIX)
+CONFIGURE_ARGS+= --enable-supermatrix
+.else
+CONFIGURE_ARGS+= --disable-supermatrix
+.endif
+
+.if !(defined(USE_GCC) || defined(USE_FORTRAN) || !empty(CC:M*gcc4*))
+CONFIGURE_ARGS+= --disable-autodetect-f77-ldflags \
+ --disable-autodetect-f77-name-mangling
+.endif
+
+.if !empty(MACHINE_CPU:Msse3)
+CFLAGS+= -msse3
+LDFLAGS+= -msse3
+CONFIGURE_ARGS+= --enable-vector-intrinsics=sse
+.else
+CONFIGURE_ARGS+= --enable-vector-intrinsics=none
+.endif
+
+.if ${ARCH} == "sparc64"
+PICFLAG?= -fPIC
+.else
+PICFLAG?= -fpic
+.endif
+CFLAGS+= ${PICFLAG}
+LDFLAGS+= ${PICFLAG} -Wl,-x
+
+.if defined(MEMORY_ALIGNMENT)
+CONFIGURE_ARGS+= --enable-memory-alignment=${MEMORY_ALIGNMENT}
+.if defined(LDIM_ALIGNMENT)
+CONFIGURE_ARGS+= --enable-ldim-alignment
+.endif
+.endif
+
+.ifndef(NOPORTDOCS)
+PORTDOCS= libflame.pdf
+.endif
+
+.ifndef(NOPORTEXAMPLES)
+PORTEXAMPLES= *
+.endif
+
+SHLIB_MAJOR?= 0
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f \( -name '*.sh' -o -name '*.sh.in' \) | \
+ ${XARGS} ${REINPLACE_CMD} -E \
+ -e 's@(#!)(/bin/bash)@\1${LOCALBASE}\2@'
+ @${FIND} ${WRKSRC} -type f \( -name 'makefile' -o -name 'config.mk.in' \) | \
+ ${XARGS} ${REINPLACE_CMD} \
+ -e 's@-lpthread@${PTHREAD_LIBS}@g' \
+ -e 's@-fPIC@${PICFLAG}@g'
+ @${REINPLACE_CMD} \
+ -e '\@MK_INCL_DIR_INST_W_ARCH_VERS[[:blank:]]*:=@ \
+ s@-$$(ARCH_VERS)@/libflame@' \
+ -e '\@MK_FLAMEC_...S_INST_W_ARCH_VERS[[:blank:]]*:=@ \
+ {N; s@-$$(ARCH_VERS)@@; s@\.so@&.${SHLIB_MAJOR}@2;}' \
+ -e '\@^$$(MK_INCL_DIR_INST):@,\@^endif@d' \
+ -e '\@^$$(INSTALL_PREFIX)/lib/%\.a:@,\@^endif@d' \
+ -e 's@^\($$(INSTALL_PREFIX)/lib/%\)\(-$$(ARCH_VERS)\)\(\.a:\)@\1\3@' \
+ -e '\@^$$(INSTALL_PREFIX)/lib/%.*\.so:@ \
+ s@\(-$$(ARCH_VERS)\)\(\.so\)@\2.${SHLIB_MAJOR}@' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's@gcc)@cc|gcc*)@g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} \
+ -e '\@FLA_LIB_PATH[[:blank:]]*:=@ \
+ s@$$(INSTALL_PREFIX)/lib@../lib/$$(HOST)@' \
+ -e '\@FLA_INC_PATH[[:blank:]]*:=@ \
+ s@$$(INSTALL_PREFIX)@${WRKDIR}@' \
+ -e '\@HOST[[:blank:]]*:=@ \
+ s@sh $$(BUILD_DIRPATH)/ac-utils/config.guess@cat ../config.sys_type@' \
+ ${WRKSRC}/test/Makefile
+
+pre-configure:
+ @${FIND} ${WRKSRC} -type f \( -name '*.bak' -o -name '*.fbsd10bak' \
+ -o -name '*.orig' \) -delete
+
+post-configure:
+.if defined(WITH_STATIC)
+ @${CP} -af ${WRKSRC} ${WRKSRC}_STATIC
+ @${REINPLACE_CMD} -e 's@${PICFLAG}@@' \
+ -e '\@FLA_ENABLE_DYNAMIC_BUILD[[:blank:]]*:=@s@yes@no@' \
+ ${WRKSRC}_STATIC/config/*/config.mk
+.endif
+.if defined(WITH_SHARED)
+ @${REINPLACE_CMD} \
+ -e '\@MK_FLAMEC_LIBS_INST.*[[:blank:]]*:=@ \
+ {N; s@$$(INSTALL_PREFIX)/lib/%@&_pic@;}' \
+ -e '\@^$$(INSTALL_PREFIX)/lib/%\.a:@s@%@&_pic@1' \
+ ${WRKSRC}/Makefile
+.endif
+
+do-build:
+.for o in SHARED STATIC
+.if defined(WITH_${o})
+ @${PRINTF} "\n\n\n===> Building ${o:L} library:\n\n\n\n"
+ @cd ${WRKSRC}${o:S|^|_|:M*STATIC}; ${SETENV} ${MAKE_ENV} ${GMAKE} \
+ ${_MAKE_JOBS} ${MAKE_ARGS} libs
+.endif
+.endfor
+
+do-install:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${_MAKE_JOBS} \
+ ${MAKE_ARGS} install-headers
+.if defined(WITH_SHARED)
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${_MAKE_JOBS} \
+ ${MAKE_ARGS} install-libs install-lib-symlinks
+.endif
+.if defined(WITH_STATIC)
+ @cd ${WRKSRC}_STATIC; ${SETENV} ${MAKE_ENV} ${GMAKE} ${_MAKE_JOBS} \
+ ${MAKE_ARGS} install-libs
+.endif
+.ifndef(NOPORTDOCS)
+ @${INSTALL_DATA} -d ${DOCSDIR}
+ @${INSTALL_DATA} ${_DISTDIR}/${PORTDOCS} ${DOCSDIR}
+.endif
+.ifndef(NOPORTEXAMPLES)
+ @${INSTALL_DATA} -d ${EXAMPLESDIR}
+ @cd ${WRKSRC}/examples; ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
+.endif
+
+.if defined(MAINTAINER_MODE)
+BUILD_DEPENDS += ${RUN_DEPENDS}
+CONFIGURE_ARGS+= --enable-verbose-make-output
+
+check regression-test test: build
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${_MAKE_JOBS} \
+ ${MAKE_ARGS} MK_INCL_DIR_INST_W_ARCH_VERS="${WRKDIR}/include" \
+ install-headers
+.for o in SHARED STATIC
+.if defined(WITH_${o})
+ @${PRINTF} "\n\n\n===> Testing ${o:L} library:\n\n\n\n"
+ @cd ${WRKSRC}${o:S|^|_|:M*STATIC}/test; ${SETENV} ${MAKE_ENV} \
+ ${GMAKE} ${_MAKE_JOBS} ${MAKE_ARGS} \
+ LIBBLAS="-L${LOCALBASE}/lib ${BLAS} -lm" \
+ LIBLAPACK="-L${LOCALBASE}/lib ${LAPACK}" test_libflame ; \
+ ./test_libflame.x
+.endif
+.endfor
+
+.endif #MAINTAINER_MODE
+.include <bsd.port.post.mk>
diff --git a/math/libflame/distinfo b/math/libflame/distinfo
new file mode 100644
index 000000000000..90055022dea8
--- /dev/null
+++ b/math/libflame/distinfo
@@ -0,0 +1,3 @@
+SHA256 (libflame-r7421.tar.gz) = 5c42ffe69f40fb46aa9bcf289a3d124700f31cfa231587207c568dd0274e01bb
+SIZE (libflame-r7421.tar.gz) = 3953831
+SHA256 (libflame.pdf) = IGNORE
diff --git a/math/libflame/pkg-descr b/math/libflame/pkg-descr
new file mode 100644
index 000000000000..bd448383a50f
--- /dev/null
+++ b/math/libflame/pkg-descr
@@ -0,0 +1,13 @@
+libflame contains implementations of many dense linear algebra operations
+that are provided by the BLAS and LAPACK libraries. (However, not all FLAME
+implementations support every datatype, and, in many cases, libflame uses a
+different naming convention for the routines.)
+
+The library is a product of the Formal Linear Algebra Methods Environment
+(FLAME), which encompasses a new notation for expressing algorithms, a
+methodology for systematic derivation of algorithms, Application Program
+Interfaces (APIs) for representing the algorithms in code, and tools for
+mechanical derivation, implementation and analysis of algorithms and
+implementations.
+
+WWW: http://z.cs.utexas.edu/wiki/flame.wiki/FrontPage
diff --git a/math/libflame/pkg-plist b/math/libflame/pkg-plist
new file mode 100644
index 000000000000..824c8f85a497
--- /dev/null
+++ b/math/libflame/pkg-plist
@@ -0,0 +1,290 @@
+include/libflame/FLAME.h
+include/libflame/FLASH.h
+include/libflame/FLASH_Queue.h
+include/libflame/FLASH_Queue_gpu.h
+include/libflame/FLASH_Queue_macro_defs.h
+include/libflame/FLASH_Queue_main_prototypes.h
+include/libflame/FLASH_blas1_prototypes.h
+include/libflame/FLASH_blas2_prototypes.h
+include/libflame/FLASH_blas3_prototypes.h
+include/libflame/FLASH_lapack_prototypes.h
+include/libflame/FLASH_macro_defs.h
+include/libflame/FLASH_main_prototypes.h
+include/libflame/FLASH_util_prototypes.h
+include/libflame/FLA_Accum_T_UT.h
+include/libflame/FLA_Accum_T_UT_fc.h
+include/libflame/FLA_Accum_T_UT_fr.h
+include/libflame/FLA_Apply_G.h
+include/libflame/FLA_Apply_GTG.h
+include/libflame/FLA_Apply_GT_2x2.h
+include/libflame/FLA_Apply_G_1x2.h
+include/libflame/FLA_Apply_G_2x2.h
+include/libflame/FLA_Apply_G_lb.h
+include/libflame/FLA_Apply_G_lf.h
+include/libflame/FLA_Apply_G_mx2_asm.h
+include/libflame/FLA_Apply_G_mx2_opt.h
+include/libflame/FLA_Apply_G_mx3_asm.h
+include/libflame/FLA_Apply_G_mx3_opt.h
+include/libflame/FLA_Apply_G_mx3b_asm.h
+include/libflame/FLA_Apply_G_mx3b_opt.h
+include/libflame/FLA_Apply_G_mx4s_asm.h
+include/libflame/FLA_Apply_G_mx4s_opt.h
+include/libflame/FLA_Apply_G_rb.h
+include/libflame/FLA_Apply_G_rf.h
+include/libflame/FLA_Apply_H2_UT.h
+include/libflame/FLA_Apply_H2_UT_l.h
+include/libflame/FLA_Apply_H2_UT_r.h
+include/libflame/FLA_Apply_HUD_UT.h
+include/libflame/FLA_Apply_HUD_UT_l.h
+include/libflame/FLA_Apply_Q2_UT.h
+include/libflame/FLA_Apply_Q2_UT_lhfc.h
+include/libflame/FLA_Apply_Q2_UT_lnfc.h
+include/libflame/FLA_Apply_QUD_UT.h
+include/libflame/FLA_Apply_QUD_UT_inc.h
+include/libflame/FLA_Apply_QUD_UT_inc_lhfc.h
+include/libflame/FLA_Apply_QUD_UT_lhfc.h
+include/libflame/FLA_Apply_Q_UT.h
+include/libflame/FLA_Apply_Q_UT_inc.h
+include/libflame/FLA_Apply_Q_UT_inc_lhfc.h
+include/libflame/FLA_Apply_Q_UT_inc_lnfc.h
+include/libflame/FLA_Apply_Q_UT_lhbc.h
+include/libflame/FLA_Apply_Q_UT_lhbr.h
+include/libflame/FLA_Apply_Q_UT_lhfc.h
+include/libflame/FLA_Apply_Q_UT_lhfr.h
+include/libflame/FLA_Apply_Q_UT_lnbc.h
+include/libflame/FLA_Apply_Q_UT_lnbr.h
+include/libflame/FLA_Apply_Q_UT_lnfc.h
+include/libflame/FLA_Apply_Q_UT_lnfr.h
+include/libflame/FLA_Apply_Q_UT_rhbc.h
+include/libflame/FLA_Apply_Q_UT_rhbr.h
+include/libflame/FLA_Apply_Q_UT_rhfc.h
+include/libflame/FLA_Apply_Q_UT_rhfr.h
+include/libflame/FLA_Apply_Q_UT_rnbc.h
+include/libflame/FLA_Apply_Q_UT_rnbr.h
+include/libflame/FLA_Apply_Q_UT_rnfc.h
+include/libflame/FLA_Apply_Q_UT_rnfr.h
+include/libflame/FLA_Apply_pivots.h
+include/libflame/FLA_Apply_pivots_ln.h
+include/libflame/FLA_Axpy.h
+include/libflame/FLA_Axpy_vars.h
+include/libflame/FLA_Axpyt.h
+include/libflame/FLA_Axpyt_c.h
+include/libflame/FLA_Axpyt_h.h
+include/libflame/FLA_Axpyt_n.h
+include/libflame/FLA_Axpyt_t.h
+include/libflame/FLA_Bidiag_UT.h
+include/libflame/FLA_Bidiag_UT_u.h
+include/libflame/FLA_Bsvd.h
+include/libflame/FLA_Bsvd_francis_v.h
+include/libflame/FLA_Bsvd_iteracc_v.h
+include/libflame/FLA_Bsvd_n.h
+include/libflame/FLA_Bsvd_sinval_v.h
+include/libflame/FLA_Bsvd_v.h
+include/libflame/FLA_Chol.h
+include/libflame/FLA_Chol_l.h
+include/libflame/FLA_Chol_u.h
+include/libflame/FLA_Cntl.h
+include/libflame/FLA_Cntl_blas1.h
+include/libflame/FLA_Cntl_blas2.h
+include/libflame/FLA_Cntl_blas3.h
+include/libflame/FLA_Cntl_init.h
+include/libflame/FLA_Cntl_init_flamec.h
+include/libflame/FLA_Cntl_init_flash.h
+include/libflame/FLA_Cntl_lapack.h
+include/libflame/FLA_Copy.h
+include/libflame/FLA_Copy_vars.h
+include/libflame/FLA_Copyt.h
+include/libflame/FLA_Copyt_c.h
+include/libflame/FLA_Copyt_h.h
+include/libflame/FLA_Copyt_n.h
+include/libflame/FLA_Copyt_t.h
+include/libflame/FLA_Eig_gest.h
+include/libflame/FLA_Eig_gest_il.h
+include/libflame/FLA_Eig_gest_iu.h
+include/libflame/FLA_Eig_gest_nl.h
+include/libflame/FLA_Eig_gest_nu.h
+include/libflame/FLA_Gemm.h
+include/libflame/FLA_Gemm_cc.h
+include/libflame/FLA_Gemm_ch.h
+include/libflame/FLA_Gemm_cn.h
+include/libflame/FLA_Gemm_ct.h
+include/libflame/FLA_Gemm_hc.h
+include/libflame/FLA_Gemm_hh.h
+include/libflame/FLA_Gemm_hn.h
+include/libflame/FLA_Gemm_ht.h
+include/libflame/FLA_Gemm_nc.h
+include/libflame/FLA_Gemm_nh.h
+include/libflame/FLA_Gemm_nn.h
+include/libflame/FLA_Gemm_nt.h
+include/libflame/FLA_Gemm_tc.h
+include/libflame/FLA_Gemm_th.h
+include/libflame/FLA_Gemm_tn.h
+include/libflame/FLA_Gemm_tt.h
+include/libflame/FLA_Gemv.h
+include/libflame/FLA_Gemv_h.h
+include/libflame/FLA_Gemv_n.h
+include/libflame/FLA_Gemv_t.h
+include/libflame/FLA_Givens2.h
+include/libflame/FLA_Hemm.h
+include/libflame/FLA_Hemm_ll.h
+include/libflame/FLA_Hemm_lu.h
+include/libflame/FLA_Hemm_rl.h
+include/libflame/FLA_Hemm_ru.h
+include/libflame/FLA_Her2k.h
+include/libflame/FLA_Her2k_lh.h
+include/libflame/FLA_Her2k_ln.h
+include/libflame/FLA_Her2k_uh.h
+include/libflame/FLA_Her2k_un.h
+include/libflame/FLA_Herk.h
+include/libflame/FLA_Herk_lh.h
+include/libflame/FLA_Herk_ln.h
+include/libflame/FLA_Herk_uh.h
+include/libflame/FLA_Herk_un.h
+include/libflame/FLA_Hess_UT.h
+include/libflame/FLA_Hess_UT_vars.h
+include/libflame/FLA_Hevd.h
+include/libflame/FLA_Hevd_ln.h
+include/libflame/FLA_Hevd_lv.h
+include/libflame/FLA_LQ_UT.h
+include/libflame/FLA_LQ_UT_vars.h
+include/libflame/FLA_LU_incpiv.h
+include/libflame/FLA_LU_incpiv_aux.h
+include/libflame/FLA_LU_nopiv.h
+include/libflame/FLA_LU_nopiv_vars.h
+include/libflame/FLA_LU_piv.h
+include/libflame/FLA_LU_piv_vars.h
+include/libflame/FLA_Lyap.h
+include/libflame/FLA_Lyap_h.h
+include/libflame/FLA_Lyap_n.h
+include/libflame/FLA_QR2_UT.h
+include/libflame/FLA_QR2_UT_vars.h
+include/libflame/FLA_QR_UT.h
+include/libflame/FLA_QR_UT_inc.h
+include/libflame/FLA_QR_UT_vars.h
+include/libflame/FLA_SPDinv.h
+include/libflame/FLA_Scal.h
+include/libflame/FLA_Scal_vars.h
+include/libflame/FLA_Scalr.h
+include/libflame/FLA_Scalr_l.h
+include/libflame/FLA_Scalr_u.h
+include/libflame/FLA_Svd.h
+include/libflame/FLA_Svd_uv.h
+include/libflame/FLA_Sylv.h
+include/libflame/FLA_Sylv_hh.h
+include/libflame/FLA_Sylv_hn.h
+include/libflame/FLA_Sylv_nh.h
+include/libflame/FLA_Sylv_nn.h
+include/libflame/FLA_Symm.h
+include/libflame/FLA_Symm_ll.h
+include/libflame/FLA_Symm_lu.h
+include/libflame/FLA_Symm_rl.h
+include/libflame/FLA_Symm_ru.h
+include/libflame/FLA_Syr2k.h
+include/libflame/FLA_Syr2k_ln.h
+include/libflame/FLA_Syr2k_lt.h
+include/libflame/FLA_Syr2k_un.h
+include/libflame/FLA_Syr2k_ut.h
+include/libflame/FLA_Syrk.h
+include/libflame/FLA_Syrk_ln.h
+include/libflame/FLA_Syrk_lt.h
+include/libflame/FLA_Syrk_un.h
+include/libflame/FLA_Syrk_ut.h
+include/libflame/FLA_Tevd.h
+include/libflame/FLA_Tevd_eigval_n.h
+include/libflame/FLA_Tevd_eigval_v.h
+include/libflame/FLA_Tevd_francis_n.h
+include/libflame/FLA_Tevd_francis_v.h
+include/libflame/FLA_Tevd_iteracc_n.h
+include/libflame/FLA_Tevd_iteracc_v.h
+include/libflame/FLA_Tevd_n.h
+include/libflame/FLA_Tevd_v.h
+include/libflame/FLA_Tridiag_UT.h
+include/libflame/FLA_Tridiag_UT_l.h
+include/libflame/FLA_Trinv.h
+include/libflame/FLA_Trinv_ln.h
+include/libflame/FLA_Trinv_lu.h
+include/libflame/FLA_Trinv_un.h
+include/libflame/FLA_Trinv_uu.h
+include/libflame/FLA_Trmm.h
+include/libflame/FLA_Trmm_llc.h
+include/libflame/FLA_Trmm_llh.h
+include/libflame/FLA_Trmm_lln.h
+include/libflame/FLA_Trmm_llt.h
+include/libflame/FLA_Trmm_luc.h
+include/libflame/FLA_Trmm_luh.h
+include/libflame/FLA_Trmm_lun.h
+include/libflame/FLA_Trmm_lut.h
+include/libflame/FLA_Trmm_rlc.h
+include/libflame/FLA_Trmm_rlh.h
+include/libflame/FLA_Trmm_rln.h
+include/libflame/FLA_Trmm_rlt.h
+include/libflame/FLA_Trmm_ruc.h
+include/libflame/FLA_Trmm_ruh.h
+include/libflame/FLA_Trmm_run.h
+include/libflame/FLA_Trmm_rut.h
+include/libflame/FLA_Trsm.h
+include/libflame/FLA_Trsm_llc.h
+include/libflame/FLA_Trsm_llh.h
+include/libflame/FLA_Trsm_lln.h
+include/libflame/FLA_Trsm_llt.h
+include/libflame/FLA_Trsm_luc.h
+include/libflame/FLA_Trsm_luh.h
+include/libflame/FLA_Trsm_lun.h
+include/libflame/FLA_Trsm_lut.h
+include/libflame/FLA_Trsm_rlc.h
+include/libflame/FLA_Trsm_rlh.h
+include/libflame/FLA_Trsm_rln.h
+include/libflame/FLA_Trsm_rlt.h
+include/libflame/FLA_Trsm_ruc.h
+include/libflame/FLA_Trsm_ruh.h
+include/libflame/FLA_Trsm_run.h
+include/libflame/FLA_Trsm_rut.h
+include/libflame/FLA_Trsv.h
+include/libflame/FLA_Trsv_lc.h
+include/libflame/FLA_Trsv_ln.h
+include/libflame/FLA_Trsv_lt.h
+include/libflame/FLA_Trsv_uc.h
+include/libflame/FLA_Trsv_un.h
+include/libflame/FLA_Trsv_ut.h
+include/libflame/FLA_Ttmm.h
+include/libflame/FLA_Ttmm_l.h
+include/libflame/FLA_Ttmm_u.h
+include/libflame/FLA_UDdate_UT.h
+include/libflame/FLA_UDdate_UT_inc.h
+include/libflame/FLA_UDdate_UT_vars.h
+include/libflame/FLA_blas1_prototypes.h
+include/libflame/FLA_blas2_prototypes.h
+include/libflame/FLA_blas3_prototypes.h
+include/libflame/FLA_blas_var_prototypes.h
+include/libflame/FLA_config.h
+include/libflame/FLA_config_check.h
+include/libflame/FLA_extern_defs.h
+include/libflame/FLA_f2c.h
+include/libflame/FLA_f77_name_mangling.h
+include/libflame/FLA_lapack_f77_prototypes.h
+include/libflame/FLA_lapack_prototypes.h
+include/libflame/FLA_lapack_var_prototypes.h
+include/libflame/FLA_macro_defs.h
+include/libflame/FLA_macro_ptr_defs.h
+include/libflame/FLA_main_prototypes.h
+include/libflame/FLA_type_defs.h
+include/libflame/FLA_util_base_prototypes.h
+include/libflame/FLA_util_lapack_prototypes.h
+include/libflame/blis.h
+include/libflame/blis_f77_name_mangling.h
+include/libflame/blis_macro_defs.h
+include/libflame/blis_prototypes_blas.h
+include/libflame/blis_prototypes_cblas.h
+include/libflame/blis_prototypes_fused1.h
+include/libflame/blis_prototypes_level1.h
+include/libflame/blis_prototypes_level2.h
+include/libflame/blis_prototypes_level3.h
+include/libflame/blis_prototypes_misc.h
+include/libflame/blis_prototypes_query.h
+include/libflame/blis_prototypes_util.h
+include/libflame/blis_type_defs.h
+%%STATIC%%lib/libflame.a
+%%SHARED%%lib/libflame_pic.a
+%%SHARED%%lib/libflame.so
+%%SHARED%%lib/libflame.so.0
+@dirrm include/libflame