aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-21 17:39:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-21 17:39:03 +0000
commit7ef963090c1ba3fae0e4ab7630e60ff49fe6a9f0 (patch)
treecf7e2bb2fe4cf190cc3da2f5ec6472007f6e4fda
parent16e40219b9f2996a944be12c348301ce78a1526a (diff)
downloadports-7ef963090c1ba3fae0e4ab7630e60ff49fe6a9f0.tar.gz
ports-7ef963090c1ba3fae0e4ab7630e60ff49fe6a9f0.zip
Notes
-rw-r--r--cad/salome/Makefile49
-rw-r--r--cad/salome/Makefile.ext4
-rw-r--r--chinese/ibus-pinyin/Makefile22
-rw-r--r--chinese/oxim/Makefile34
-rw-r--r--comms/fl_moxgen/Makefile12
5 files changed, 60 insertions, 61 deletions
diff --git a/cad/salome/Makefile b/cad/salome/Makefile
index 9068fccc9f19..19a72a3473d5 100644
--- a/cad/salome/Makefile
+++ b/cad/salome/Makefile
@@ -14,19 +14,20 @@ EXTRACT_ONLY= #none
MAINTAINER= devel@stasyan.com
-OPTIONS= \
- GEOM "GEOM module" on \
- MED "MED module" on \
- SMESH "SMESH module (require MED & GEOM)" on \
- NETGENPLUGIN "Netgen-meser plugin" on \
- VISU "VISU module (require MED)" on \
- LIGHT "LIGHT module" on \
- YACS "Yacs module" on \
- MULTIPR "Multipr module" on \
- RANDOMIZER "Randomizer module" on \
- SIERPINSKY "Sierpinsky module" on \
- JOBMAN "Job manager module" on \
- MPI "build with support parrallel calculation" on
+OPTIONS_DEFINE= GEOM MED SMESH NETGENPLUGIN VISU LIGHT YACS MULTIPR RANDOMIZER SIERPINSKY
+OPTIONS_DEFAULT= GEOM MED SMESH NETGENPLUGIN VISU LIGHT YACS MULTIPR RANDOMIZER SIERPINSKY
+GEOM_DESC= GEOM module
+MED_DESC= MED module
+SMESH_DESC= SMESH module (require MED & GEOM)
+NETGENPLUGIN_DESC= Netgen-meser plugin
+VISU_DESC= VISU module (require MED)
+LIGHT_DESC= LIGHT module
+YACS_DESC= Yacs module
+MULTIPR_DESC= Multipr module
+RANDOMIZER_DESC= Randomizer module
+SIERPINSKY_DESC= Sierpinsky module
+JOBMAN_DESC= Job manager module
+MPI_DESC= build with support parrallel calculation
RESOURCEDIR= ${PREFIX}/share/salome/resources
@@ -47,37 +48,37 @@ NO_BUILD= yes
RUN_DEPENDS+= ${RESOURCEDIR}/kernel:${PORTSDIR}/cad/salome-kernel \
${RESOURCEDIR}/gui:${PORTSDIR}/cad/salome-gui
-.if defined(WITH_GEOM)
+.if ${PORT_OPTIONS:MGEOM}
RUN_DEPENDS+= ${RESOURCEDIR}/geom:${PORTSDIR}/cad/salome-geom
.endif
-.if defined(WITH_LIGHT)
+.if ${PORT_OPTIONS:MLIGHT}
RUN_DEPENDS+= ${RESOURCEDIR}/light:${PORTSDIR}/cad/salome-light
.endif
-.if defined(WITH_YACS)
+.if ${PORT_OPTIONS:MYACS}
RUN_DEPENDS+= ${RESOURCEDIR}/yacs:${PORTSDIR}/cad/salome-yacs
.endif
-.if defined(WITH_RANDOMIZER)
+.if ${PORT_OPTIONS:MRANDOMIZER}
RUN_DEPENDS+= ${RESOURCEDIR}/randomizer:${PORTSDIR}/cad/salome-randomizer
.endif
-.if defined(WITH_VISU)
+.if ${PORT_OPTIONS:MVISU}
RUN_DEPENDS+= ${RESOURCEDIR}/visu:${PORTSDIR}/cad/salome-visu
.endif
-.if defined(WITH_MED)
+.if ${PORT_OPTIONS:MMED}
RUN_DEPENDS+= ${RESOURCEDIR}/med:${PORTSDIR}/cad/salome-med
.endif
-.if defined(WITH_SIERPINSKY)
+.if ${PORT_OPTIONS:MSIERPINSKY}
RUN_DEPENDS+= ${RESOURCEDIR}/sierpinsky:${PORTSDIR}/cad/salome-sierpinsky
.endif
-.if defined(WITH_SMESH)
+.if ${PORT_OPTIONS:MSMESH}
RUN_DEPENDS+= ${RESOURCEDIR}/smesh:${PORTSDIR}/cad/salome-smesh
.endif
-.if defined(WITH_NETGENPLUGIN)
+.if ${PORT_OPTIONS:MNETGENPLUGIN}
RUN_DEPENDS+= ${RESOURCEDIR}/netgenplugin:${PORTSDIR}/cad/salome-netgenplugin
.endif
-.if defined(WITH_MULTIPR)
+.if ${PORT_OPTIONS:MMULTIPR}
RUN_DEPENDS+= ${RESOURCEDIR}/multipr:${PORTSDIR}/cad/salome-multipr
.endif
-.if defined(WITH_JOBMAN)
+.if ${PORT_OPTIONS:MJOBMAN}
RUN_DEPENDS+= ${RESOURCEDIR}/jobmanager:${PORTSDIR}/cad/salome-jobmanager
.endif
diff --git a/cad/salome/Makefile.ext b/cad/salome/Makefile.ext
index e1537bf03ce7..8243cd13770e 100644
--- a/cad/salome/Makefile.ext
+++ b/cad/salome/Makefile.ext
@@ -269,7 +269,7 @@ STRIP=
#turn off cppunit support
.if ${SAL_MODULE} == "kernel" || ${SAL_MODULE} == "gui" || ${SAL_MODULE} == "yacs" || ${SAL_MODULE} == "med"
-#.if defined(WITH_CPPUNIT)
+#.if ${PORT_OPTIONS:MCPPUNIT}
#CONFIGURE_ARGS+= --with-cppunit=${LOCALBASE} --with-cppunit_inc=${LOCALBASE}/include/cppunit
#BUILD_DEPENDS+= cppunit-config:${PORTSDIR}/devel/cppunit
#PLIST_SUB+= CPPUNIT=""
@@ -281,7 +281,7 @@ PLIST_SUB+= CPPUNIT="@comment "
#optionally dependency from mpich2
.if ${SAL_MODULE} == "kernel" || ${SAL_MODULE} == "med"
-.if defined(WITH_MPI)
+.if ${PORT_OPTIONS:MMPI}
LIB_DEPENDS+= mpich.2:${PORTSDIR}/net/mpich2
CONFIGURE_ARGS+= --with-mpich=${LOCALBASE}/mpich2 --with-mpi=${LOCALBASE}/mpich2
PLIST_SUB+= MPI=""
diff --git a/chinese/ibus-pinyin/Makefile b/chinese/ibus-pinyin/Makefile
index cd1b5b6c29f4..4b71430b5b86 100644
--- a/chinese/ibus-pinyin/Makefile
+++ b/chinese/ibus-pinyin/Makefile
@@ -27,13 +27,15 @@ CONFIGURE_ARGS= --disable-dependency-tracking --disable-lua-extension
PROJECTHOST= ibus
-OPTIONS= ANDROID_DB "Build Android DB" on \
- OPENPHRASE_DB "Build Open Phrase DB" off \
- OPENCC "Use opencc" off
+OPTIONS_DEFINE= ANDROID_DB OPENPHRASE_DB OPENCC NLS
+OPTIONS_DEFAULT= ANDROID_DB
+ANDROID_DB_DESC= Build Android DB
+OPENPHRASE_DB_DESC= Build Open Phrase DB
+OPENCC_DESC= Use opencc
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_ANDROID_DB)
+.if ${PORT_OPTIONS:MANDROID_DB}
CONFIGURE_ARGS+= --enable-db-android
PLIST_SUB+= ANDROID_DB=""
.else
@@ -44,7 +46,7 @@ PLIST_SUB+= ANDROID_DB="@comment "
OPENPHRASE_DBVER= 1.2.99
OPENPHRASE_DBFILE= pinyin-database-${OPENPHRASE_DBVER}.tar.bz2
-.if defined(WITH_OPENPHRASE_DB)
+.if ${PORT_OPTIONS:MOPENPHRASE_DB}
CONFIGURE_ARGS+= --enable-db-open-phrase
DISTFILES+= ${OPENPHRASE_DBFILE}
PLIST_SUB+= OPENPHRASE_DB=""
@@ -53,14 +55,14 @@ CONFIGURE_ARGS+= --disable-db-open-phrase
PLIST_SUB+= OPENPHRASE_DB="@comment "
.endif
-.if defined(WITH_OPENCC)
+.if ${PORT_OPTIONS:MOPENCC}
CONFIGURE_ARGS+= --enable-opencc
LIB_DEPENDS+= opencc.1:${PORTSDIR}/chinese/opencc
.else
CONFIGURE_ARGS+= --disable-opencc
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -69,11 +71,11 @@ PLIST_SUB+= NLS="@comment "
.endif
post-extract:
-.if defined(WITH_OPENPHRASE_DB)
+.if ${PORT_OPTIONS:MOPENPHRASE_DB}
@${CP} ${DISTDIR}/${OPENPHRASE_DBFILE} ${WRKSRC}/data/db/open-phrase
.endif
post-patch:
@${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/chinese/oxim/Makefile b/chinese/oxim/Makefile
index b218b60798a1..978eab85484b 100644
--- a/chinese/oxim/Makefile
+++ b/chinese/oxim/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: oxim
-# Date created: Mar 19 2006
-# Whom: Rong-En Fan <rafan@infor.org>
-#
+# Created by: Rong-En Fan <rafan@infor.org>
# $FreeBSD$
-#
PORTNAME= oxim
PORTVERSION= 1.2.2
@@ -17,9 +13,11 @@ COMMENT= Open X Input Method server
RUN_DEPENDS= ${LOCALBASE}/share/fonts/TrueType/fireflysung.ttf:${PORTSDIR}/chinese/fireflyttf
-OPTIONS= GTK2 "Enable GTK2 input method module" On \
- CHEWING "Enable Chewing input module" On \
- UNICODE "Enable Unicode input module" On
+OPTIONS_DEFINE= GTK2 CHEWING UNICODE
+OPTIONS_DEFAULT= GTK2 CHEWING UNICODE
+GTK2_DESC= GTK2 input method module
+CHEWING_DESC= Chewing input module
+UNICODE_DESC= Unicode input module
USE_ICONV= yes
USE_XORG= x11 xft xpm xtst
@@ -38,18 +36,18 @@ CONFIGURE_ARGS+=--disable-qt-immodule
MAN1= oxim.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_GTK2)
-CONFIGURE_ARGS+= --disable-gtk-immodule
-PLIST_SUB+= GTK2="@comment "
-.else
+.if ${PORT_OPTIONS:MGTK2}
USE_GNOME+= gtk20
CONFIGURE_ARGS+= --enable-gtk-immodule
PLIST_SUB+= GTK2=""
+.else
+CONFIGURE_ARGS+= --disable-gtk-immodule
+PLIST_SUB+= GTK2="@comment "
.endif
-.if !defined(WITHOUT_CHEWING)
+.if ${PORT_OPTIONS:MCHEWING}
# make sure we have the required libchewing
BUILD_DEPENDS+= zh-libchewing>=0.3.2:${PORTSDIR}/chinese/libchewing
RUN_DEPENDS+= zh-libchewing>=0.3.2:${PORTSDIR}/chinese/libchewing
@@ -62,7 +60,7 @@ CONFIGURE_ARGS+= --disable-chewing-module
PLIST_SUB+= CHEWING="@comment "
.endif
-.if !defined(WITHOUT_UNICODE)
+.if ${PORT_OPTIONS:MUNICODE}
CONFIGURE_ARGS+= --enable-unicode-module
PLIST_SUB+= UNICODE=""
.else
@@ -71,7 +69,7 @@ PLIST_SUB+= UNICODE="@comment "
.endif
# TODO WITHOUT_NLS knob
-#.if !defined(WITHOUT_NLS)
+#.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
LDFLAGS+= -lintl
PLIST_SUB+= NLS=""
@@ -85,10 +83,10 @@ post-patch:
${WRKSRC}/src/gtk-immodule/gtkintl.h
post-install:
-.if !defined(WITHOUT_GTK2)
+.if ${PORT_OPTIONS:MGTK2}
@gtk-query-immodules-2.0 > ${PREFIX}/etc/gtk-2.0/gtk.immodules
.endif
@${CAT} ${PKGMESSAGE}
@${ECHO} To display this message again, type ${PKG_INFO} -D ${PKGNAME}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/comms/fl_moxgen/Makefile b/comms/fl_moxgen/Makefile
index fcbe4347ede9..f7f06e04e427 100644
--- a/comms/fl_moxgen/Makefile
+++ b/comms/fl_moxgen/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fl_moxgen
-# Date created: 2012-05-15
-# Whom: Stephen Hurd <shurd@sasktel.net>
-#
+# Created by: Stephen Hurd <shurd@sasktel.net>
# $FreeBSD$
-#
PORTNAME= fl_moxgen
PORTVERSION= 0.05
@@ -23,11 +19,13 @@ LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk
DESKTOP_ENTRIES= "Fl_MoxGen" "${COMMENT}" "" "${PORTNAME}" \
"Network;HamRadio;" "false"
-OPTIONS= PDF "Enable PDF Writing (requires libharu)" on
+OPTIONS_DEFINE= PDF
+OPTIONS_DEFAULT= PDF
+PDF_DESC= Enable PDF Writing (requires libharu)
.include <bsd.port.options.mk>
-.ifdef WITH_PDF
+.if ${PORT_OPTIONS:MPDF}
LIB_DEPENDS+= hpdf:${PORTSDIR}/print/libharu
ALL_TARGET= fl_moxgen
.else