aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-10-20 18:19:28 +0000
committerSteve Wills <swills@FreeBSD.org>2013-10-20 18:19:28 +0000
commit7f7d5fdda7da2ee7c184e7ac815a666c38620ab3 (patch)
tree3803fc6c21ebefe47d58c707816f6c3ba63c7871
parent2ba17ce7d0426a03ac55652a7393a29ea26267a4 (diff)
downloadports-7f7d5fdda7da2ee7c184e7ac815a666c38620ab3.tar.gz
ports-7f7d5fdda7da2ee7c184e7ac815a666c38620ab3.zip
Notes
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/rubygem-tinder/Makefile26
-rw-r--r--net-im/rubygem-tinder/distinfo2
-rw-r--r--net-im/rubygem-tinder/pkg-descr3
4 files changed, 32 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index e3b9f4f77562..cef4491e4314 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -155,6 +155,7 @@
SUBDIR += rubygem-earthquake
SUBDIR += rubygem-hipchat
SUBDIR += rubygem-termtter
+ SUBDIR += rubygem-tinder
SUBDIR += sendxmpp
SUBDIR += skype
SUBDIR += skype-devel
diff --git a/net-im/rubygem-tinder/Makefile b/net-im/rubygem-tinder/Makefile
new file mode 100644
index 000000000000..f421ef1b81f0
--- /dev/null
+++ b/net-im/rubygem-tinder/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= tinder
+PORTVERSION= 1.9.3
+CATEGORIES= net-im rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby API for interfacing with Campfire
+
+RUN_DEPENDS= rubygem-json>=1.8.0:${PORTSDIR}/devel/rubygem-json \
+ rubygem-eventmachine>=1.0:${PORTSDIR}/devel/rubygem-eventmachine \
+ rubygem-faraday>=0.8:${PORTSDIR}/www/rubygem-faraday\
+ rubygem-faraday_middleware>=0.9:${PORTSDIR}/www/rubygem-faraday_middleware \
+ rubygem-hashie>=1.0:${PORTSDIR}/devel/rubygem-hashie \
+ rubygem-mime-types>=1.19:${PORTSDIR}/misc/rubygem-mime-types \
+ rubygem-multi_json>=1.7:${PORTSDIR}/devel/rubygem-multi_json \
+ rubygem-twitter-stream>=0.1:${PORTSDIR}/net/rubygem-twitter-stream
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/net-im/rubygem-tinder/distinfo b/net-im/rubygem-tinder/distinfo
new file mode 100644
index 000000000000..985a19314b63
--- /dev/null
+++ b/net-im/rubygem-tinder/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/tinder-1.9.3.gem) = 0b06fd2a72ed424e82b1896852dd9ebb10791ef6ab8412e74ad2fa9069f6bd47
+SIZE (rubygem/tinder-1.9.3.gem) = 18944
diff --git a/net-im/rubygem-tinder/pkg-descr b/net-im/rubygem-tinder/pkg-descr
new file mode 100644
index 000000000000..cf8deca7a10c
--- /dev/null
+++ b/net-im/rubygem-tinder/pkg-descr
@@ -0,0 +1,3 @@
+A Ruby API for interfacing with Campfire, the 37Signals chat application.
+
+WWW: http://github.com/collectiveidea/tinder