aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2013-03-03 00:13:19 +0000
committerEitan Adler <eadler@FreeBSD.org>2013-03-03 00:13:19 +0000
commit7f9081c6187c8bc456ea194e6a7d938ba7c52686 (patch)
tree9c0a88a472a40346a746a23d5b2c8c32b1441deb
parenta09a37b9a63c38372e6a605de89b1edc7e7ea863 (diff)
downloadports-7f9081c6187c8bc456ea194e6a7d938ba7c52686.tar.gz
ports-7f9081c6187c8bc456ea194e6a7d938ba7c52686.zip
Notes
-rw-r--r--misc/getopt/Makefile5
-rw-r--r--misc/getopt/distinfo4
-rw-r--r--misc/getopt/files/patch-Makefile38
-rw-r--r--misc/getopt/files/patch-getopt.c55
-rw-r--r--misc/getopt/pkg-plist18
5 files changed, 21 insertions, 99 deletions
diff --git a/misc/getopt/Makefile b/misc/getopt/Makefile
index 8f0da2e8bbe3..ac71ef437978 100644
--- a/misc/getopt/Makefile
+++ b/misc/getopt/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= getopt
-PORTVERSION= 1.1.4
-PORTREVISION= 2
+PORTVERSION= 1.1.5
CATEGORIES= misc
MASTER_SITES= http://software.frodo.looijaard.name/getopt/files/
@@ -15,7 +14,7 @@ USE_GMAKE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-MAKE_ENV= LIBCGETOPT=0
+MAKE_ENV+= LIBCGETOPT=0
MAN1= getopt.1
DOCS= Changelog README
diff --git a/misc/getopt/distinfo b/misc/getopt/distinfo
index 830c4b9d30ac..8c426e35be8c 100644
--- a/misc/getopt/distinfo
+++ b/misc/getopt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (getopt-1.1.4.tar.gz) = 41083d9993c26792851e79b81a0991996a3f61e14998fdd607615cc3bf933bab
-SIZE (getopt-1.1.4.tar.gz) = 37163
+SHA256 (getopt-1.1.5.tar.gz) = 11893276b94b1629606ab75772143918a5713259950fbf4216288e246f19fbb6
+SIZE (getopt-1.1.5.tar.gz) = 51794
diff --git a/misc/getopt/files/patch-Makefile b/misc/getopt/files/patch-Makefile
deleted file mode 100644
index fadb1f525005..000000000000
--- a/misc/getopt/files/patch-Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
---- Makefile.orig Thu Jan 23 23:52:29 2003
-+++ Makefile Thu Jun 5 16:17:44 2003
-@@ -1,7 +1,7 @@
- .SUFFIXES:
-
- DESTDIR=
--prefix=/usr/local
-+prefix=$(PREFIX)
- bindir=$(prefix)/bin
- mandir=$(prefix)/man
- man1dir=$(mandir)/man1
-@@ -29,7 +29,7 @@
- LANGUAGES = cs de es fr it ja nl pt_BR
- MOFILES:=$(patsubst %,po/%.mo,$(LANGUAGES))
-
--CPPFLAGS=-DLIBCGETOPT=$(LIBCGETOPT) -DWITH_GETTEXT=$(WITH_GETTEXT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX
-+CPPFLAGS+=-DLIBCGETOPT=$(LIBCGETOPT) -DWITH_GETTEXT=$(WITH_GETTEXT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX
- ifeq ($(LIBCGETOPT),0)
- CPPFLAGS+=-I./gnu
- endif
-@@ -39,8 +39,6 @@
- -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
- -Wnested-externs -Winline
- OPTIMIZE=-O3 -fno-strength-reduce
--CFLAGS=$(WARNINGS) $(OPTIMIZE)
--LDFLAGS=
-
- sources=getopt.c
- ifeq ($(LIBCGETOPT),0)
-@@ -71,7 +69,7 @@
- getopt-test.bash getopt-test.tcsh \
- $(DESTDIR)$(getoptdir)
-
--ifeq ($(WITH_GETTEXT),1)
-+ifeq ($(WITHOUT_GETTEXT),0)
- all_po: $(MOFILES)
- install_po: all_po
- $(INSTALL) -m 755 -d $(DESTDIR)$(localedir)
diff --git a/misc/getopt/files/patch-getopt.c b/misc/getopt/files/patch-getopt.c
deleted file mode 100644
index 70cf42ffe042..000000000000
--- a/misc/getopt/files/patch-getopt.c
+++ /dev/null
@@ -1,55 +0,0 @@
---- getopt.c.orig Thu Jun 5 16:00:34 2003
-+++ getopt.c Thu Jun 5 16:02:34 2003
-@@ -66,7 +66,6 @@
- int quiet_errors=0; /* 0 is not quiet. */
- int quiet_output=0; /* 0 is not quiet. */
- int quote=1; /* 1 is do quote. */
--int alternative=0; /* 0 is getopt_long, 1 is getopt_long_only */
-
- /* Function prototypes */
- void *our_malloc(size_t size);
-@@ -188,9 +187,7 @@
- opterr=0;
- optind=0; /* Reset getopt(3) */
-
-- while ((opt = (alternative?
-- getopt_long_only(argc,argv,optstr,longopts,&longindex):
-- getopt_long(argc,argv,optstr,longopts,&longindex)))
-+ while ((opt = getopt_long(argc,argv,optstr,longopts,&longindex))
- != EOF)
- if (opt == '?' || opt == ':' )
- exit_code = 1;
-@@ -325,7 +322,6 @@
- fputs(_(" getopt [options] [--] optstring parameters\n"),stderr);
- fputs(_(" getopt [options] -o|--options optstring [options] [--]\n"),stderr);
- fputs(_(" parameters\n"),stderr);
-- fputs(_(" -a, --alternative Allow long options starting with single -\n"),stderr);
- fputs(_(" -h, --help This small usage guide\n"),stderr);
- fputs(_(" -l, --longoptions=longopts Long options to be recognized\n"),stderr);
- fputs(_(" -n, --name=progname The name under which errors are reported\n"),stderr);
-@@ -355,14 +351,13 @@
- {"test",no_argument,NULL,'T'},
- {"unquoted",no_argument,NULL,'u'},
- {"help",no_argument,NULL,'h'},
-- {"alternative",no_argument,NULL,'a'},
- {"name",required_argument,NULL,'n'},
- {"version",no_argument,NULL,'V'},
- {NULL,0,NULL,0}
- };
-
- /* Stop scanning as soon as a non-option argument is found! */
--static const char *shortopts="+ao:l:n:qQs:TuhV";
-+static const char *shortopts="+o:l:n:qQs:TuhV";
-
- int main(int argc, char *argv[])
- {
-@@ -405,9 +400,6 @@
-
- while ((opt=getopt_long(argc,argv,shortopts,longopts,NULL)) != EOF)
- switch (opt) {
-- case 'a':
-- alternative=1;
-- break;
- case 'h':
- print_help();
- exit(0);
diff --git a/misc/getopt/pkg-plist b/misc/getopt/pkg-plist
index 6f935e6d168a..bf80ae576161 100644
--- a/misc/getopt/pkg-plist
+++ b/misc/getopt/pkg-plist
@@ -1,13 +1,29 @@
-@comment $Id$
bin/getopt
%%PORTDOCS%%%%DOCSDIR%%/Changelog
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+share/locale/ca/LC_MESSAGES/getopt.mo
share/locale/cs/LC_MESSAGES/getopt.mo
+share/locale/da/LC_MESSAGES/getopt.mo
share/locale/de/LC_MESSAGES/getopt.mo
share/locale/es/LC_MESSAGES/getopt.mo
+share/locale/et/LC_MESSAGES/getopt.mo
+share/locale/eu/LC_MESSAGES/getopt.mo
+share/locale/fi/LC_MESSAGES/getopt.mo
share/locale/fr/LC_MESSAGES/getopt.mo
+share/locale/gl/LC_MESSAGES/getopt.mo
+share/locale/hu/LC_MESSAGES/getopt.mo
+share/locale/id/LC_MESSAGES/getopt.mo
share/locale/it/LC_MESSAGES/getopt.mo
share/locale/ja/LC_MESSAGES/getopt.mo
share/locale/nl/LC_MESSAGES/getopt.mo
+share/locale/pl/LC_MESSAGES/getopt.mo
share/locale/pt_BR/LC_MESSAGES/getopt.mo
+share/locale/ru/LC_MESSAGES/getopt.mo
+share/locale/sl/LC_MESSAGES/getopt.mo
+share/locale/sv/LC_MESSAGES/getopt.mo
+share/locale/tr/LC_MESSAGES/getopt.mo
+share/locale/uk/LC_MESSAGES/getopt.mo
+share/locale/vi/LC_MESSAGES/getopt.mo
+share/locale/zh_CN/LC_MESSAGES/getopt.mo
+share/locale/zh_TW/LC_MESSAGES/getopt.mo