aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2016-06-09 19:50:40 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2016-06-09 19:50:40 +0000
commit8070996ff0fb060c9c690e4b3be5e91df8dcad59 (patch)
tree6ff651ecb1830bbac7d040071f00f03336bec5ff
parentb0a1b69d0c73dd27b058b3178aa2229439822836 (diff)
downloadports-8070996ff0fb060c9c690e4b3be5e91df8dcad59.tar.gz
ports-8070996ff0fb060c9c690e4b3be5e91df8dcad59.zip
[NEW] databases/postgresql-repmgr2: 2.X version of postgresql-repmgr
- postgresql-repmgr will be updated to 3.X branch PR: 201962 Submitted by: olgeni
Notes
Notes: svn path=/head/; revision=416623
-rw-r--r--UPDATING18
-rw-r--r--databases/Makefile1
-rw-r--r--databases/postgresql-repmgr2/Makefile38
-rw-r--r--databases/postgresql-repmgr2/distinfo3
-rw-r--r--databases/postgresql-repmgr2/files/repmgrd.in33
-rw-r--r--databases/postgresql-repmgr2/pkg-descr4
-rw-r--r--databases/postgresql-repmgr2/pkg-plist8
7 files changed, 105 insertions, 0 deletions
diff --git a/UPDATING b/UPDATING
index 18a3cdc862bb..94da1317a157 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,24 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20160610
+ AFFECTS: users of databases/postgresql-repmgr
+ AUTHOR: bofh@FreeBSD.org
+
+ The port has been repocopied to databases/postgresql-repmgr2 and current
+ post has been updated to 3.x series. If anyone is still looking forward
+ to use the 2.x please upgrade as following.
+
+ # portmaster -o databases/postgresql-repmgr2 databases/postgresql-repmgr
+ or
+ # portupgrade -o databases/postgresql-repmgr2 databases/postgresql-repmgr
+
+ Otherwise if you want to move on with 3.x series just use
+
+ # portmaster -r databases/postgresql-repmgr
+ or
+ # portupgrade -fr databases/postgresql-repmgr
+
20160605
AFFECTS: Users of www/h2o
AUTHOR: junovitch@FreeBSD.org
diff --git a/databases/Makefile b/databases/Makefile
index 139b7db00932..0608f145b58d 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -653,6 +653,7 @@
SUBDIR += postgresql-plv8js
SUBDIR += postgresql-relay
SUBDIR += postgresql-repmgr
+ SUBDIR += postgresql-repmgr2
SUBDIR += postgresql90-client
SUBDIR += postgresql90-pgtcl
SUBDIR += postgresql90-plperl
diff --git a/databases/postgresql-repmgr2/Makefile b/databases/postgresql-repmgr2/Makefile
new file mode 100644
index 000000000000..fa25728c6ad2
--- /dev/null
+++ b/databases/postgresql-repmgr2/Makefile
@@ -0,0 +1,38 @@
+# Created by: alp@sfedu.ru
+# $FreeBSD$
+
+PORTNAME= postgresql-repmgr
+PORTVERSION= 2.0.3
+CATEGORIES= databases
+MASTER_SITES= http://www.repmgr.org/download/
+DISTNAME= repmgr-${PORTVERSION}
+PKGNAMESUFFIX= 2
+
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= PostgreSQL replication manager
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= rsync:net/rsync
+
+USES+= gettext gmake pgsql:9.2-
+USE_RC_SUBR= repmgrd
+WANT_PGSQL= server
+MAKE_ENV= USE_PGXS=1
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/repmgr ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/repmgrd ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/repmgr.conf.sample ${STAGEDIR}${PREFIX}/etc
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.rst ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/repmgr.sql ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/sql/repmgr_funcs.sql ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/sql/uninstall_repmgr_funcs.sql ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/postgresql
+ ${INSTALL_LIB} ${WRKSRC}/sql/repmgr_funcs.so ${STAGEDIR}${PREFIX}/lib/postgresql
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-repmgr2/distinfo b/databases/postgresql-repmgr2/distinfo
new file mode 100644
index 000000000000..29d26da2538a
--- /dev/null
+++ b/databases/postgresql-repmgr2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465474704
+SHA256 (repmgr-2.0.3.tar.gz) = b257921c74602c733f0ab39012160cbd36c1713f86b8d9ee957042d7ce006f19
+SIZE (repmgr-2.0.3.tar.gz) = 77172
diff --git a/databases/postgresql-repmgr2/files/repmgrd.in b/databases/postgresql-repmgr2/files/repmgrd.in
new file mode 100644
index 000000000000..33f7b336890c
--- /dev/null
+++ b/databases/postgresql-repmgr2/files/repmgrd.in
@@ -0,0 +1,33 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: repmgrd
+# REQUIRE: postgresql
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf to enable this
+# service:
+#
+# repmgrd_enable (bool): Set to YES to enable repmgrd. Default: NO
+#
+# repmgrd_config (path): Default: %%PREFIX%%/etc/repmgr.conf
+#
+
+. /etc/rc.subr
+
+name=repmgrd
+rcvar=repmgrd_enable
+
+load_rc_config $name
+
+: ${repmgrd_enable:="NO"}
+: ${repmgrd_config="%%PREFIX%%/etc/repmgr.conf"}
+
+command=%%PREFIX%%/sbin/${name}
+pidfile=/var/run/${name}.pid
+
+command_args="-p $pidfile -f $repmgrd_config"
+
+run_rc_command "$1"
+
diff --git a/databases/postgresql-repmgr2/pkg-descr b/databases/postgresql-repmgr2/pkg-descr
new file mode 100644
index 000000000000..a45d06d0f05f
--- /dev/null
+++ b/databases/postgresql-repmgr2/pkg-descr
@@ -0,0 +1,4 @@
+repmgr allows you to monitor and manage your replicated PostgreSQL
+databases as a single cluster.
+
+WWW: http://projects.2ndquadrant.com/repmgr
diff --git a/databases/postgresql-repmgr2/pkg-plist b/databases/postgresql-repmgr2/pkg-plist
new file mode 100644
index 000000000000..b3383bae623e
--- /dev/null
+++ b/databases/postgresql-repmgr2/pkg-plist
@@ -0,0 +1,8 @@
+bin/repmgr
+@sample etc/repmgr.conf.sample
+sbin/repmgrd
+lib/postgresql/repmgr_funcs.so
+%%PORTDOCS%%%%DOCSDIR%%/README.rst
+%%DATADIR%%/repmgr.sql
+%%DATADIR%%/repmgr_funcs.sql
+%%DATADIR%%/uninstall_repmgr_funcs.sql