aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-10-26 18:03:43 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-10-26 18:03:43 +0000
commit80c62c16c1ab2af44139d656a0fb028eae1abbcd (patch)
treed96ddd862124b516951215f7c0fb373cf3d8b7a1
parente0aec28ab0105fc66d5534cdeebae2ba6565af3c (diff)
downloadports-80c62c16c1ab2af44139d656a0fb028eae1abbcd.tar.gz
ports-80c62c16c1ab2af44139d656a0fb028eae1abbcd.zip
Notes
-rw-r--r--net-p2p/gtorrentviewer/Makefile15
-rw-r--r--net-p2p/gtorrentviewer/distinfo4
-rw-r--r--net-p2p/gtorrentviewer/pkg-plist2
-rw-r--r--net/gtorrentviewer/Makefile15
-rw-r--r--net/gtorrentviewer/distinfo4
-rw-r--r--net/gtorrentviewer/pkg-plist2
6 files changed, 20 insertions, 22 deletions
diff --git a/net-p2p/gtorrentviewer/Makefile b/net-p2p/gtorrentviewer/Makefile
index ec30780bbf76..1af4012cc1cd 100644
--- a/net-p2p/gtorrentviewer/Makefile
+++ b/net-p2p/gtorrentviewer/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gtorrentviewer
-PORTVERSION= 0.2a
+PORTVERSION= 0.2b
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,22 +18,19 @@ COMMENT= GTK+2 viewer and editor for BitTorrent meta files
LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
USE_GNOME= gtk20 gnomehier
+USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
USE_GETOPT_LONG=yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-pixmapsdir=${PREFIX}/share/gnome/pixmaps \
+ --with-desktopdir=${PREFIX}/share/gnome/applications
MAN1= gtorrentviewer.1
DOCS= AUTHORS COPYING ChangeLog README
-post-patch:
- @${REINPLACE_CMD} -e 's|[(]datadir[)]/applications|(prefix)/share/gnome/applications|g' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|[(]datadir[)]/pixmaps|(prefix)/share/gnome/pixmaps|g' \
- ${WRKSRC}/pixmaps/Makefile.in
- @${REINPLACE_CMD} -e 's|SYSTEM_PIXMAPS_DIR|PIXMAPS_DIR|g' \
- ${WRKSRC}/src/mainwindow.h
-
.ifndef (NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
diff --git a/net-p2p/gtorrentviewer/distinfo b/net-p2p/gtorrentviewer/distinfo
index a6b1d1106a46..d854b764495f 100644
--- a/net-p2p/gtorrentviewer/distinfo
+++ b/net-p2p/gtorrentviewer/distinfo
@@ -1,2 +1,2 @@
-MD5 (GTorrentViewer-0.2a.tar.gz) = 7d0e33e184d3c3c14e1942d38c1cbb68
-SIZE (GTorrentViewer-0.2a.tar.gz) = 213301
+MD5 (GTorrentViewer-0.2b.tar.gz) = c29058a09f26693863404ecdb2580770
+SIZE (GTorrentViewer-0.2b.tar.gz) = 247584
diff --git a/net-p2p/gtorrentviewer/pkg-plist b/net-p2p/gtorrentviewer/pkg-plist
index 10a13f4299b1..d09d2ed6ce57 100644
--- a/net-p2p/gtorrentviewer/pkg-plist
+++ b/net-p2p/gtorrentviewer/pkg-plist
@@ -5,10 +5,12 @@ share/GTorrentViewer/pixmaps/dictionary.png
share/GTorrentViewer/pixmaps/error.png
share/GTorrentViewer/pixmaps/gtorrentviewer.png
share/GTorrentViewer/pixmaps/gtorrentviewer.xpm
+share/GTorrentViewer/pixmaps/info.png
share/GTorrentViewer/pixmaps/integer.png
share/GTorrentViewer/pixmaps/list.png
share/GTorrentViewer/pixmaps/ok.png
share/GTorrentViewer/pixmaps/string.png
+share/GTorrentViewer/pixmaps/unknown.png
share/GTorrentViewer/pixmaps/warning.png
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
diff --git a/net/gtorrentviewer/Makefile b/net/gtorrentviewer/Makefile
index ec30780bbf76..1af4012cc1cd 100644
--- a/net/gtorrentviewer/Makefile
+++ b/net/gtorrentviewer/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gtorrentviewer
-PORTVERSION= 0.2a
+PORTVERSION= 0.2b
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,22 +18,19 @@ COMMENT= GTK+2 viewer and editor for BitTorrent meta files
LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
USE_GNOME= gtk20 gnomehier
+USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
USE_GETOPT_LONG=yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-pixmapsdir=${PREFIX}/share/gnome/pixmaps \
+ --with-desktopdir=${PREFIX}/share/gnome/applications
MAN1= gtorrentviewer.1
DOCS= AUTHORS COPYING ChangeLog README
-post-patch:
- @${REINPLACE_CMD} -e 's|[(]datadir[)]/applications|(prefix)/share/gnome/applications|g' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|[(]datadir[)]/pixmaps|(prefix)/share/gnome/pixmaps|g' \
- ${WRKSRC}/pixmaps/Makefile.in
- @${REINPLACE_CMD} -e 's|SYSTEM_PIXMAPS_DIR|PIXMAPS_DIR|g' \
- ${WRKSRC}/src/mainwindow.h
-
.ifndef (NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
diff --git a/net/gtorrentviewer/distinfo b/net/gtorrentviewer/distinfo
index a6b1d1106a46..d854b764495f 100644
--- a/net/gtorrentviewer/distinfo
+++ b/net/gtorrentviewer/distinfo
@@ -1,2 +1,2 @@
-MD5 (GTorrentViewer-0.2a.tar.gz) = 7d0e33e184d3c3c14e1942d38c1cbb68
-SIZE (GTorrentViewer-0.2a.tar.gz) = 213301
+MD5 (GTorrentViewer-0.2b.tar.gz) = c29058a09f26693863404ecdb2580770
+SIZE (GTorrentViewer-0.2b.tar.gz) = 247584
diff --git a/net/gtorrentviewer/pkg-plist b/net/gtorrentviewer/pkg-plist
index 10a13f4299b1..d09d2ed6ce57 100644
--- a/net/gtorrentviewer/pkg-plist
+++ b/net/gtorrentviewer/pkg-plist
@@ -5,10 +5,12 @@ share/GTorrentViewer/pixmaps/dictionary.png
share/GTorrentViewer/pixmaps/error.png
share/GTorrentViewer/pixmaps/gtorrentviewer.png
share/GTorrentViewer/pixmaps/gtorrentviewer.xpm
+share/GTorrentViewer/pixmaps/info.png
share/GTorrentViewer/pixmaps/integer.png
share/GTorrentViewer/pixmaps/list.png
share/GTorrentViewer/pixmaps/ok.png
share/GTorrentViewer/pixmaps/string.png
+share/GTorrentViewer/pixmaps/unknown.png
share/GTorrentViewer/pixmaps/warning.png
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING