aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-08-09 14:29:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-08-09 14:29:13 +0000
commit81324366be728872aa7f35e233f093bdb7ae4e1d (patch)
tree7978cfb28e8a9f1e503f75b907454a636a3460ac
parent7334d0b764896320b5efe5d0bb75effec75fd39d (diff)
downloadports-81324366be728872aa7f35e233f093bdb7ae4e1d.tar.gz
ports-81324366be728872aa7f35e233f093bdb7ae4e1d.zip
Notes
-rw-r--r--converters/pecl-igbinary/Makefile3
-rw-r--r--devel/pecl-msgpack/Makefile3
-rw-r--r--lang/php55/Makefile.ext6
-rw-r--r--lang/php56/Makefile.ext6
-rw-r--r--lang/php70/Makefile.ext6
-rw-r--r--net/php55-soap/Makefile2
-rw-r--r--net/php56-soap/Makefile2
-rw-r--r--net/php70-soap/Makefile2
-rw-r--r--security/php-suhosin/Makefile3
-rw-r--r--textproc/php55-pspell/Makefile2
-rw-r--r--textproc/php56-pspell/Makefile2
-rw-r--r--textproc/php70-pspell/Makefile2
-rw-r--r--www/php55-session/Makefile2
-rw-r--r--www/php56-session/Makefile2
-rw-r--r--www/php70-session/Makefile2
15 files changed, 15 insertions, 30 deletions
diff --git a/converters/pecl-igbinary/Makefile b/converters/pecl-igbinary/Makefile
index 153d3868fe51..6c399d8d2302 100644
--- a/converters/pecl-igbinary/Makefile
+++ b/converters/pecl-igbinary/Makefile
@@ -3,7 +3,7 @@
PORTNAME= igbinary
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= converters
MASTER_SITES= http://pecl.php.net/get/ \
LOCAL/sunpoet
@@ -19,7 +19,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_powerpc64= does not build
IGNORE_WITH_PHP=70
-USE_PHP= session:build
USES= php:ext tar:tgz
.include <bsd.port.mk>
diff --git a/devel/pecl-msgpack/Makefile b/devel/pecl-msgpack/Makefile
index 4e31103d25b5..a5f47f4e6205 100644
--- a/devel/pecl-msgpack/Makefile
+++ b/devel/pecl-msgpack/Makefile
@@ -3,7 +3,7 @@
PORTNAME= msgpack
PORTVERSION= 0.5.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -17,7 +17,6 @@ LICENSE= BSD3CLAUSE
BROKEN_powerpc64= Does not build
USES= php:ext tar:tgz
-USE_PHP= session:build
IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index b834be078ef6..0087da08853b 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -300,9 +300,6 @@ CONFIGURE_ARGS+=--enable-posix
LIB_DEPENDS+= libaspell.so:textproc/aspell
CONFIGURE_ARGS+=--with-pspell=${LOCALBASE}
-
-# Ugly hack to load session before psell to avoid crashes
-USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "readline"
@@ -318,6 +315,7 @@ CONFIGURE_ARGS+=--with-recode=${LOCALBASE}
.if ${PHP_MODNAME} == "session"
CONFIGURE_ARGS+=--enable-session
+PHP_MOD_PRIO= 18
.endif
.if ${PHP_MODNAME} == "shmop"
@@ -349,8 +347,6 @@ CONFIGURE_ARGS+=--enable-soap \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
-
-USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "sockets"
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index 266b508ef208..9957c30b7fbc 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -300,9 +300,6 @@ CONFIGURE_ARGS+=--enable-posix
LIB_DEPENDS+= libaspell.so:textproc/aspell
CONFIGURE_ARGS+=--with-pspell=${LOCALBASE}
-
-# Ugly hack to load session before psell to avoid crashes
-USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "readline"
@@ -318,6 +315,7 @@ CONFIGURE_ARGS+=--with-recode=${LOCALBASE}
.if ${PHP_MODNAME} == "session"
CONFIGURE_ARGS+=--enable-session
+PHP_MOD_PRIO= 18
.endif
.if ${PHP_MODNAME} == "shmop"
@@ -349,8 +347,6 @@ CONFIGURE_ARGS+=--enable-soap \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
-
-USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "sockets"
diff --git a/lang/php70/Makefile.ext b/lang/php70/Makefile.ext
index 51182856614e..3104bd2696e9 100644
--- a/lang/php70/Makefile.ext
+++ b/lang/php70/Makefile.ext
@@ -292,9 +292,6 @@ CONFIGURE_ARGS+=--enable-posix
LIB_DEPENDS+= libaspell.so:textproc/aspell
CONFIGURE_ARGS+=--with-pspell=${LOCALBASE}
-
-# Ugly hack to load session before psell to avoid crashes
-USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "readline"
@@ -310,6 +307,7 @@ CONFIGURE_ARGS+=--with-recode=${LOCALBASE}
.if ${PHP_MODNAME} == "session"
CONFIGURE_ARGS+=--enable-session
+PHP_MOD_PRIO= 18
.endif
.if ${PHP_MODNAME} == "shmop"
@@ -341,8 +339,6 @@ CONFIGURE_ARGS+=--enable-soap \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
-
-USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "sockets"
diff --git a/net/php55-soap/Makefile b/net/php55-soap/Makefile
index 814c3d56f1d5..45655f863432 100644
--- a/net/php55-soap/Makefile
+++ b/net/php55-soap/Makefile
@@ -1,7 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTERDIR= ${.CURDIR}/../../lang/php55
diff --git a/net/php56-soap/Makefile b/net/php56-soap/Makefile
index 15296c87dbe2..c2b2fdb70259 100644
--- a/net/php56-soap/Makefile
+++ b/net/php56-soap/Makefile
@@ -1,7 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTERDIR= ${.CURDIR}/../../lang/php56
diff --git a/net/php70-soap/Makefile b/net/php70-soap/Makefile
index 2010a44c3c82..1d3dbcc241fd 100644
--- a/net/php70-soap/Makefile
+++ b/net/php70-soap/Makefile
@@ -1,7 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTERDIR= ${.CURDIR}/../../lang/php70
diff --git a/security/php-suhosin/Makefile b/security/php-suhosin/Makefile
index ade9e92916f8..3b57512af18d 100644
--- a/security/php-suhosin/Makefile
+++ b/security/php-suhosin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= suhosin
PORTVERSION= 0.9.38
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://download.suhosin.org/
PKGNAMEPREFIX= php-
@@ -18,7 +18,6 @@ BROKEN_powerpc64= Does not build
OPTIONS_DEFINE= EXAMPLES
USES= php:ext
-USE_PHP= session:build
IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --enable-suhosin
diff --git a/textproc/php55-pspell/Makefile b/textproc/php55-pspell/Makefile
index 8e4516afa120..012cdb56138b 100644
--- a/textproc/php55-pspell/Makefile
+++ b/textproc/php55-pspell/Makefile
@@ -1,7 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTERDIR= ${.CURDIR}/../../lang/php55
diff --git a/textproc/php56-pspell/Makefile b/textproc/php56-pspell/Makefile
index b5b268b9f740..4a3af2cd29c2 100644
--- a/textproc/php56-pspell/Makefile
+++ b/textproc/php56-pspell/Makefile
@@ -1,7 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTERDIR= ${.CURDIR}/../../lang/php56
diff --git a/textproc/php70-pspell/Makefile b/textproc/php70-pspell/Makefile
index 14b8abaa17b3..78b1f3da9655 100644
--- a/textproc/php70-pspell/Makefile
+++ b/textproc/php70-pspell/Makefile
@@ -1,7 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTERDIR= ${.CURDIR}/../../lang/php70
diff --git a/www/php55-session/Makefile b/www/php55-session/Makefile
index 7ac4188d1273..d8877fafbeee 100644
--- a/www/php55-session/Makefile
+++ b/www/php55-session/Makefile
@@ -1,7 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTERDIR= ${.CURDIR}/../../lang/php55
diff --git a/www/php56-session/Makefile b/www/php56-session/Makefile
index d4e611efb9a3..58343f11a0a6 100644
--- a/www/php56-session/Makefile
+++ b/www/php56-session/Makefile
@@ -1,7 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTERDIR= ${.CURDIR}/../../lang/php56
diff --git a/www/php70-session/Makefile b/www/php70-session/Makefile
index d445ec8d63c2..e291f0f4cf37 100644
--- a/www/php70-session/Makefile
+++ b/www/php70-session/Makefile
@@ -1,7 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTERDIR= ${.CURDIR}/../../lang/php70