aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-07-11 19:15:34 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-07-11 19:15:34 +0000
commit81344b78c574faa339551308efbf88521d729ada (patch)
treef65b0e9bcb578ece918d21f6f3ebda2fa1fa746d
parent70c1a0c1890eb154502c3b6f66fbc74e603dc4c9 (diff)
downloadports-81344b78c574faa339551308efbf88521d729ada.tar.gz
ports-81344b78c574faa339551308efbf88521d729ada.zip
Notes
-rw-r--r--security/unicornscan/Makefile42
-rw-r--r--security/unicornscan/pkg-plist1
2 files changed, 19 insertions, 24 deletions
diff --git a/security/unicornscan/Makefile b/security/unicornscan/Makefile
index 9fd013029026..0d38ad430049 100644
--- a/security/unicornscan/Makefile
+++ b/security/unicornscan/Makefile
@@ -7,12 +7,12 @@ PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= SF/osace/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Asynchronous TCP and UDP port scanner
LICENSE= GPLv2
-LIB_DEPENDS= net:${PORTSDIR}/net/libnet
+LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
USES= gmake
MAKE_ENV= LIBNET_CONFIG="${LIBNET_CONFIG}"
@@ -21,9 +21,6 @@ LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
SUB_FILES= pkg-message
-MAN1= unicornscan.1
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|-lnet|`${LIBNET_CONFIG} --libs`|' \
${WRKSRC}/src/scan_progs/Makefile ${WRKSRC}/src/tools/Makefile
@@ -34,40 +31,37 @@ post-patch:
${WRKSRC}/src/unilib/tsc.c
do-install:
- @${MKDIR} ${PREFIX}/etc/unicornscan
- @${MKDIR} ${PREFIX}/libexec/unicornscan/modules
- @${MKDIR} ${PREFIX}/share/unicornscan
- @${MKDIR} ${PREFIX}/var/unicornscan
- ${INSTALL_PROGRAM} ${WRKSRC}/src/unicornscan ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/src/tools/fantaip ${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/unicornscan
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/unicornscan/modules
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/unicornscan
+ @${MKDIR} ${STAGEDIR}${PREFIX}/var/unicornscan
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/unicornscan ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/tools/fantaip ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/src/scan_progs/unisend \
- ${PREFIX}/libexec/unicornscan
+ ${STAGEDIR}${PREFIX}/libexec/unicornscan
${INSTALL_PROGRAM} ${WRKSRC}/src/scan_progs/unilisten \
- ${PREFIX}/libexec/unicornscan
+ ${STAGEDIR}${PREFIX}/libexec/unicornscan
for confs in ${WRKSRC}/fconf/*.conf; do \
- ${INSTALL_DATA} $$confs ${PREFIX}/etc/unicornscan/`basename $$confs`.sample ; \
+ ${INSTALL_DATA} $$confs ${STAGEDIR}${PREFIX}/etc/unicornscan/`basename $$confs`.sample ; \
done
${INSTALL_DATA} ${WRKSRC}/fconf/port-numbers \
- ${PREFIX}/share/unicornscan
+ ${STAGEDIR}${PREFIX}/share/unicornscan
for mods in ${WRKSRC}/src/payload_modules/*.so; do \
- ${INSTALL_PROGRAM} $$mods ${PREFIX}/libexec/unicornscan/modules/ ; \
+ ${INSTALL_PROGRAM} $$mods ${STAGEDIR}${PREFIX}/libexec/unicornscan/modules/ ; \
done
for mods in ${WRKSRC}/src/report_modules/shlibs/*.so; do \
- ${INSTALL_PROGRAM} $$mods ${PREFIX}/libexec/unicornscan/modules/ ; \
+ ${INSTALL_PROGRAM} $$mods ${STAGEDIR}${PREFIX}/libexec/unicornscan/modules/ ; \
done
for pofs in p0f.fp p0fa.fp p0fr.fp; do \
- ${INSTALL_DATA} ${WRKSRC}/src/report_modules/p0f/$$pofs ${PREFIX}/share/unicornscan/ ; \
+ ${INSTALL_DATA} ${WRKSRC}/src/report_modules/p0f/$$pofs ${STAGEDIR}${PREFIX}/share/unicornscan/ ; \
done
${INSTALL_PROGRAM} ${WRKSRC}/src/report_modules/shlibs/libp0f.so \
- ${PREFIX}/libexec/unicornscan/modules
- ${INSTALL_MAN} ${WRKSRC}/docs/unicornscan.1 ${MANPREFIX}/man/man1
+ ${STAGEDIR}${PREFIX}/libexec/unicornscan/modules
+ ${INSTALL_MAN} ${WRKSRC}/docs/unicornscan.1 ${STAGEDIR}${MANPREFIX}/man/man1
# XXX: shouldn't these files below be installed as PORTDOCS?
for files in README misc/UDP_PAYLOADS_NEEDED \
TODO_BUGSTOFIX README.database; do \
- ${INSTALL_DATA} ${WRKSRC}/$$files ${MANPREFIX}/share/unicornscan/ ; \
+ ${INSTALL_DATA} ${WRKSRC}/$$files ${STAGEDIR}${PREFIX}/share/unicornscan/ ; \
done
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
.include <bsd.port.mk>
diff --git a/security/unicornscan/pkg-plist b/security/unicornscan/pkg-plist
index c0a9e24a93da..fcf5fbe9af50 100644
--- a/security/unicornscan/pkg-plist
+++ b/security/unicornscan/pkg-plist
@@ -11,6 +11,7 @@ libexec/unicornscan/modules/sip.so
libexec/unicornscan/modules/upnp.so
libexec/unicornscan/unilisten
libexec/unicornscan/unisend
+man/man1/unicornscan.1.gz
share/unicornscan/README
share/unicornscan/README.database
share/unicornscan/TODO_BUGSTOFIX