aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2017-09-19 23:45:59 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2017-09-19 23:45:59 +0000
commit815b5103bcef8d8290bc4a700973b33b2558ba05 (patch)
tree2886742a4b851254d2f243c10cca738ecde89473
parent058c493f3e0b96b807117728c0adefd00e8d1d19 (diff)
downloadports-815b5103bcef8d8290bc4a700973b33b2558ba05.tar.gz
ports-815b5103bcef8d8290bc4a700973b33b2558ba05.zip
Notes
-rw-r--r--graphics/libfreehand/Makefile14
-rw-r--r--graphics/libfreehand/distinfo5
-rw-r--r--graphics/libfreehand/pkg-descr2
-rw-r--r--graphics/libfreehand/pkg-plist2
4 files changed, 13 insertions, 10 deletions
diff --git a/graphics/libfreehand/Makefile b/graphics/libfreehand/Makefile
index bae7c61b3ad7..534380ecb569 100644
--- a/graphics/libfreehand/Makefile
+++ b/graphics/libfreehand/Makefile
@@ -1,18 +1,19 @@
# $FreeBSD$
PORTNAME= libfreehand
-PORTVERSION= 0.1.1
-PORTREVISION= 7
+PORTVERSION= 0.1.2
CATEGORIES= graphics
MASTER_SITES= LODEV
MAINTAINER= office@FreeBSD.org
-COMMENT= Library providing ability to interpret and import Adobe/Macromedia drawings
+COMMENT= Library for interpreting and importing Adobe/Macromedia drawings
-LICENSE= LGPL21 MPL GPLv2
-LICENSE_COMB= dual
+LICENSE= MPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= icu-config:devel/icu
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/cstdint.hpp:devel/boost-libs \
+ cppunit-config:devel/cppunit \
+ icu-config:devel/icu
LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
librevenge-0.0.so:textproc/librevenge
@@ -21,6 +22,7 @@ USES= compiler:c++11-lang gperf perl5 libtool pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
USE_PERL5= build
CONFIGURE_ARGS= --disable-werror --without-docs
+CPPFLAGS+= -I ${LOCALBASE}/include
INSTALL_TARGET= install-strip
.include <bsd.port.mk>
diff --git a/graphics/libfreehand/distinfo b/graphics/libfreehand/distinfo
index 53ca366a2cd7..d2655de07a75 100644
--- a/graphics/libfreehand/distinfo
+++ b/graphics/libfreehand/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libfreehand-0.1.1.tar.xz) = ec6676d0c63f7feac7801a1fe18dd7abe9044b39c3882fc99b9afef39bdf1d30
-SIZE (libfreehand-0.1.1.tar.xz) = 492916
+TIMESTAMP = 1505860846
+SHA256 (libfreehand-0.1.2.tar.xz) = 0e422d1564a6dbf22a9af598535425271e583514c0f7ba7d9091676420de34ac
+SIZE (libfreehand-0.1.2.tar.xz) = 516132
diff --git a/graphics/libfreehand/pkg-descr b/graphics/libfreehand/pkg-descr
index 5e7f9e2d86f5..ec02e8155798 100644
--- a/graphics/libfreehand/pkg-descr
+++ b/graphics/libfreehand/pkg-descr
@@ -1,4 +1,4 @@
Libfreehand is library providing ability to interpret and import
Adobe/Macromedia drawings into various applications
-WWW: http://www.freedesktop.org/wiki/Software/libfreehand/
+WWW: https://wiki.documentfoundation.org/DLP/Libraries/libfreehand
diff --git a/graphics/libfreehand/pkg-plist b/graphics/libfreehand/pkg-plist
index 93eb019ccb1b..905f68ff2ab9 100644
--- a/graphics/libfreehand/pkg-plist
+++ b/graphics/libfreehand/pkg-plist
@@ -5,5 +5,5 @@ include/libfreehand-0.1/libfreehand/FreeHandDocument.h
include/libfreehand-0.1/libfreehand/libfreehand.h
lib/libfreehand-0.1.so
lib/libfreehand-0.1.so.1
-lib/libfreehand-0.1.so.1.0.1
+lib/libfreehand-0.1.so.1.0.2
libdata/pkgconfig/libfreehand-0.1.pc