aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-07-08 05:35:16 +0000
committerJohn Marino <marino@FreeBSD.org>2015-07-08 05:35:16 +0000
commit81d07266e4ff734899799a74ca5e78078b47a6ad (patch)
tree3e3e23658cb55e03d24d30ceb3ee5b4839bbd3f4
parent8c4803560d1f268a7f83c2d7e205542bacbfd1c1 (diff)
downloadports-81d07266e4ff734899799a74ca5e78078b47a6ad.tar.gz
ports-81d07266e4ff734899799a74ca5e78078b47a6ad.zip
Notes
-rw-r--r--graphics/copperspice/Makefile4
-rw-r--r--graphics/copperspice/distinfo4
-rw-r--r--graphics/copperspice/files/patch-src_3rdparty_javascriptcore_JavaScriptCore_wtf_TypeTraits.h71
-rw-r--r--graphics/copperspice/files/patch-src_3rdparty_webkit_Source_JavaScriptCore_wtf_TypeTraits.h71
4 files changed, 3 insertions, 147 deletions
diff --git a/graphics/copperspice/Makefile b/graphics/copperspice/Makefile
index 5c9198dbc4c0..e82ab33e61e5 100644
--- a/graphics/copperspice/Makefile
+++ b/graphics/copperspice/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= copperspice
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= graphics
MASTER_SITES= http://download.copperspice.com/copperspice/source/
@@ -11,8 +11,6 @@ COMMENT= Modern cross-platform C++ GUI library (derived from Qt 4.8)
LICENSE= LGPL21
-BROKEN_FreeBSD= F10 q_emitSignals unable to register method pointer
-
BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
LIB_DEPENDS= libaudio.so:${PORTSDIR}/audio/nas \
libfreetype.so:${PORTSDIR}/print/freetype2
diff --git a/graphics/copperspice/distinfo b/graphics/copperspice/distinfo
index f63868317131..bd8eeaaba30d 100644
--- a/graphics/copperspice/distinfo
+++ b/graphics/copperspice/distinfo
@@ -1,2 +1,2 @@
-SHA256 (copperspice-1.0.3.tar.bz2) = 274dd9072bb7d53e6367b472c0a9f4a56feb076442c9ff5ae2e7a4c74a399889
-SIZE (copperspice-1.0.3.tar.bz2) = 15341523
+SHA256 (copperspice-1.0.4.tar.bz2) = b4ce66b7a80dfc15ca94abb90da7d4bbb18f4884f3c5d89c1a4425a9c675bfc5
+SIZE (copperspice-1.0.4.tar.bz2) = 15348145
diff --git a/graphics/copperspice/files/patch-src_3rdparty_javascriptcore_JavaScriptCore_wtf_TypeTraits.h b/graphics/copperspice/files/patch-src_3rdparty_javascriptcore_JavaScriptCore_wtf_TypeTraits.h
deleted file mode 100644
index 156d97c3adb6..000000000000
--- a/graphics/copperspice/files/patch-src_3rdparty_javascriptcore_JavaScriptCore_wtf_TypeTraits.h
+++ /dev/null
@@ -1,71 +0,0 @@
---- src/3rdparty/javascriptcore/JavaScriptCore/wtf/TypeTraits.h.orig 2015-04-23 19:00:28 UTC
-+++ src/3rdparty/javascriptcore/JavaScriptCore/wtf/TypeTraits.h
-@@ -164,60 +164,15 @@ namespace WTF {
- typedef T Type;
- };
-
-+ template<typename T>
-+ struct HasTrivialConstructor :
-+ public std::is_trivially_constructible<T> {
-+ };
-
--} // namespace WTF
--
--
--// copperspice solution for type traits (used in javascript and webkit)
--class cs_alternate{};
--
--class cs_preferred : public cs_alternate{};
--
--namespace std{
-- template<class> struct is_trivially_constructible;
-- template<class> struct has_trivial_default_constructor;
--
-- template<class> struct is_trivially_destructible;
-- template<class> struct has_trivial_destructor;
--}
--
--namespace WTF {
--
--// constructor
--template<typename T>
--decltype(std::is_trivially_constructible<T>::value, std::is_trivially_constructible<T>{})
-- cs_check_constructor(const cs_preferred &)
--{
--}
--
--template<typename T>
--decltype(std::has_trivial_default_constructor<T>::value, std::has_trivial_default_constructor<T>{})
-- cs_check_constructor(const cs_alternate &)
--{
--}
--
--template<typename T>
--struct HasTrivialConstructor : public decltype(cs_check_constructor<T>(cs_preferred{}))
--{
--};
--
--// destructor
--template<typename T>
--decltype(std::is_trivially_destructible<T>::value, std::is_trivially_destructible<T>{})
-- cs_check_destructor(const cs_preferred &)
--{
--}
--
--template<typename T>
--decltype(std::has_trivial_destructor<T>::value, std::has_trivial_destructor<T>{})
-- cs_check_destructor(const cs_alternate &)
--{
--}
--
--template<typename T>
--struct HasTrivialDestructor : public decltype(cs_check_destructor<T>(cs_preferred{}))
--{
--};
-+ template<typename T>
-+ struct HasTrivialDestructor :
-+ public std::is_trivially_destructible<T> {
-+ };
-
- } // namespace WTF
-
diff --git a/graphics/copperspice/files/patch-src_3rdparty_webkit_Source_JavaScriptCore_wtf_TypeTraits.h b/graphics/copperspice/files/patch-src_3rdparty_webkit_Source_JavaScriptCore_wtf_TypeTraits.h
deleted file mode 100644
index ee14ef34259e..000000000000
--- a/graphics/copperspice/files/patch-src_3rdparty_webkit_Source_JavaScriptCore_wtf_TypeTraits.h
+++ /dev/null
@@ -1,71 +0,0 @@
---- src/3rdparty/webkit/Source/JavaScriptCore/wtf/TypeTraits.h.orig 2015-04-23 19:00:48 UTC
-+++ src/3rdparty/webkit/Source/JavaScriptCore/wtf/TypeTraits.h
-@@ -176,60 +176,15 @@ namespace WTF {
- typedef T Type;
- };
-
-+ template<typename T>
-+ struct HasTrivialConstructor :
-+ public std::is_trivially_constructible<T> {
-+ };
-
--} // namespace WTF
--
--
--// copperspice solution for type traits (used in javascript and webkit)
--class cs_alternate{};
--
--class cs_preferred : public cs_alternate{};
--
--namespace std{
-- template<class> struct is_trivially_constructible;
-- template<class> struct has_trivial_default_constructor;
--
-- template<class> struct is_trivially_destructible;
-- template<class> struct has_trivial_destructor;
--}
--
--namespace WTF {
--
--// constructor
--template<typename T>
--decltype(std::is_trivially_constructible<T>::value, std::is_trivially_constructible<T>{})
-- cs_check_constructor(const cs_preferred &)
--{
--}
--
--template<typename T>
--decltype(std::has_trivial_default_constructor<T>::value, std::has_trivial_default_constructor<T>{})
-- cs_check_constructor(const cs_alternate &)
--{
--}
--
--template<typename T>
--struct HasTrivialConstructor : public decltype(cs_check_constructor<T>(cs_preferred{}))
--{
--};
--
--// destructor
--template<typename T>
--decltype(std::is_trivially_destructible<T>::value, std::is_trivially_destructible<T>{})
-- cs_check_destructor(const cs_preferred &)
--{
--}
--
--template<typename T>
--decltype(std::has_trivial_destructor<T>::value, std::has_trivial_destructor<T>{})
-- cs_check_destructor(const cs_alternate &)
--{
--}
--
--template<typename T>
--struct HasTrivialDestructor : public decltype(cs_check_destructor<T>(cs_preferred{}))
--{
--};
-+ template<typename T>
-+ struct HasTrivialDestructor :
-+ public std::is_trivially_destructible<T> {
-+ };
-
- } // namespace WTF
-