aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-02-04 22:33:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-02-04 22:33:06 +0000
commit820c075bc0dada17b8f0e996cce0f0b4281b437c (patch)
tree52b386ddcdd02d6c9e34af924d94eddd6822b1dd
parent9e9a0d0a1f687066860f39365f4a5de1c2ba5fee (diff)
downloadports-820c075bc0dada17b8f0e996cce0f0b4281b437c.tar.gz
ports-820c075bc0dada17b8f0e996cce0f0b4281b437c.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-sounddevice/Makefile29
-rw-r--r--audio/py-sounddevice/distinfo3
-rw-r--r--audio/py-sounddevice/pkg-descr7
4 files changed, 40 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 2280a053f1ac..3b4fbdcf6102 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -680,6 +680,7 @@
SUBDIR += py-pysndfile
SUBDIR += py-shout
SUBDIR += py-soundcloud
+ SUBDIR += py-sounddevice
SUBDIR += py-soundscrape
SUBDIR += py-speechrecognition
SUBDIR += py-speex
diff --git a/audio/py-sounddevice/Makefile b/audio/py-sounddevice/Makefile
new file mode 100644
index 000000000000..64f8c30e3e08
--- /dev/null
+++ b/audio/py-sounddevice/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= sounddevice
+PORTVERSION= 0.3.10
+CATEGORIES= audio python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Play and record sound through OSS in python programs
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${FLAVOR} \
+ ${PYNUMPY} \
+ portaudio>0:audio/portaudio
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+post-install: # workaround for https://github.com/spatialaudio/python-sounddevice/issues/116
+ @${GREP} "/sounddevice\." < ${_PYTHONPKGLIST} \
+ | ${SED} -e 's|/sounddevice\.|/_sounddevice.|' \
+ >> ${_PYTHONPKGLIST}
+
+.include <bsd.port.mk>
diff --git a/audio/py-sounddevice/distinfo b/audio/py-sounddevice/distinfo
new file mode 100644
index 000000000000..9ac13a53dd51
--- /dev/null
+++ b/audio/py-sounddevice/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1516010801
+SHA256 (sounddevice-0.3.10.tar.gz) = 6a972db105b11a570b454c0b92b5d37ead46829ce71a278b148ec6479209ad9f
+SIZE (sounddevice-0.3.10.tar.gz) = 46411
diff --git a/audio/py-sounddevice/pkg-descr b/audio/py-sounddevice/pkg-descr
new file mode 100644
index 000000000000..63b76dd1b733
--- /dev/null
+++ b/audio/py-sounddevice/pkg-descr
@@ -0,0 +1,7 @@
+sounddevice provides bindings for the PortAudio library and a few convenience
+functions to play and record NumPy arrays containing audio signals.
+
+It is primarily intended for use in signal analysis software.
+PortAudio plays and records sound through the OSS audio interface.
+
+WWW: https://github.com/spatialaudio/python-sounddevice