aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-06-17 04:39:51 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-06-17 04:39:51 +0000
commit828b05b7edef971b1a49ac2bf20b0b1b4e71165f (patch)
tree6d2835947307197a89261a15b1853e7a9f6c6e1e
parent2335e2f0e60f67bb233390810490b7c23315f9c4 (diff)
downloadports-828b05b7edef971b1a49ac2bf20b0b1b4e71165f.tar.gz
ports-828b05b7edef971b1a49ac2bf20b0b1b4e71165f.zip
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/cglm/Makefile25
-rw-r--r--math/cglm/distinfo3
-rw-r--r--math/cglm/pkg-descr9
-rw-r--r--math/cglm/pkg-plist91
5 files changed, 129 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index fe7afc9451f4..5a1b9befc753 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -177,6 +177,7 @@
SUBDIR += ceres-solver
SUBDIR += cgal
SUBDIR += cgl
+ SUBDIR += cglm
SUBDIR += chaco
SUBDIR += chryzodus
SUBDIR += clasp
diff --git a/math/cglm/Makefile b/math/cglm/Makefile
new file mode 100644
index 000000000000..52e3df4718d6
--- /dev/null
+++ b/math/cglm/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= cglm
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.7.6
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Highly optimized graphics math (glm) for C
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= recp
+USE_LDCONFIG= yes
+
+do-test:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DCGLM_USE_TEST:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+.include <bsd.port.mk>
diff --git a/math/cglm/distinfo b/math/cglm/distinfo
new file mode 100644
index 000000000000..9231994915aa
--- /dev/null
+++ b/math/cglm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1592368404
+SHA256 (recp-cglm-v0.7.6_GH0.tar.gz) = 29ff8af4edc03697e36d3e6f99a80b884a80ee09d46055ce45765e5d6b2456d9
+SIZE (recp-cglm-v0.7.6_GH0.tar.gz) = 220522
diff --git a/math/cglm/pkg-descr b/math/cglm/pkg-descr
new file mode 100644
index 000000000000..1eaf169794fe
--- /dev/null
+++ b/math/cglm/pkg-descr
@@ -0,0 +1,9 @@
+cglm is optimized 3D math library written in C99 (compatible with C89).
+It is similar to original glm library except this is mainly for C
+
+This library stores matrices as column-major order but in the future row-major
+is considered to be supported as optional.
+
+Currently only float type is supported for most operations.
+
+WWW: https://github.com/recp/cglm
diff --git a/math/cglm/pkg-plist b/math/cglm/pkg-plist
new file mode 100644
index 000000000000..b00c5797083d
--- /dev/null
+++ b/math/cglm/pkg-plist
@@ -0,0 +1,91 @@
+include/cglm/affine-mat.h
+include/cglm/affine.h
+include/cglm/applesimd.h
+include/cglm/bezier.h
+include/cglm/box.h
+include/cglm/call.h
+include/cglm/call/affine.h
+include/cglm/call/bezier.h
+include/cglm/call/box.h
+include/cglm/call/cam.h
+include/cglm/call/curve.h
+include/cglm/call/ease.h
+include/cglm/call/euler.h
+include/cglm/call/frustum.h
+include/cglm/call/io.h
+include/cglm/call/mat2.h
+include/cglm/call/mat3.h
+include/cglm/call/mat4.h
+include/cglm/call/plane.h
+include/cglm/call/project.h
+include/cglm/call/quat.h
+include/cglm/call/ray.h
+include/cglm/call/sphere.h
+include/cglm/call/vec2.h
+include/cglm/call/vec3.h
+include/cglm/call/vec4.h
+include/cglm/cam.h
+include/cglm/cglm.h
+include/cglm/color.h
+include/cglm/common.h
+include/cglm/curve.h
+include/cglm/ease.h
+include/cglm/euler.h
+include/cglm/frustum.h
+include/cglm/io.h
+include/cglm/mat2.h
+include/cglm/mat3.h
+include/cglm/mat4.h
+include/cglm/plane.h
+include/cglm/project.h
+include/cglm/quat.h
+include/cglm/ray.h
+include/cglm/simd/arm.h
+include/cglm/simd/avx/affine.h
+include/cglm/simd/avx/mat4.h
+include/cglm/simd/intrin.h
+include/cglm/simd/neon/mat4.h
+include/cglm/simd/sse2/affine.h
+include/cglm/simd/sse2/mat2.h
+include/cglm/simd/sse2/mat3.h
+include/cglm/simd/sse2/mat4.h
+include/cglm/simd/sse2/quat.h
+include/cglm/simd/x86.h
+include/cglm/sphere.h
+include/cglm/struct.h
+include/cglm/struct/affine.h
+include/cglm/struct/box.h
+include/cglm/struct/cam.h
+include/cglm/struct/color.h
+include/cglm/struct/curve.h
+include/cglm/struct/euler.h
+include/cglm/struct/frustum.h
+include/cglm/struct/io.h
+include/cglm/struct/mat2.h
+include/cglm/struct/mat3.h
+include/cglm/struct/mat4.h
+include/cglm/struct/plane.h
+include/cglm/struct/project.h
+include/cglm/struct/quat.h
+include/cglm/struct/sphere.h
+include/cglm/struct/vec2-ext.h
+include/cglm/struct/vec2.h
+include/cglm/struct/vec3-ext.h
+include/cglm/struct/vec3.h
+include/cglm/struct/vec4-ext.h
+include/cglm/struct/vec4.h
+include/cglm/types-struct.h
+include/cglm/types.h
+include/cglm/util.h
+include/cglm/vec2-ext.h
+include/cglm/vec2.h
+include/cglm/vec3-ext.h
+include/cglm/vec3.h
+include/cglm/vec4-ext.h
+include/cglm/vec4.h
+include/cglm/version.h
+lib/cglm/cmake/cglm-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cglm/cmake/cglm.cmake
+lib/libcglm.so
+lib/libcglm.so.0
+lib/libcglm.so.0.7.6