aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-02-01 18:51:20 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-02-01 18:51:20 +0000
commit828e9509b7a2ca4c3ee4892682a38bf3471e8191 (patch)
tree321eee644309f086b6ce2b6edd39bdf7366d3b60
parent9cfe421df1fd736ffa1490661e0ff41952f0cccc (diff)
downloadports-828e9509b7a2ca4c3ee4892682a38bf3471e8191.tar.gz
ports-828e9509b7a2ca4c3ee4892682a38bf3471e8191.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gtk-mixer/Makefile27
-rw-r--r--audio/gtk-mixer/distinfo3
-rw-r--r--audio/gtk-mixer/pkg-descr14
4 files changed, 45 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index f0d8c73a2367..c35ffd64fef2 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -315,6 +315,7 @@
SUBDIR += gstreamer1-plugins-wavpack
SUBDIR += gstreamer1-plugins-webrtcdsp
SUBDIR += gtick
+ SUBDIR += gtk-mixer
SUBDIR += gtkguitune
SUBDIR += gtkpod
SUBDIR += gtmixer
diff --git a/audio/gtk-mixer/Makefile b/audio/gtk-mixer/Makefile
new file mode 100644
index 000000000000..518cf5bbb4ef
--- /dev/null
+++ b/audio/gtk-mixer/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= gtk-mixer
+PORTVERSION= 1.0.0
+CATEGORIES= audio
+
+MAINTAINER= rozhuk.im@gmail.com
+COMMENT= GTK based volume control tool
+
+LICENSE= GPLv2
+
+USES= cmake gnome pkgconfig
+USE_GNOME= cairo gdkpixbuf2 gtk30
+USE_GITHUB= yes
+GH_ACCOUNT= rozhuk-im
+
+PLIST_FILES= bin/gtk-mixer \
+ share/pixmaps/gtk-mixer.png
+
+DESKTOP_ENTRIES="GTK-Mixer" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "GTK;AudioVideo;Audio;Mixer;" true
+
+post-install:
+ ${LN} -sf gvolwheel/audio-volume-high.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+.include <bsd.port.mk>
diff --git a/audio/gtk-mixer/distinfo b/audio/gtk-mixer/distinfo
new file mode 100644
index 000000000000..352ffe6cd07d
--- /dev/null
+++ b/audio/gtk-mixer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1612162986
+SHA256 (rozhuk-im-gtk-mixer-1.0.0_GH0.tar.gz) = 184ddcd8b7cfd8deb057746a603aa28cfc826ea24ab015f496ecf79166882e30
+SIZE (rozhuk-im-gtk-mixer-1.0.0_GH0.tar.gz) = 27490
diff --git a/audio/gtk-mixer/pkg-descr b/audio/gtk-mixer/pkg-descr
new file mode 100644
index 000000000000..63889cd44667
--- /dev/null
+++ b/audio/gtk-mixer/pkg-descr
@@ -0,0 +1,14 @@
+GTK-Mixer is GTK based volume control tool ("mixer").
+
+GUI from xfce4-mixer: https://gitlab.xfce.org/apps/xfce4-mixer but
+xfce4 and gstreamer does not used.
+
+Features
+- plugins for support different sound backens
+- change system default sound card
+- set volume per line/channel
+- enable/disable lines (mute/unmute)
+- detect sound cards connect/disconnect
+- detect default sound card change
+
+WWW: https://github.com/rozhuk-im/gtk-mixer