aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2015-02-15 22:30:45 +0000
committerDon Lewis <truckman@FreeBSD.org>2015-02-15 22:30:45 +0000
commit830f77d3d4e98c069acefcbf866b6631cdb7e2f4 (patch)
tree87e5a6150bcd8e3aca62a1de06217842d5ed186d
parentebc2dac2d17d27d6e151ad328d526b6d6ceab4b0 (diff)
downloadports-830f77d3d4e98c069acefcbf866b6631cdb7e2f4.tar.gz
ports-830f77d3d4e98c069acefcbf866b6631cdb7e2f4.zip
Notes
-rw-r--r--editors/openoffice-4/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 24f59a976097..5abcd74a6086 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -91,7 +91,7 @@ USE_XORG= x11 ice xaw xau xext xrender xrandr \
xi xt xcursor xdamage xcomposite xfixes
USE_GL= gl glu
USE_GSTREAMER= yes
-USE_GCC= 4.8
+USE_GCC= yes
USES+= bison desktop-file-utils gmake perl5 pkgconfig python tar:bzip2
USE_PERL5= build
WITHOUT_CPU_CFLAGS= true
@@ -252,6 +252,11 @@ post-patch:
.if defined (USE_GCC)
${REINPLACE_CMD} -e "s+%%RPATH%%+-Wl,-rpath=${_GCC_RUNTIME}+" ${WRKSRC}/solenv/inc/unxfbsd.mk
${REINPLACE_CMD} -e "s+%%RPATH%%+-Wl,-rpath=${_GCC_RUNTIME}+" ${WRKSRC}/solenv/gbuild/platform/freebsd.mk
+ # g++49 -Os sometimes leaves inline class methods undefined
+ if [ ${CXX} = g++49 ]; then \
+ ${REINPLACE_CMD} -e "s/ := -Os/ := -O0/" ${WRKSRC}/solenv/gbuild/platform/freebsd.mk; \
+ ${REINPLACE_CMD} -e "s/=-Os /=-O0 /" ${WRKSRC}/solenv/inc/unxfbsdi.mk; \
+ fi
.else
${REINPLACE_CMD} -e "s+%%RPATH%%++" ${WRKSRC}/solenv/inc/unxfbsd.mk
${REINPLACE_CMD} -e "s+%%RPATH%%++" ${WRKSRC}/solenv/gbuild/platform/freebsd.mk