aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-09 23:10:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-09 23:10:49 +0000
commit83401453e86f526cb858bdb0f5427f6543b6a4bc (patch)
tree168e5b8641ed0d9e6d5ef07ec0a7cbe49ae1d0e9
parent4298e8363103beefacefe919e42f6548ce8082d1 (diff)
downloadports-83401453e86f526cb858bdb0f5427f6543b6a4bc.tar.gz
ports-83401453e86f526cb858bdb0f5427f6543b6a4bc.zip
Notes
-rw-r--r--audio/x42-plugins-lv2/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/audio/x42-plugins-lv2/Makefile b/audio/x42-plugins-lv2/Makefile
index f80fc2a09f8b..c4f89c006e22 100644
--- a/audio/x42-plugins-lv2/Makefile
+++ b/audio/x42-plugins-lv2/Makefile
@@ -41,6 +41,8 @@ OPTIONS_DEFINE_i386= SSE
OPTIONS_DEFAULT_amd64= SSE
OPTIONS_DEFAULT_i386= SSE
+SSE_MAKE_ARGS= PORT_SIMD_FLAGS="-msse -msse2 -mfpmath=sse"
+
post-patch:
@${REINPLACE_CMD} 's| -O3||' \
${WRKSRC}/*.lv2/Makefile
@@ -50,12 +52,7 @@ post-patch:
@${REINPLACE_CMD} 's|$$(mandir)/man1|$$(MANDIR)|' \
${WRKSRC}/sisco.lv2/Makefile
@cd ${WRKSRC} && ${RM} -r convoLV2 && ${MV} convoLV2zita4 convoLV2
-
-post-patch-SSE-off:
- @${REINPLACE_CMD} 's| -msse -msse2 -mfpmath=sse||' \
+ @${REINPLACE_CMD} 's| -msse -msse2 -mfpmath=sse| $$(PORT_SIMD_FLAGS)|' \
${WRKSRC}/*.lv2/Makefile ${WRKSRC}/convoLV2/Makefile
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/convo.lv2/convoLV2.so
-
.include <bsd.port.mk>