aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-26 16:17:52 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-26 16:17:52 +0000
commit839325d812b91c39d42ffe6713a08c972ffd19ac (patch)
tree96b0b35584c1ef0f36fa0e7737b4bda1963b1717
parent4bccb677da92530d6f61f94c9c5a60fa10462a6a (diff)
downloadports-839325d812b91c39d42ffe6713a08c972ffd19ac.tar.gz
ports-839325d812b91c39d42ffe6713a08c972ffd19ac.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/gupnp-ui/Makefile24
-rw-r--r--net/gupnp-ui/distinfo3
-rw-r--r--net/gupnp-ui/pkg-descr3
-rw-r--r--net/gupnp-ui/pkg-plist25
5 files changed, 56 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5258478ce35a..d97f1148fd75 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -205,6 +205,7 @@
SUBDIR += gtic
SUBDIR += gtk-vnc
SUBDIR += gupnp
+ SUBDIR += gupnp-ui
SUBDIR += gutenfetch
SUBDIR += gwhois
SUBDIR += haproxy
diff --git a/net/gupnp-ui/Makefile b/net/gupnp-ui/Makefile
new file mode 100644
index 000000000000..c3b782c86eee
--- /dev/null
+++ b/net/gupnp-ui/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: gupnp-ui
+# Date created: 2009-12-26
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gupnp-ui
+PORTVERSION= 0.1.1
+CATEGORIES= net
+MASTER_SITES= http://www.gupnp.org/sources/${PORTNAME}/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Framework for UPnP devices
+
+LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup \
+ gupnp-1.0:${PORTSDIR}/net/gupnp
+
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack intlhack libglade2 gtk20
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/net/gupnp-ui/distinfo b/net/gupnp-ui/distinfo
new file mode 100644
index 000000000000..d7333f9184b5
--- /dev/null
+++ b/net/gupnp-ui/distinfo
@@ -0,0 +1,3 @@
+MD5 (gupnp-ui-0.1.1.tar.gz) = 5ca6b3f6740d0295066b0b533289aa4c
+SHA256 (gupnp-ui-0.1.1.tar.gz) = 54446978d10507b58bb171671a8fe50cff5a7cf1ad8457bf2b5b45837a7bda38
+SIZE (gupnp-ui-0.1.1.tar.gz) = 362414
diff --git a/net/gupnp-ui/pkg-descr b/net/gupnp-ui/pkg-descr
new file mode 100644
index 000000000000..fb3822e1ff3c
--- /dev/null
+++ b/net/gupnp-ui/pkg-descr
@@ -0,0 +1,3 @@
+GUPnP-UI provides a collection of simple GTK+ widgets on top of GUPnP
+
+WWW: http://www.gupnp.org/
diff --git a/net/gupnp-ui/pkg-plist b/net/gupnp-ui/pkg-plist
new file mode 100644
index 000000000000..6fbddfd9afac
--- /dev/null
+++ b/net/gupnp-ui/pkg-plist
@@ -0,0 +1,25 @@
+include/gupnp-ui-1.0/libgupnp-ui/gupnp-ui-device-store.h
+include/gupnp-ui-1.0/libgupnp-ui/gupnp-ui-device-view.h
+include/gupnp-ui-1.0/libgupnp-ui/gupnp-ui.h
+lib/libgupnp-ui-1.0.a
+lib/libgupnp-ui-1.0.la
+lib/libgupnp-ui-1.0.so
+lib/libgupnp-ui-1.0.so.0
+libdata/pkgconfig/gupnp-ui-1.0.pc
+share/gtk-doc/html/gupnp-ui/GUPnPUIDeviceStore.html
+share/gtk-doc/html/gupnp-ui/GUPnPUIDeviceView.html
+share/gtk-doc/html/gupnp-ui/ch01.html
+share/gtk-doc/html/gupnp-ui/gupnp-ui.devhelp
+share/gtk-doc/html/gupnp-ui/gupnp-ui.devhelp2
+share/gtk-doc/html/gupnp-ui/home.png
+share/gtk-doc/html/gupnp-ui/index.html
+share/gtk-doc/html/gupnp-ui/index.sgml
+share/gtk-doc/html/gupnp-ui/left.png
+share/gtk-doc/html/gupnp-ui/right.png
+share/gtk-doc/html/gupnp-ui/style.css
+share/gtk-doc/html/gupnp-ui/up.png
+@dirrm share/gtk-doc/html/gupnp-ui
+@dirrm share/gtk-doc/html
+@dirrm share/gtk-doc
+@dirrm include/gupnp-ui-1.0/libgupnp-ui
+@dirrm include/gupnp-ui-1.0