aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2010-09-15 14:16:10 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2010-09-15 14:16:10 +0000
commit8682c34ec399b157d2b46f5710eda6da5630c78f (patch)
treec705cb6fed827b19ee380e517d40c97127ae09cd
parentad4553883316386003521895d157343c114bdf9f (diff)
downloadports-8682c34ec399b157d2b46f5710eda6da5630c78f.tar.gz
ports-8682c34ec399b157d2b46f5710eda6da5630c78f.zip
Notes
-rw-r--r--graphics/tumbler/Makefile32
-rw-r--r--graphics/tumbler/distinfo6
-rw-r--r--graphics/tumbler/pkg-plist68
3 files changed, 79 insertions, 27 deletions
diff --git a/graphics/tumbler/Makefile b/graphics/tumbler/Makefile
index c6142f4b5a45..c70c85bdece3 100644
--- a/graphics/tumbler/Makefile
+++ b/graphics/tumbler/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= tumbler
-PORTVERSION= 0.1.1
-PORTREVISION= 3
+PORTVERSION= 0.1.2
CATEGORIES= graphics xfce
-MASTER_SITES= http://archive.xfce.org/src/apps/${PORTNAME}/0.1/
+MASTER_SITES= XFCE
+MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/0.1
MAINTAINER= ashish@FreeBSD.org
COMMENT= D-Bus service for generating thumbnails
@@ -26,7 +26,9 @@ BUILD_DEPENDS= dbus-binding-tool:${PORTSDIR}/devel/dbus-glib \
OPTIONS= GTK2 "Enable GdkPixBuf thumbnailer plugin" On \
JPEG "Enable JPEG thumbnailer plugin with EXIF support" On \
+ FFMPEG "Enable FFMPEG thumbnailer plugin" On \
FREETYPE "Enable Freetype font thumbnailer plugin" On \
+ POPPLER "Enable Poppler PDF/PS thumbnailer plugin" On \
XDG "Enable freedesktop.org cache plugin" On
USE_BZIP2= yes
@@ -37,6 +39,9 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
USE_GETTEXT= yes
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
.include <bsd.port.options.mk>
.if defined(WITH_GTK2)
@@ -59,6 +64,16 @@ CONFIGURE_ARGS+= --disable-jpeg-thumbnailer
PLIST_SUB+= JPEG="@comment "
.endif
+.if defined(WITH_FFMPEG)
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/libffmpegthumbnailer.pc:${PORTSDIR}/multimedia/ffmpegthumbnailer
+LIB_DEPENDS+= ffmpegthumbnailer.4:${PORTSDIR}/multimedia/ffmpegthumbnailer
+PLIST_SUB+= FFMPEG=""
+WITH_PLUGINS= true
+.elif defined(WITHOUT_FFMPEG)
+CONFIGURE_ARGS+= --disable-ffmpeg-thumbnailer
+PLIST_SUB+= FFMPEG="@comment "
+.endif
+
.if defined(WITH_FREETYPE)
BUILD_DEPENDS+= freetype-config:${PORTSDIR}/print/freetype2
PLIST_SUB+= FREETYPE=""
@@ -68,6 +83,17 @@ CONFIGURE_ARGS+= --disable-font-thumbnailer
PLIST_SUB+= FREETYPE="@comment "
.endif
+.if defined(WITH_POPPLER)
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/poppler-glib.pc:${PORTSDIR}/graphics/poppler-gtk \
+ poppler-gtk>=0.12.0:${PORTSDIR}/graphics/poppler-gtk
+LIB_DEPENDS+= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk
+PLIST_SUB+= POPPLER=""
+WITH_PLUGINS= true
+.elif defined(WITHOUT_POPPLER)
+CONFIGURE_ARGS+= --disable-poppler-thumbnailer
+PLIST_SUB+= POPPLER="@comment "
+.endif
+
.if defined(WITHOUT_XDG)
CONFIGURE_ARGS+= --disable-xdg-cache
PLIST_SUB+= XDG="@comment "
diff --git a/graphics/tumbler/distinfo b/graphics/tumbler/distinfo
index 7ddb9367828a..8c8001eba0a4 100644
--- a/graphics/tumbler/distinfo
+++ b/graphics/tumbler/distinfo
@@ -1,3 +1,3 @@
-MD5 (tumbler-0.1.1.tar.bz2) = f3f9c549ddac430904f61d80ebf7d1ac
-SHA256 (tumbler-0.1.1.tar.bz2) = cd600beb28ec2438efb1124ac45203389e7eb537608b7fbbafe25d62fab954ae
-SIZE (tumbler-0.1.1.tar.bz2) = 412032
+MD5 (tumbler-0.1.2.tar.bz2) = b115449bbf8e542531f8e34dc5e96901
+SHA256 (tumbler-0.1.2.tar.bz2) = a34f41bb4bd79ec6e76f92f68c9e8c5ef1a84325caec0d6b851a363f9bf3b599
+SIZE (tumbler-0.1.2.tar.bz2) = 399848
diff --git a/graphics/tumbler/pkg-plist b/graphics/tumbler/pkg-plist
index b70594be7e02..c622baacfe83 100644
--- a/graphics/tumbler/pkg-plist
+++ b/graphics/tumbler/pkg-plist
@@ -33,6 +33,36 @@ libdata/pkgconfig/tumbler-1.pc
%%GTK2%%lib/tumbler-1/plugins/tumbler-pixbuf-thumbnailer.a
%%GTK2%%lib/tumbler-1/plugins/tumbler-pixbuf-thumbnailer.la
%%GTK2%%lib/tumbler-1/plugins/tumbler-pixbuf-thumbnailer.so
+%%FFMPEG%%lib/tumbler-1/plugins/tumbler-ffmpeg-thumbnailer.so
+%%FFMPEG%%lib/tumbler-1/plugins/tumbler-ffmpeg-thumbnailer.la
+%%FFMPEG%%lib/tumbler-1/plugins/tumbler-ffmpeg-thumbnailer.a
+%%POPPLER%%lib/tumbler-1/plugins/tumbler-poppler-thumbnailer.so
+%%POPPLER%%lib/tumbler-1/plugins/tumbler-poppler-thumbnailer.la
+%%POPPLER%%lib/tumbler-1/plugins/tumbler-poppler-thumbnailer.a
+share/locale/ast/LC_MESSAGES/tumbler.mo
+share/locale/bn/LC_MESSAGES/tumbler.mo
+share/locale/ca/LC_MESSAGES/tumbler.mo
+share/locale/da/LC_MESSAGES/tumbler.mo
+share/locale/en_GB/LC_MESSAGES/tumbler.mo
+share/locale/eu/LC_MESSAGES/tumbler.mo
+share/locale/fi/LC_MESSAGES/tumbler.mo
+share/locale/fr/LC_MESSAGES/tumbler.mo
+share/locale/gl/LC_MESSAGES/tumbler.mo
+share/locale/id/LC_MESSAGES/tumbler.mo
+share/locale/it/LC_MESSAGES/tumbler.mo
+share/locale/ja/LC_MESSAGES/tumbler.mo
+share/locale/kk/LC_MESSAGES/tumbler.mo
+share/locale/lv/LC_MESSAGES/tumbler.mo
+share/locale/pa/LC_MESSAGES/tumbler.mo
+share/locale/pt/LC_MESSAGES/tumbler.mo
+share/locale/ru/LC_MESSAGES/tumbler.mo
+share/locale/si/LC_MESSAGES/tumbler.mo
+share/locale/sv/LC_MESSAGES/tumbler.mo
+share/locale/tr/LC_MESSAGES/tumbler.mo
+share/locale/ug/LC_MESSAGES/tumbler.mo
+share/locale/uk/LC_MESSAGES/tumbler.mo
+share/locale/zh_CN/LC_MESSAGES/tumbler.mo
+share/locale/zh_TW/LC_MESSAGES/tumbler.mo
libexec/tumblerd
share/dbus-1/services/org.xfce.Tumbler.Cache1.service
share/dbus-1/services/org.xfce.Tumbler.Manager1.service
@@ -51,35 +81,31 @@ share/gtk-doc/html/tumbler/pt01.html
share/gtk-doc/html/tumbler/right.png
share/gtk-doc/html/tumbler/style.css
share/gtk-doc/html/tumbler/thumbnails.html
-share/gtk-doc/html/tumbler/tumbler-tumbler-cache.html
-share/gtk-doc/html/tumbler/tumbler-tumbler-config.html
-share/gtk-doc/html/tumbler/tumbler-tumbler-enum-types.html
-share/gtk-doc/html/tumbler/tumbler-tumbler-error.html
share/gtk-doc/html/tumbler/tumbler-tumbler-file-info.html
share/gtk-doc/html/tumbler/tumbler-tumbler-provider-factory.html
share/gtk-doc/html/tumbler/tumbler-tumbler-provider-plugin.html
-share/gtk-doc/html/tumbler/tumbler-tumbler-thumbnail.html
-share/gtk-doc/html/tumbler/tumbler-tumbler-thumbnailer-provider.html
+share/gtk-doc/html/tumbler/TumblerCache.html
+share/gtk-doc/html/tumbler/TumblerThumbnail.html
+share/gtk-doc/html/tumbler/TumblerThumbnailerProvider.html
+share/gtk-doc/html/tumbler/tumbler-Error-Domain-and-Types.html
+share/gtk-doc/html/tumbler/tumbler-Various-Enumeration-Types.html
+share/gtk-doc/html/tumbler/tumbler-Version-Information-and-Compatibility-Checks.html
share/gtk-doc/html/tumbler/tumbler.devhelp
share/gtk-doc/html/tumbler/tumbler.devhelp2
share/gtk-doc/html/tumbler/up.png
-share/locale/ast/LC_MESSAGES/tumbler.mo
-share/locale/ca/LC_MESSAGES/tumbler.mo
-share/locale/da/LC_MESSAGES/tumbler.mo
-share/locale/en_GB/LC_MESSAGES/tumbler.mo
-share/locale/fr/LC_MESSAGES/tumbler.mo
-share/locale/gl/LC_MESSAGES/tumbler.mo
-share/locale/ja/LC_MESSAGES/tumbler.mo
-share/locale/lv/LC_MESSAGES/tumbler.mo
-share/locale/pt/LC_MESSAGES/tumbler.mo
-share/locale/sv/LC_MESSAGES/tumbler.mo
-share/locale/tr/LC_MESSAGES/tumbler.mo
-share/locale/zh_CN/LC_MESSAGES/tumbler.mo
-@dirrm share/gtk-doc/html/tumbler
-@dirrmtry share/gtk-doc/html
-@dirrmtry share/gtk-doc/
%%XDG%%@dirrm lib/tumbler-1/plugins/cache
%%PLUGINS%%@dirrm lib/tumbler-1/plugins
%%PLUGINS%%@dirrm lib/tumbler-1
+@dirrm share/gtk-doc/html/tumbler
@dirrm include/tumbler-1/tumbler
@dirrm include/tumbler-1
+@dirrm share/locale/ast/LC_MESSAGES
+@dirrm share/locale/ast
+@dirrm share/locale/kk/LC_MESSAGES
+@dirrm share/locale/kk
+@dirrm share/locale/ug/LC_MESSAGES
+@dirrm share/locale/ug
+@dirrm share/locale/si/LC_MESSAGES
+@dirrm share/locale/si
+@dirrmtry share/gtk-doc/html
+@dirrmtry share/gtk-doc