aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 09:07:58 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 09:07:58 +0000
commit86d16f2675fd705fa78870828e0e4c66cd5972d3 (patch)
tree20ce818981a1c16901fb0154cfeb10e7887519be
parent3657d5cb0d39e774a6a7f4d15f055031c01ff483 (diff)
downloadports-86d16f2675fd705fa78870828e0e4c66cd5972d3.tar.gz
ports-86d16f2675fd705fa78870828e0e4c66cd5972d3.zip
Notes
-rw-r--r--sysutils/bacula-server/Makefile8
-rw-r--r--sysutils/dar/Makefile12
-rw-r--r--sysutils/dc3dd/Makefile14
-rw-r--r--sysutils/eiciel/Makefile10
-rw-r--r--sysutils/fusefs-encfs/Makefile10
-rw-r--r--sysutils/gnome-schedule/Makefile12
-rw-r--r--sysutils/lxinput/Makefile10
-rw-r--r--sysutils/lxtask/Makefile4
-rw-r--r--sysutils/lxterminal/Makefile10
-rw-r--r--sysutils/progsreiserfs/Makefile14
-rw-r--r--sysutils/relaxconf/Makefile16
11 files changed, 56 insertions, 64 deletions
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index 1fe598b2c782..d6dd0f0cbf03 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -29,7 +29,7 @@ OPTIONS_DEFINE?= SQLITE3 MYSQL PGSQL MTX NLS OPENSSL
OPTIONS_DEFAULT?= NLS OPENSSL PGSQL
MTX_DESC= Install mtx for control of autochanger devices
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PKGNAMESUFFIX} == "-client" || ${PKGNAMESUFFIX} == "-server" #Till end of the file
@@ -87,8 +87,8 @@ SUB_LIST= BACULA_USER=${BACULA_USER} \
BACULA_GID=${BACULA_GID} \
BACULA_DIR=${BACULA_DIR}
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
CONFIGURE_ARGS+= --enable-nls
.else
CONFIGURE_ARGS+= --disable-nls
@@ -264,4 +264,4 @@ post-install:
.else
.include "${MASTERDIR}/Makefile.common"
.endif # -client and -server are defined
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/dar/Makefile b/sysutils/dar/Makefile
index af73df2c2b9c..c8e81b68d673 100644
--- a/sysutils/dar/Makefile
+++ b/sysutils/dar/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dar
-# Date created: 3 January 2004
-# Whom: Edson Brandi <ebrandi@fugspbr.org>
-#
+# Created by: Edson Brandi <ebrandi@fugspbr.org>
# $FreeBSD$
-#
PORTNAME= dar
PORTVERSION= 2.3.11
@@ -23,7 +19,9 @@ CPPFLAGS+= -DHAVE_DECL_GETOPT=0
MAN1= dar.1 dar_cp.1 dar_manager.1 dar_slave.1 dar_xform.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
@@ -35,7 +33,7 @@ PLIST_SUB+= NLS="@comment "
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${INSTALL_DATA} *.html *.dtd *.txt *.jpg [CR]* ${DOCSDIR}
@${MKDIR} ${DOCSDIR}/samples
diff --git a/sysutils/dc3dd/Makefile b/sysutils/dc3dd/Makefile
index 4c5c2c8095b2..65f68da185da 100644
--- a/sysutils/dc3dd/Makefile
+++ b/sysutils/dc3dd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dc3dd
-# Date created: 15 February 2011
-# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
-#
+# Created by: MANTANI Nobutaka <nobutaka@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= dc3dd
PORTVERSION= 7.1.614
@@ -25,11 +21,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
MAN1= dc3dd.1
-.if defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ARGS= --disable-nls
PLIST_SUB+= NLS="@comment "
-.else
-PLIST_SUB+= NLS=""
.endif
.include <bsd.port.mk>
diff --git a/sysutils/eiciel/Makefile b/sysutils/eiciel/Makefile
index 77dcab3281d7..7492a0fac1ec 100644
--- a/sysutils/eiciel/Makefile
+++ b/sysutils/eiciel/Makefile
@@ -27,12 +27,14 @@ MAKE_JOBS_SAFE= yes
MAN1= eiciel.1
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-install:
diff --git a/sysutils/fusefs-encfs/Makefile b/sysutils/fusefs-encfs/Makefile
index 7b4c1639c139..6e32746df382 100644
--- a/sysutils/fusefs-encfs/Makefile
+++ b/sysutils/fusefs-encfs/Makefile
@@ -27,12 +27,14 @@ USES= fuse
USE_GMAKE= yes
USE_LDCONFIG= yes
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
MAN1= encfs.1 encfsctl.1
diff --git a/sysutils/gnome-schedule/Makefile b/sysutils/gnome-schedule/Makefile
index a23e2f901f94..24f864a667cf 100644
--- a/sysutils/gnome-schedule/Makefile
+++ b/sysutils/gnome-schedule/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gnome-schedule
-# Date created: 2004-11-06
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/sysutils/gnome-schedule/Makefile,v 1.5 2007/09/10 06:20:14 mezz Exp $
-#
PORTNAME= gnome-schedule
PORTVERSION= 2.1.5
@@ -26,7 +22,7 @@ USE_GNOME= gnomeprefix gnomehack pygnome2
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
-.if !defined(WITHOUT_APPLET)
+.if !defined(WITHOUT_APPLET)
CONFIGURE_ARGS+= --enable-applet
PLIST_SUB+= APPLET=""
.else
@@ -34,7 +30,9 @@ CONFIGURE_ARGS+= --disable-applet
PLIST_SUB+= APPLET="@comment "
.endif
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/sysutils/lxinput/Makefile b/sysutils/lxinput/Makefile
index 5c3c0bb99396..141dc69692e4 100644
--- a/sysutils/lxinput/Makefile
+++ b/sysutils/lxinput/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lxinput
-# Date created: 2010/09/24
-# Whom: Kris Moore <kmoore@freebsd.org>
-#
+# Created by: Kris Moore <kmoore@freebsd.org>
# $FreeBSD$
-#
PORTNAME= lxinput
PORTVERSION= 0.3.1
@@ -22,7 +18,9 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
MAN1= lxinput.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/sysutils/lxtask/Makefile b/sysutils/lxtask/Makefile
index 3dfc8c071154..051f8e2e82c0 100644
--- a/sysutils/lxtask/Makefile
+++ b/sysutils/lxtask/Makefile
@@ -16,7 +16,9 @@ USES= iconv
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/sysutils/lxterminal/Makefile b/sysutils/lxterminal/Makefile
index a93fee7404ec..fd25aa4bf92c 100644
--- a/sysutils/lxterminal/Makefile
+++ b/sysutils/lxterminal/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lxterminal
-# Date created: 2010/09/24
-# Whom: Kris Moore <kmoore@freebsd.org>
-#
+# Created by: Kris Moore <kmoore@freebsd.org>
# $FreeBSD$
-#
PORTNAME= lxterminal
PORTVERSION= 0.1.11
@@ -24,7 +20,9 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
MAN1= lxterminal.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/sysutils/progsreiserfs/Makefile b/sysutils/progsreiserfs/Makefile
index ee7b793925c3..f5808bf1e55e 100644
--- a/sysutils/progsreiserfs/Makefile
+++ b/sysutils/progsreiserfs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: progsreiserfs
-# Date created: May 13 2004
-# Whom: Florent Thoumie <flz@xbsd.org>
-#
+# Created by: Florent Thoumie <flz@xbsd.org>
# $FreeBSD$
-#
PORTNAME= progsreiserfs
PORTVERSION= 0.3.1.r8
@@ -22,12 +18,14 @@ CFLAGS+= -Dgetopt_long_only=getopt_long
EXTRA_PATCHES= ${FILESDIR}/extrapatch-progsreiserfs::libmisc::Makefile.in
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.else
+CONFIGURE_ARGS+=--disable-nls
.endif
MAN8= cpfs.reiserfs.8 mkfs.reiserfs.8 reiserfs.8 \
diff --git a/sysutils/relaxconf/Makefile b/sysutils/relaxconf/Makefile
index a5856776f741..09c19ec8cea9 100644
--- a/sysutils/relaxconf/Makefile
+++ b/sysutils/relaxconf/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: RelaxBSD
-# Date created: 2005-10-12
-# Whom: Yinghong Liu <relaxbsd@gmail.com>
-#
+# Created by: Yinghong Liu <relaxbsd@gmail.com>
# $FreeBSD$
-#
PORTNAME= relaxconf
PORTVERSION= 1.1.1
@@ -20,12 +16,14 @@ RUN_DEPENDS= cdialog:${PORTSDIR}/devel/cdialog \
GNU_CONFIGURE= yes
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-CONFIGURE_ARGS+=--disable-nls
-.else
+.include <bsd.port.options.mK>
+
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=""
USES+= gettext
+.else
+PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+=--disable-nls
.endif
.include <bsd.port.mk>