aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2019-02-15 15:55:24 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2019-02-15 15:55:24 +0000
commit870ae39704deaaf7e1ddf2c37f22cde1f8a46582 (patch)
treedce963e7613472580ab4902efa9075b2ded5e2eb
parent3f3404aff7344e319003afbcbb055515af710f53 (diff)
downloadports-870ae39704deaaf7e1ddf2c37f22cde1f8a46582.tar.gz
ports-870ae39704deaaf7e1ddf2c37f22cde1f8a46582.zip
Notes
-rw-r--r--UPDATING16
-rw-r--r--net-im/ejabberd/Makefile1
-rw-r--r--net-im/ejabberd/files/patch-configure.ac2
-rw-r--r--net-im/ejabberd/files/patch-ejabberd-bug2744.diff35
4 files changed, 52 insertions, 2 deletions
diff --git a/UPDATING b/UPDATING
index 3582d5026b4a..8835fc6b2142 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,10 +5,24 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20190215:
+ AFFECTS: users of net-im/ejabberd
+ AUTHOR: ashish@FreeBSD.org
+
+ If you've mod_mam enabled with compress_xml set to true, then you're affected
+ by bug where the XML namespace, and tag elements get interchanged in the MAM cache
+ which results in invalid XML, and causing XMPP clients to disconnect. For more details,
+ please refer to: https://github.com/processone/ejabberd/issues/2744
+
+ This upgrade contains the patch that fixes the problem going forward. For fixing already
+ affected users, you'll need to wipe off the MAM cache for the affected users:
+
+ sudo -u ejabberd -H ejabberdctl remove_mam_for_user <user> <server>
+
20190202:
AFFECTS: users of archivers/urbackup-server
AUTHOR: freebsd@coombscloud.com
-
+
Some of the port's sources previously included absolute references to /etc/urbackup.
The upgrade now changes these references to ${PREFIX}/etc/urbackup. If you have placed
any configuration files within /etc/urbackup, these should be relocated to
diff --git a/net-im/ejabberd/Makefile b/net-im/ejabberd/Makefile
index dabcccd0cff2..286a55f4bb69 100644
--- a/net-im/ejabberd/Makefile
+++ b/net-im/ejabberd/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ejabberd
PORTVERSION= 18.12.1
+PORTREVISION= 1
CATEGORIES= net-im
MAINTAINER= ashish@FreeBSD.org
diff --git a/net-im/ejabberd/files/patch-configure.ac b/net-im/ejabberd/files/patch-configure.ac
index c101ad118930..e3b46efa3300 100644
--- a/net-im/ejabberd/files/patch-configure.ac
+++ b/net-im/ejabberd/files/patch-configure.ac
@@ -5,7 +5,7 @@
AC_PREREQ(2.53)
-AC_INIT(ejabberd, m4_esyscmd([echo `git describe --tags 2>/dev/null || echo 0.0` | sed 's/-g.*//;s/-/./' | tr -d '\012']), [ejabberd@process-one.net], [ejabberd])
-+AC_INIT(ejabberd, 18.12.1, [ejabberd@process-one.net], [ejabberd])
++AC_INIT(ejabberd, %%PORTVERSION%%, [ejabberd@process-one.net], [ejabberd])
REQUIRE_ERLANG_MIN="8.0 (Erlang/OTP 19.0)"
REQUIRE_ERLANG_MAX="100.0.0 (No Max)"
diff --git a/net-im/ejabberd/files/patch-ejabberd-bug2744.diff b/net-im/ejabberd/files/patch-ejabberd-bug2744.diff
new file mode 100644
index 000000000000..5c512d67fc77
--- /dev/null
+++ b/net-im/ejabberd/files/patch-ejabberd-bug2744.diff
@@ -0,0 +1,35 @@
+From 06d69c5277f08d9a57f74836c247d3927ca390e6 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Pawe=C5=82=20Chmielowski?= <pchmielowski@process-one.net>
+Date: Mon, 7 Jan 2019 16:08:58 +0100
+Subject: [PATCH] Fix decompressing of custom elements with custom namespace
+
+--- src/xml_compress.erl.orig 2018-12-21 09:44:15 UTC
++++ src/xml_compress.erl
+@@ -506,8 +506,8 @@ decode_child(<<2:8, Rest/binary>>, PNs, J1, J2) ->
+ {Children, Rest4} = decode_children(Rest3, PNs, J1, J2),
+ {{xmlel, Name, Attrs, Children}, Rest4};
+ decode_child(<<3:8, Rest/binary>>, PNs, J1, J2) ->
+- {Name, Rest2} = decode_string(Rest),
+- {Ns, Rest3} = decode_string(Rest2),
++ {Ns, Rest2} = decode_string(Rest),
++ {Name, Rest3} = decode_string(Rest2),
+ {Attrs, Rest4} = decode_attrs(Rest3),
+ {Children, Rest5} = decode_children(Rest4, Ns, J1, J2),
+ {{xmlel, Name, add_ns(PNs, Ns, Attrs), Children}, Rest5};
+ src/xml_compress.erl | 4 ++--
+ tools/xml_compress_gen.erl | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+--- tools/xml_compress_gen.erl.orig 2018-12-21 09:44:15 UTC
++++ tools/xml_compress_gen.erl
+@@ -117,8 +117,8 @@ gen_decode(Dev, Data, VerId) ->
+ " {Children, Rest4} = decode_children(Rest3, PNs, J1, J2),~n"
+ " {{xmlel, Name, Attrs, Children}, Rest4};~n", []),
+ io:format(Dev, "decode_child(<<3:8, Rest/binary>>, PNs, J1, J2) ->~n"
+- " {Name, Rest2} = decode_string(Rest),~n"
+- " {Ns, Rest3} = decode_string(Rest2),~n"
++ " {Ns, Rest2} = decode_string(Rest),~n"
++ " {Name, Rest3} = decode_string(Rest2),~n"
+ " {Attrs, Rest4} = decode_attrs(Rest3),~n"
+ " {Children, Rest5} = decode_children(Rest4, Ns, J1, J2),~n"
+ " {{xmlel, Name, add_ns(PNs, Ns, Attrs), Children}, Rest5};~n", []),