aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2017-05-11 20:42:00 +0000
committerJohan van Selst <johans@FreeBSD.org>2017-05-11 20:42:00 +0000
commit8882332a006d56fea937f235b8ab687be672b337 (patch)
treeb13e7fdadb355754620de0bebe5952f42a9a1f9f
parentc733439c63dcdb746aa2efc9bdf0cd16189cccb1 (diff)
downloadports-8882332a006d56fea937f235b8ab687be672b337.tar.gz
ports-8882332a006d56fea937f235b8ab687be672b337.zip
Notes
-rw-r--r--news/inn/Makefile22
-rw-r--r--news/inn/distinfo5
-rw-r--r--news/inn/pkg-plist5
3 files changed, 22 insertions, 10 deletions
diff --git a/news/inn/Makefile b/news/inn/Makefile
index e7155897d8e4..b2dd16b8b9b5 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= inn
-PORTVERSION= 2.6.0
+PORTVERSION= 2.6.1
CATEGORIES= news ipv6
MASTER_SITES= ISC/${PORTNAME}
@@ -23,8 +23,10 @@ CPE_VENDOR= isc
CONFLICTS?= inn-stable-[0-9]* inn-current-[0-9]*
OPTIONS_DEFINE= BERKELEYDB GNUPG KERBEROS SASL KEYWORDS \
- LARGE_FILES OPENSSL TAGGED_HASH
-OPTIONS_DEFAULT= BERKELEYDB GNUPG KEYWORDS OPENSSL LARGE_FILES
+ LARGE_FILES OPENSSL SETGID_INEWS TAGGED_HASH \
+ UUCP_RNEWS
+OPTIONS_DEFAULT= BERKELEYDB GNUPG KEYWORDS OPENSSL LARGE_FILES \
+ SETGID_INEW UUCP_RNEWS
OPTIONS_SUB= yes
KERBEROS_DESC= Enable Kerberos v5 (for auth_krb5)
@@ -35,6 +37,8 @@ KEYWORDS_DESC= Automatic keyword generation support
BERKELEYDB_DESC= Enable BerkeleyDB (for ovdb overview method)
OPENSSL_DESC= Enable OpenSSL (for NNTP over TLS/SSL support)
GNUPG_DESC= GnuPG support (for pgpverify control message)
+UUCP_RNEWS_DESC= Install rnews suitable for use with net/freebsd-uucp
+SETGID_INEWS_DESC= Enable posting articles locally for all users
VARBASE?= /var
@@ -54,8 +58,14 @@ CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
--datarootdir=${INN_SHAREDIR} \
--with-perl
-LIBVER_LONG= 3.0.0
-PLIST_SUB+= LIBVER=${LIBVER_LONG:R:R} LIBVER_LONG=${LIBVER_LONG}
+UUCP_RNEWS_CONFIGURE_ON=--enable-uucp-rnews
+UUCP_RNEWS_RUN_DEPENDS= uucp:net/freebsd-uucp
+SETGID_INEWS_CONFIGURE_ON= --enable-setgid-inews
+
+INNLIB_LONG= 4.0.0
+LIBVER_LONG= 3.0.1
+PLIST_SUB+= LIBVER=${LIBVER_LONG:R:R} LIBVER_LONG=${LIBVER_LONG} \
+ INNLIB=${INNLIB_LONG:R:R} INNLIB_LONG=${INNLIB_LONG}
.include <bsd.port.options.mk>
@@ -132,7 +142,7 @@ TO_BE_STRIPPED= bin/actsync bin/archive bin/auth/passwd/auth_krb5 \
bin/ovdb_stat bin/overchan bin/prunehistory bin/rnews \
bin/rnews.libexec/decode bin/rnews.libexec/encode bin/shlock \
bin/shrinkfile bin/sm bin/tdx-util bin/tinyleaf \
- lib/libinn.so.${LIBVER_LONG} lib/libinnhist.so.${LIBVER_LONG} \
+ lib/libinn.so.${INNLIB_LONG} lib/libinnhist.so.${LIBVER_LONG} \
lib/libstorage.so.${LIBVER_LONG}
CONFIG_FILES= actsync.cfg actsync.ign buffindexed.conf control.ctl \
diff --git a/news/inn/distinfo b/news/inn/distinfo
index 8a6eb3e9bce1..6c0be88ddd66 100644
--- a/news/inn/distinfo
+++ b/news/inn/distinfo
@@ -1,2 +1,3 @@
-SHA256 (inn-2.6.0.tar.gz) = ba96be8e87c2b56bf896c9f96492ed7706beb68e082794f8fabc7058a1804da7
-SIZE (inn-2.6.0.tar.gz) = 2597729
+TIMESTAMP = 1482846642
+SHA256 (inn-2.6.1.tar.gz) = 50f03516d39922f5c4db68915d2a70c8d5ffe8c14a16ba01029c148700523bda
+SIZE (inn-2.6.1.tar.gz) = 2570558
diff --git a/news/inn/pkg-plist b/news/inn/pkg-plist
index 9f403949aedd..3458b8ea4fc5 100644
--- a/news/inn/pkg-plist
+++ b/news/inn/pkg-plist
@@ -133,6 +133,7 @@ doc/hook-python
doc/sample-control
http/innreport.css
include/inn/buffer.h
+include/inn/concat.h
include/inn/confparse.h
include/inn/dbz.h
include/inn/defines.h
@@ -181,8 +182,8 @@ lib/innshellvars.pl
lib/innshellvars.tcl
lib/libinn.a
lib/libinn.so
-lib/libinn.so.%%LIBVER%%
-lib/libinn.so.%%LIBVER_LONG%%
+lib/libinn.so.%%INNLIB%%
+lib/libinn.so.%%INNLIB_LONG%%
lib/libinnhist.a
lib/libinnhist.so
lib/libinnhist.so.%%LIBVER%%