aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-04-07 07:02:51 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-04-07 07:02:51 +0000
commit88980b00358391e327ec9c0cb82062c694ea5ba9 (patch)
tree2fece56bd285ee202fa7d5fb84dcd792e16390e5
parentb323d4d4b54fc5d41b5ce2637f2e0baca40fdd37 (diff)
downloadports-88980b00358391e327ec9c0cb82062c694ea5ba9.tar.gz
ports-88980b00358391e327ec9c0cb82062c694ea5ba9.zip
Import of libranlib. libranlib is a library of random number
generators from netlib.
Notes
Notes: svn path=/head/; revision=6153
-rw-r--r--math/librandlib/Makefile28
-rw-r--r--math/librandlib/distinfo1
-rw-r--r--math/librandlib/files/Makefile.lib17
-rw-r--r--math/librandlib/pkg-comment1
-rw-r--r--math/librandlib/pkg-descr20
-rw-r--r--math/librandlib/pkg-plist7
-rw-r--r--math/libranlib/Makefile28
-rw-r--r--math/libranlib/distinfo1
-rw-r--r--math/libranlib/files/Makefile.lib17
-rw-r--r--math/libranlib/pkg-comment1
-rw-r--r--math/libranlib/pkg-descr20
-rw-r--r--math/libranlib/pkg-plist7
-rw-r--r--math/randlib/Makefile28
-rw-r--r--math/randlib/distinfo1
-rw-r--r--math/randlib/files/Makefile.lib17
-rw-r--r--math/randlib/pkg-comment1
-rw-r--r--math/randlib/pkg-descr20
-rw-r--r--math/randlib/pkg-plist7
18 files changed, 222 insertions, 0 deletions
diff --git a/math/librandlib/Makefile b/math/librandlib/Makefile
new file mode 100644
index 000000000000..356be74ade63
--- /dev/null
+++ b/math/librandlib/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ranlib
+# Version required: ?
+# Date created: 06 April 1997
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= ranlib.f
+PKGNAME= ranlib-1.0
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.netlib.org/random/
+
+MAINTAINER= tg@FreeBSD.ORG
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+post-extract:
+ @${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/ranlib
+ @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/* ${PREFIX}/share/doc/ranlib
+.endif
+ @${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/math/librandlib/distinfo b/math/librandlib/distinfo
new file mode 100644
index 000000000000..b375c5c594a4
--- /dev/null
+++ b/math/librandlib/distinfo
@@ -0,0 +1 @@
+MD5 (ranlib.f.tar.gz) = b2d4aeb9ea5ec5eec7d32600d0d8de29
diff --git a/math/librandlib/files/Makefile.lib b/math/librandlib/files/Makefile.lib
new file mode 100644
index 000000000000..d0e41db77e0c
--- /dev/null
+++ b/math/librandlib/files/Makefile.lib
@@ -0,0 +1,17 @@
+# bmake'd makefile for ranlib sources
+
+LIBDIR = $(PREFIX)/lib
+
+SHLIB_MAJOR= 1
+SHLIB_MINOR= 0
+LIB= ranlib
+
+SRCS = advnst.f genbet.f genchi.f genexp.f genf.f gengam.f genmn.f \
+ genmul.f gennch.f gennf.f gennor.f genprm.f genunf.f getcgn.f \
+ getsd.f ignbin.f ignlgi.f ignnbn.f ignpoi.f ignuin.f initgn.f \
+ inrgcm.f lennob.f mltmod.f phrtsd.f qrgnin.f ranf.f setall.f \
+ setant.f setgmn.f setsd.f sexpo.f sgamma.f snorm.f
+
+CLEANFILES+= ${SRC:.f=.c}
+
+.include <bsd.lib.mk>
diff --git a/math/librandlib/pkg-comment b/math/librandlib/pkg-comment
new file mode 100644
index 000000000000..49c4cb80d006
--- /dev/null
+++ b/math/librandlib/pkg-comment
@@ -0,0 +1 @@
+Library of Routines for Random Number Generation
diff --git a/math/librandlib/pkg-descr b/math/librandlib/pkg-descr
new file mode 100644
index 000000000000..e42d51236e6b
--- /dev/null
+++ b/math/librandlib/pkg-descr
@@ -0,0 +1,20 @@
+This library provides routines that return:
+ (1) Beta random deviates
+ (2) Chi-square random deviates
+ (3) Exponential random deviates
+ (4) F random deviates
+ (5) Gamma random deviates
+ (6) Multivariate normal random deviates (mean and covariance
+ matrix specified)
+ (7) Noncentral chi-square random deviates
+ (8) Noncentral F random deviates
+ (9) Univariate normal random deviates
+ (10) Random permutations of an integer array
+ (11) Real uniform random deviates between specif
+ (12) Binomial random deviates
+ (13) Negative Binomial random deviates
+ (14) Multinomial random deviates
+ (15) Poisson random deviates
+ (16) Integer uniform deviates between specified limits
+ (17) Seeds for the random number generator calculated from a
+ character string
diff --git a/math/librandlib/pkg-plist b/math/librandlib/pkg-plist
new file mode 100644
index 000000000000..acb3b7b5ec70
--- /dev/null
+++ b/math/librandlib/pkg-plist
@@ -0,0 +1,7 @@
+lib/libranlib.a
+lib/libranlib.so.1.0
+@exec /sbin/ldconfig -m %B
+share/doc/ranlib/Basegen.doc
+share/doc/ranlib/ranlib.chs
+share/doc/ranlib/ranlib.fdoc
+@dirrm %B
diff --git a/math/libranlib/Makefile b/math/libranlib/Makefile
new file mode 100644
index 000000000000..356be74ade63
--- /dev/null
+++ b/math/libranlib/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ranlib
+# Version required: ?
+# Date created: 06 April 1997
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= ranlib.f
+PKGNAME= ranlib-1.0
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.netlib.org/random/
+
+MAINTAINER= tg@FreeBSD.ORG
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+post-extract:
+ @${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/ranlib
+ @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/* ${PREFIX}/share/doc/ranlib
+.endif
+ @${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/math/libranlib/distinfo b/math/libranlib/distinfo
new file mode 100644
index 000000000000..b375c5c594a4
--- /dev/null
+++ b/math/libranlib/distinfo
@@ -0,0 +1 @@
+MD5 (ranlib.f.tar.gz) = b2d4aeb9ea5ec5eec7d32600d0d8de29
diff --git a/math/libranlib/files/Makefile.lib b/math/libranlib/files/Makefile.lib
new file mode 100644
index 000000000000..d0e41db77e0c
--- /dev/null
+++ b/math/libranlib/files/Makefile.lib
@@ -0,0 +1,17 @@
+# bmake'd makefile for ranlib sources
+
+LIBDIR = $(PREFIX)/lib
+
+SHLIB_MAJOR= 1
+SHLIB_MINOR= 0
+LIB= ranlib
+
+SRCS = advnst.f genbet.f genchi.f genexp.f genf.f gengam.f genmn.f \
+ genmul.f gennch.f gennf.f gennor.f genprm.f genunf.f getcgn.f \
+ getsd.f ignbin.f ignlgi.f ignnbn.f ignpoi.f ignuin.f initgn.f \
+ inrgcm.f lennob.f mltmod.f phrtsd.f qrgnin.f ranf.f setall.f \
+ setant.f setgmn.f setsd.f sexpo.f sgamma.f snorm.f
+
+CLEANFILES+= ${SRC:.f=.c}
+
+.include <bsd.lib.mk>
diff --git a/math/libranlib/pkg-comment b/math/libranlib/pkg-comment
new file mode 100644
index 000000000000..49c4cb80d006
--- /dev/null
+++ b/math/libranlib/pkg-comment
@@ -0,0 +1 @@
+Library of Routines for Random Number Generation
diff --git a/math/libranlib/pkg-descr b/math/libranlib/pkg-descr
new file mode 100644
index 000000000000..e42d51236e6b
--- /dev/null
+++ b/math/libranlib/pkg-descr
@@ -0,0 +1,20 @@
+This library provides routines that return:
+ (1) Beta random deviates
+ (2) Chi-square random deviates
+ (3) Exponential random deviates
+ (4) F random deviates
+ (5) Gamma random deviates
+ (6) Multivariate normal random deviates (mean and covariance
+ matrix specified)
+ (7) Noncentral chi-square random deviates
+ (8) Noncentral F random deviates
+ (9) Univariate normal random deviates
+ (10) Random permutations of an integer array
+ (11) Real uniform random deviates between specif
+ (12) Binomial random deviates
+ (13) Negative Binomial random deviates
+ (14) Multinomial random deviates
+ (15) Poisson random deviates
+ (16) Integer uniform deviates between specified limits
+ (17) Seeds for the random number generator calculated from a
+ character string
diff --git a/math/libranlib/pkg-plist b/math/libranlib/pkg-plist
new file mode 100644
index 000000000000..acb3b7b5ec70
--- /dev/null
+++ b/math/libranlib/pkg-plist
@@ -0,0 +1,7 @@
+lib/libranlib.a
+lib/libranlib.so.1.0
+@exec /sbin/ldconfig -m %B
+share/doc/ranlib/Basegen.doc
+share/doc/ranlib/ranlib.chs
+share/doc/ranlib/ranlib.fdoc
+@dirrm %B
diff --git a/math/randlib/Makefile b/math/randlib/Makefile
new file mode 100644
index 000000000000..356be74ade63
--- /dev/null
+++ b/math/randlib/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ranlib
+# Version required: ?
+# Date created: 06 April 1997
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= ranlib.f
+PKGNAME= ranlib-1.0
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.netlib.org/random/
+
+MAINTAINER= tg@FreeBSD.ORG
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+post-extract:
+ @${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/ranlib
+ @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/* ${PREFIX}/share/doc/ranlib
+.endif
+ @${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/math/randlib/distinfo b/math/randlib/distinfo
new file mode 100644
index 000000000000..b375c5c594a4
--- /dev/null
+++ b/math/randlib/distinfo
@@ -0,0 +1 @@
+MD5 (ranlib.f.tar.gz) = b2d4aeb9ea5ec5eec7d32600d0d8de29
diff --git a/math/randlib/files/Makefile.lib b/math/randlib/files/Makefile.lib
new file mode 100644
index 000000000000..d0e41db77e0c
--- /dev/null
+++ b/math/randlib/files/Makefile.lib
@@ -0,0 +1,17 @@
+# bmake'd makefile for ranlib sources
+
+LIBDIR = $(PREFIX)/lib
+
+SHLIB_MAJOR= 1
+SHLIB_MINOR= 0
+LIB= ranlib
+
+SRCS = advnst.f genbet.f genchi.f genexp.f genf.f gengam.f genmn.f \
+ genmul.f gennch.f gennf.f gennor.f genprm.f genunf.f getcgn.f \
+ getsd.f ignbin.f ignlgi.f ignnbn.f ignpoi.f ignuin.f initgn.f \
+ inrgcm.f lennob.f mltmod.f phrtsd.f qrgnin.f ranf.f setall.f \
+ setant.f setgmn.f setsd.f sexpo.f sgamma.f snorm.f
+
+CLEANFILES+= ${SRC:.f=.c}
+
+.include <bsd.lib.mk>
diff --git a/math/randlib/pkg-comment b/math/randlib/pkg-comment
new file mode 100644
index 000000000000..49c4cb80d006
--- /dev/null
+++ b/math/randlib/pkg-comment
@@ -0,0 +1 @@
+Library of Routines for Random Number Generation
diff --git a/math/randlib/pkg-descr b/math/randlib/pkg-descr
new file mode 100644
index 000000000000..e42d51236e6b
--- /dev/null
+++ b/math/randlib/pkg-descr
@@ -0,0 +1,20 @@
+This library provides routines that return:
+ (1) Beta random deviates
+ (2) Chi-square random deviates
+ (3) Exponential random deviates
+ (4) F random deviates
+ (5) Gamma random deviates
+ (6) Multivariate normal random deviates (mean and covariance
+ matrix specified)
+ (7) Noncentral chi-square random deviates
+ (8) Noncentral F random deviates
+ (9) Univariate normal random deviates
+ (10) Random permutations of an integer array
+ (11) Real uniform random deviates between specif
+ (12) Binomial random deviates
+ (13) Negative Binomial random deviates
+ (14) Multinomial random deviates
+ (15) Poisson random deviates
+ (16) Integer uniform deviates between specified limits
+ (17) Seeds for the random number generator calculated from a
+ character string
diff --git a/math/randlib/pkg-plist b/math/randlib/pkg-plist
new file mode 100644
index 000000000000..acb3b7b5ec70
--- /dev/null
+++ b/math/randlib/pkg-plist
@@ -0,0 +1,7 @@
+lib/libranlib.a
+lib/libranlib.so.1.0
+@exec /sbin/ldconfig -m %B
+share/doc/ranlib/Basegen.doc
+share/doc/ranlib/ranlib.chs
+share/doc/ranlib/ranlib.fdoc
+@dirrm %B