aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-07-02 14:57:56 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-07-02 14:57:56 +0000
commit88dae91a85e25d4e124ba31ef41cd5419ae18c63 (patch)
treec80e13ab36cb66fb41b0a0e589640ec6a3e8c4be
parent8a163be53dec333e4503db64ab78a9d3c2c470c7 (diff)
downloadports-88dae91a85e25d4e124ba31ef41cd5419ae18c63.tar.gz
ports-88dae91a85e25d4e124ba31ef41cd5419ae18c63.zip
Notes
-rw-r--r--www/lynx/Makefile34
-rw-r--r--www/lynx/pkg-plist76
2 files changed, 64 insertions, 46 deletions
diff --git a/www/lynx/Makefile b/www/lynx/Makefile
index 2a87cde877a9..f3a1abcbefc2 100644
--- a/www/lynx/Makefile
+++ b/www/lynx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lynx
PORTVERSION= 2.8.6.5
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= http://lynx.isc.org/current/ \
@@ -23,9 +23,23 @@ USE_BZIP2= yes
USE_OPENSSL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}2-8-6
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-screen=ncurses --with-zlib --libdir="${L_LIB}" \
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+=--with-zlib --libdir="${L_LIB}" \
--enable-nsl-fork --enable-persistent-cookies \
- --with-ssl="${OPENSSLBASE}"
+ --enable-nested-tables --enable-gzip-help \
+
+OPTIONS= SSL "SSL support" on \
+ DEFAULT_COLORS "Colors support" off \
+ IPV6 "IPV6 support" off \
+ NLS "Native language support" on
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 602107 || (${OSVERSION} >= 700000 && ${OSVERSION} < 700033)
+CONFIGURE_ARGS+= --with-screen=ncurses
+.else
+CONFIGURE_ARGS+= --with-screen=ncursesw
+.endif
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
@@ -37,13 +51,17 @@ CONFIGURE_ARGS+=--enable-nls --with-libiconv-prefix="${LOCALBASE}"
PLIST_SUB+= NLS=''
.endif
-.if defined(NO_INET6) || defined(WITHOUT_IPV6)
-CONFIGURE_ARGS+=--disable-ipv6
-.else
+.if defined(WITH_IPV6) && ! defined(NO_INET6)
CONFIGURE_ARGS+=--enable-ipv6
+.else
+CONFIGURE_ARGS+=--disable-ipv6
+.endif
+
+.if defined(WITH_SSL)
+CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
.endif
-.if defined(ENABLE_DEFAULT_COLORS)
+.if defined(WITH_DEFAULT_COLORS) || defined(ENABLE_DEFAULT_COLORS)
CONFIGURE_ARGS+=--enable-default-colors
.endif
@@ -65,4 +83,4 @@ post-install:
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${L_HELP}
${CHOWN} ${SHAREOWN}:${SHAREGRP} ${L_LIB}/lynx.cfg
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/lynx/pkg-plist b/www/lynx/pkg-plist
index f793633e82cc..53d64ba5dffb 100644
--- a/www/lynx/pkg-plist
+++ b/www/lynx/pkg-plist
@@ -17,16 +17,16 @@ etc/lynx.lss.sample
@unexec rm -f %D/share/lynx_help/COPYING.asc
%%DOCSDIR%%/PROBLEMS
%%DOCSDIR%%/README
-%%DOCSDIR%%/docs/CHANGES2.3
-%%DOCSDIR%%/docs/CHANGES2.4
-%%DOCSDIR%%/docs/CHANGES2.5
-%%DOCSDIR%%/docs/CHANGES2.6
-%%DOCSDIR%%/docs/CHANGES2.7
-%%DOCSDIR%%/docs/CHANGES2.8
-%%DOCSDIR%%/docs/CRAWL.announce
-%%DOCSDIR%%/docs/FM.announce
-%%DOCSDIR%%/docs/IBMPC-charsets.announce
-%%DOCSDIR%%/docs/OS-390.announce
+%%DOCSDIR%%/docs/CHANGES2.3.gz
+%%DOCSDIR%%/docs/CHANGES2.4.gz
+%%DOCSDIR%%/docs/CHANGES2.5.gz
+%%DOCSDIR%%/docs/CHANGES2.6.gz
+%%DOCSDIR%%/docs/CHANGES2.7.gz
+%%DOCSDIR%%/docs/CHANGES2.8.gz
+%%DOCSDIR%%/docs/CRAWL.announce.gz
+%%DOCSDIR%%/docs/FM.announce.gz
+%%DOCSDIR%%/docs/IBMPC-charsets.announce.gz
+%%DOCSDIR%%/docs/OS-390.announce.gz
%%DOCSDIR%%/docs/README.TRST
%%DOCSDIR%%/docs/README.chartrans
%%DOCSDIR%%/docs/README.defines
@@ -35,13 +35,13 @@ etc/lynx.lss.sample
%%DOCSDIR%%/docs/README.rootcerts
%%DOCSDIR%%/docs/README.ssl
%%DOCSDIR%%/docs/README.sslcerts
-%%DOCSDIR%%/docs/SOCKETSHR.announce
-%%DOCSDIR%%/docs/TCPWARE.announce
-%%DOCSDIR%%/docs/VMSWAIS.announce
+%%DOCSDIR%%/docs/SOCKETSHR.announce.gz
+%%DOCSDIR%%/docs/TCPWARE.announce.gz
+%%DOCSDIR%%/docs/VMSWAIS.announce.gz
%%DOCSDIR%%/docs/djgpp.key
%%DOCSDIR%%/docs/pdcurses.key
%%DOCSDIR%%/docs/slang.key
-%%DOCSDIR%%/docs/win-386.announce
+%%DOCSDIR%%/docs/win-386.announce.gz
%%DOCSDIR%%/samples/blue-background.lss
%%DOCSDIR%%/samples/bright-blue.lss
%%DOCSDIR%%/samples/cernrules.txt
@@ -78,30 +78,30 @@ etc/lynx.lss.sample
%%DOCSDIR%%/test/utf-8-demo.html
share/lynx_help/COPYHEADER
share/lynx_help/COPYING
-share/lynx_help/Lynx_users_guide.html
-share/lynx_help/about_lynx.html
-share/lynx_help/keystrokes/alt_edit_help.html
-share/lynx_help/keystrokes/bashlike_edit_help.html
-share/lynx_help/keystrokes/bookmark_help.html
-share/lynx_help/keystrokes/cookie_help.html
-share/lynx_help/keystrokes/dired_help.html
-share/lynx_help/keystrokes/edit_help.html
-share/lynx_help/keystrokes/environments.html
-share/lynx_help/keystrokes/follow_help.html
-share/lynx_help/keystrokes/gopher_types_help.html
-share/lynx_help/keystrokes/history_help.html
-share/lynx_help/keystrokes/keystroke_help.html
-share/lynx_help/keystrokes/movement_help.html
-share/lynx_help/keystrokes/option_help.html
-share/lynx_help/keystrokes/other_help.html
-share/lynx_help/keystrokes/print_help.html
-share/lynx_help/keystrokes/scrolling_help.html
-share/lynx_help/keystrokes/test_display.html
-share/lynx_help/keystrokes/visited_help.html
-share/lynx_help/keystrokes/xterm_help.html
-share/lynx_help/lynx-dev.html
-share/lynx_help/lynx_help_main.html
-share/lynx_help/lynx_url_support.html
+share/lynx_help/Lynx_users_guide.html.gz
+share/lynx_help/about_lynx.html.gz
+share/lynx_help/keystrokes/alt_edit_help.html.gz
+share/lynx_help/keystrokes/bashlike_edit_help.html.gz
+share/lynx_help/keystrokes/bookmark_help.html.gz
+share/lynx_help/keystrokes/cookie_help.html.gz
+share/lynx_help/keystrokes/dired_help.html.gz
+share/lynx_help/keystrokes/edit_help.html.gz
+share/lynx_help/keystrokes/environments.html.gz
+share/lynx_help/keystrokes/follow_help.html.gz
+share/lynx_help/keystrokes/gopher_types_help.html.gz
+share/lynx_help/keystrokes/history_help.html.gz
+share/lynx_help/keystrokes/keystroke_help.html.gz
+share/lynx_help/keystrokes/movement_help.html.gz
+share/lynx_help/keystrokes/option_help.html.gz
+share/lynx_help/keystrokes/other_help.html.gz
+share/lynx_help/keystrokes/print_help.html.gz
+share/lynx_help/keystrokes/scrolling_help.html.gz
+share/lynx_help/keystrokes/test_display.html.gz
+share/lynx_help/keystrokes/visited_help.html.gz
+share/lynx_help/keystrokes/xterm_help.html.gz
+share/lynx_help/lynx-dev.html.gz
+share/lynx_help/lynx_help_main.html.gz
+share/lynx_help/lynx_url_support.html.gz
@dirrm %%DOCSDIR%%/docs
@dirrm %%DOCSDIR%%/samples
@dirrm %%DOCSDIR%%/test