aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-07-10 08:44:55 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-07-10 08:44:55 +0000
commit893841946a8dbc80f42aa662d49fc6e0f3b1a7e6 (patch)
treeec9d7d21855befa868442cf4ba3d61a125a02c1f
parent6e7d3ec869a31c60f9b9bd30ad02ea4cdecc9779 (diff)
downloadports-893841946a8dbc80f42aa662d49fc6e0f3b1a7e6.tar.gz
ports-893841946a8dbc80f42aa662d49fc6e0f3b1a7e6.zip
MFH: r445231
Update PHP 7 from 7.0.20 to 7.0.21 Changelog: http://www.php.net/ChangeLog-7.php#7.0.21 Also: - Remove patch "patch-main_php__ini.c", has been patched upstream - Remove CONFIGURE_ARGS for "--with-regex=*" and "--with-zend-vm=*", they are not supported anymore PR: 220531 Submitted by: Dani <i.dani@outlook.com> Reported by: Fabiano Sidler <fabianosidler@swissonline.ch> Security: CVE-2017-9224 Security: CVE-2017-9226 Security: CVE-2017-9227 Security: CVE-2017-9228 Security: CVE-2017-9229 Differential Revision: https://reviews.freebsd.org/D11515 Approved by: ports-secteam (junovitch)
Notes
Notes: svn path=/branches/2017Q3/; revision=445418
-rw-r--r--devel/php70-readline/Makefile1
-rw-r--r--lang/php70/Makefile18
-rw-r--r--lang/php70/distinfo6
-rw-r--r--lang/php70/files/patch-main_php__ini.c31
4 files changed, 5 insertions, 51 deletions
diff --git a/devel/php70-readline/Makefile b/devel/php70-readline/Makefile
index 4fb5212936cf..72efa2395e67 100644
--- a/devel/php70-readline/Makefile
+++ b/devel/php70-readline/Makefile
@@ -1,7 +1,6 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
CATEGORIES= devel
MASTERDIR= ${.CURDIR}/../../lang/php70
diff --git a/lang/php70/Makefile b/lang/php70/Makefile
index df7e21bfa55a..6b34fcc54326 100644
--- a/lang/php70/Makefile
+++ b/lang/php70/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= php70
-PORTVERSION= 7.0.20
-PORTREVISION?= 1
+PORTVERSION= 7.0.21
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${PORTVERSION}
@@ -120,20 +120,6 @@ PLIST_SUB+= SAPI_INC=""
PLIST_SUB+= SAPI_INC="@comment "
.endif
-.if !defined(WITH_REGEX_TYPE) || ${WITH_REGEX_TYPE} == "php"
-CONFIGURE_ARGS+=--with-regex=php
-.elif defined(WITH_REGEX_TYPE) && ${WITH_REGEX_TYPE} == "system"
-CONFIGURE_ARGS+=--with-regex=system
-.endif
-
-.if !defined(WITH_ZEND_VM) || ${WITH_ZEND_VM} == "CALL"
-CONFIGURE_ARGS+=--with-zend-vm=CALL
-.elif defined(WITH_ZEND_VM) && ${WITH_ZEND_VM} == "SWITCH"
-CONFIGURE_ARGS+=--with-zend-vm=SWITCH
-.elif defined(WITH_ZEND_VM) && ${WITH_ZEND_VM} == "GOTO"
-CONFIGURE_ARGS+=--with-zend-vm=GOTO
-.endif
-
CONFIGURE_ENV+= ac_cv_decimal_fp_supported="no" \
lt_cv_path_SED="sed"
diff --git a/lang/php70/distinfo b/lang/php70/distinfo
index 6732ba58d47e..53e3dd5c4b48 100644
--- a/lang/php70/distinfo
+++ b/lang/php70/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1497260078
-SHA256 (php-7.0.20.tar.xz) = 31b9cf1fb83fe3cd82c2f6603a0ae81ae6abacb5286827e362d8f85e68908e0a
-SIZE (php-7.0.20.tar.xz) = 12604260
+TIMESTAMP = 1499416619
+SHA256 (php-7.0.21.tar.xz) = 6713fe3024365d661593235b525235045ef81f18d0043654658c9de1bcb8b9e3
+SIZE (php-7.0.21.tar.xz) = 12626276
diff --git a/lang/php70/files/patch-main_php__ini.c b/lang/php70/files/patch-main_php__ini.c
deleted file mode 100644
index 1d0224235439..000000000000
--- a/lang/php70/files/patch-main_php__ini.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- main/php_ini.c.orig 2017-06-14 13:27:29 UTC
-+++ main/php_ini.c
-@@ -280,7 +280,7 @@ static void php_ini_parser_cb(zval *arg1
- size_t key_len;
-
- /* PATH sections */
-- if (zend_string_equals_literal_ci(Z_STR_P(arg1), "PATH")) {
-+ if (!zend_binary_strncasecmp(Z_STRVAL_P(arg1), Z_STRLEN_P(arg1), "PATH", sizeof("PATH") - 1, sizeof("PATH") - 1)) {
- key = Z_STRVAL_P(arg1);
- key = key + sizeof("PATH") - 1;
- key_len = Z_STRLEN_P(arg1) - sizeof("PATH") + 1;
-@@ -291,7 +291,7 @@ static void php_ini_parser_cb(zval *arg1
- TRANSLATE_SLASHES_LOWER(key);
-
- /* HOST sections */
-- } else if (zend_string_equals_literal_ci(Z_STR_P(arg1), "HOST")) {
-+ } else if (!zend_binary_strncasecmp(Z_STRVAL_P(arg1), Z_STRLEN_P(arg1), "HOST", sizeof("HOST") - 1, sizeof("HOST") - 1)) {
- key = Z_STRVAL_P(arg1);
- key = key + sizeof("HOST") - 1;
- key_len = Z_STRLEN_P(arg1) - sizeof("HOST") + 1;
-@@ -328,7 +328,9 @@ static void php_ini_parser_cb(zval *arg1
- zend_hash_init(Z_ARRVAL(section_arr), 8, NULL, (dtor_func_t) config_zval_dtor, 1);
- entry = zend_hash_str_update(target_hash, key, key_len, &section_arr);
- }
-- active_ini_hash = Z_ARRVAL_P(entry);
-+ if (Z_TYPE_P(entry) == IS_ARRAY) {
-+ active_ini_hash = Z_ARRVAL_P(entry);
-+ }
- }
- }
- break;