aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:58:04 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:58:04 +0000
commit897ad0b36e733c0ecd382d79bc924e8826b141c2 (patch)
tree51651e644edd2c685808f4c990c2f85e7b689f49
parentbbd9c2e7e1340971b4a4a2c5675a3a06c28998ed (diff)
downloadports-897ad0b36e733c0ecd382d79bc924e8826b141c2.tar.gz
ports-897ad0b36e733c0ecd382d79bc924e8826b141c2.zip
Notes
-rw-r--r--net-im/diligent/Makefile2
-rw-r--r--net-im/ekiga/Makefile4
-rw-r--r--net-im/empathy/Makefile4
-rw-r--r--net-im/gajim/Makefile2
-rw-r--r--net-im/gitterdone/Makefile2
-rw-r--r--net-im/licq-qt-gui/Makefile2
-rw-r--r--net-im/pidgin/Makefile2
-rw-r--r--net-im/psi/Makefile2
-rw-r--r--net-im/ricochet/Makefile2
-rw-r--r--net-im/spectral/Makefile2
-rw-r--r--net-im/vqcc-gtk/Makefile2
-rw-r--r--net-mgmt/wifimgr/Makefile2
-rw-r--r--net-p2p/awgg/Makefile2
-rw-r--r--net-p2p/retroshare/Makefile2
-rw-r--r--net/drawterm/Makefile2
-rw-r--r--net/gkrellmwireless2/Makefile2
-rw-r--r--net/gtk-vnc/Makefile3
-rw-r--r--net/mpich2/Makefile1
-rw-r--r--net/opennx/Makefile2
-rw-r--r--net/pload/Makefile2
-rw-r--r--net/rdesktop/Makefile2
-rw-r--r--net/remmina-plugin-nx/Makefile2
-rw-r--r--net/remmina-plugin-rdp/Makefile2
-rw-r--r--net/remmina/Makefile2
-rw-r--r--net/ssvnc/Makefile2
-rw-r--r--net/tcpflow/Makefile2
-rw-r--r--net/tcpillust/Makefile2
-rw-r--r--net/tigervnc-server/Makefile2
-rw-r--r--net/tigervnc-viewer/Makefile2
-rw-r--r--net/tightvnc/Makefile2
-rw-r--r--net/twitux/Makefile2
-rw-r--r--net/vinagre/Makefile2
-rw-r--r--net/vino/Makefile2
-rw-r--r--net/wmnd/Makefile2
-rw-r--r--net/wmnet/Makefile1
-rw-r--r--net/wmnetload/Makefile2
-rw-r--r--net/wmnetmon/Makefile1
-rw-r--r--net/wmpiki/Makefile1
-rw-r--r--net/wmping/Makefile2
-rw-r--r--net/wmwave/Makefile1
-rw-r--r--net/wmwifi/Makefile2
-rw-r--r--net/wmwlmon/Makefile1
-rw-r--r--net/x11vnc/Makefile2
-rw-r--r--net/x2goclient/Makefile2
-rw-r--r--net/xipmsg/Makefile2
-rw-r--r--net/xisp/Makefile2
-rw-r--r--net/xrdp/Makefile2
-rw-r--r--news/knews/Makefile2
-rw-r--r--news/slrnface/Makefile1
-rw-r--r--news/xrn/Makefile2
50 files changed, 53 insertions, 45 deletions
diff --git a/net-im/diligent/Makefile b/net-im/diligent/Makefile
index 637a98b46e09..23091d012762 100644
--- a/net-im/diligent/Makefile
+++ b/net-im/diligent/Makefile
@@ -16,7 +16,7 @@ USE_LDCONFIG= yes
USE_QT= core gui linguist network svg \
webkit widgets x11extras buildtools_build
USE_GL= gl
-USES= compiler:c++11-lang qmake qt:5
+USES= compiler:c++11-lang gl qmake qt:5
QMAKE_ARGS= CONFIG+="configure"
diff --git a/net-im/ekiga/Makefile b/net-im/ekiga/Makefile
index c2e38652206a..d1363db5a8a0 100644
--- a/net-im/ekiga/Makefile
+++ b/net-im/ekiga/Makefile
@@ -23,8 +23,8 @@ LIB_DEPENDS= libopal.so:net/opal \
RUN_DEPENDS= gnome-icon-theme>=3.0.0:misc/gnome-icon-theme
GNU_CONFIGURE= yes
-USES= compiler:c++11-lang cpe gettext gmake libtool localbase \
- pathfix pkgconfig tar:xz
+USES= compiler:c++11-lang cpe gettext gmake gnome libtool localbase \
+ pathfix pkgconfig tar:xz xorg
USE_XORG= xv
USE_GNOME= gtk20 intlhack libxml2
INSTALLS_ICONS= yes
diff --git a/net-im/empathy/Makefile b/net-im/empathy/Makefile
index 3fda27a1ea29..34ff3d785c60 100644
--- a/net-im/empathy/Makefile
+++ b/net-im/empathy/Makefile
@@ -48,8 +48,8 @@ RUN_DEPENDS= iso-codes>=0:misc/iso-codes \
geoclue>=0:net/geoclue \
mc-tool:net-im/telepathy-mission-control
-USES= compiler:c11 gettext gmake gnome libtool localbase pathfix \
- pkgconfig python:2.7 tar:xz
+USES= compiler:c11 gettext gl gmake gnome libtool localbase pathfix \
+ pkgconfig python:2.7 tar:xz xorg
USE_GNOME= cairo evolutiondataserver3 intlhack
USE_XORG= x11 xcomposite xdamage xext xfixes xi xrandr
USE_GL= egl
diff --git a/net-im/gajim/Makefile b/net-im/gajim/Makefile
index abfcb1cad8dd..4254f23de0e0 100644
--- a/net-im/gajim/Makefile
+++ b/net-im/gajim/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cssutils>=1.0.2:www/py-cssutils@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}cairo>0:graphics/py-cairo@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyasn1>=0:devel/py-pyasn1@${PY_FLAVOR}
-USES= cpe dos2unix gnome python:3.5+ tar:bzip2
+USES= cpe dos2unix gnome python:3.5+ tar:bzip2 xorg
USE_PYTHON= autoplist distutils noflavors
USE_GNOME= intltool pygobject3
USE_XORG= x11 xext xscrnsaver
diff --git a/net-im/gitterdone/Makefile b/net-im/gitterdone/Makefile
index e1467e2a8176..2816aa3bb5d4 100644
--- a/net-im/gitterdone/Makefile
+++ b/net-im/gitterdone/Makefile
@@ -10,7 +10,7 @@ COMMENT= Gitter Client based on Qt5
LICENSE= BSD2CLAUSE
-USES= compiler:c++11-lang qmake qt:5 shebangfix tar:xz
+USES= compiler:c++11-lang gl qmake qt:5 shebangfix tar:xz
USE_QT= core gui network linguist_build \
buildtools_build widgets webkit svg
USE_GL+= gl
diff --git a/net-im/licq-qt-gui/Makefile b/net-im/licq-qt-gui/Makefile
index 6d94f4287927..dafa9d7e1218 100644
--- a/net-im/licq-qt-gui/Makefile
+++ b/net-im/licq-qt-gui/Makefile
@@ -18,8 +18,8 @@ LIB_DEPENDS= libboost_regex.so:devel/boost-libs
RUN_DEPENDS= licq:${LICQ_PORT} \
${LOCALBASE}/lib/licq/protocol_icq.so:${LICQ_PORT}-icq
+USES= cmake qt:5 xorg
USE_XORG= x11 xext ice xscrnsaver sm
-USES= cmake qt:5
USE_QT= buildtools_build qmake_build linguisttools_build core \
xml gui network dbus svg widgets
USE_GITHUB= yes
diff --git a/net-im/pidgin/Makefile b/net-im/pidgin/Makefile
index db9368ea420f..4adfe5582dec 100644
--- a/net-im/pidgin/Makefile
+++ b/net-im/pidgin/Makefile
@@ -20,7 +20,7 @@ PLIST= ${.CURDIR}/pkg-plist
PIDGIN_SLAVE= yes
WITH_GTKUI= yes
-USES= python:build
+USES= gnome python:build xorg
USE_LDCONFIG= yes
USE_GNOME= gnomeprefix gtk20 intltool
USE_XORG= xscrnsaver sm
diff --git a/net-im/psi/Makefile b/net-im/psi/Makefile
index 1aad19d91d1a..e8bfeb24f81c 100644
--- a/net-im/psi/Makefile
+++ b/net-im/psi/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libidn.so:dns/libidn \
libqca-qt5.so:devel/qca
USES= cmake compiler:c++11-lang desktop-file-utils pkgconfig \
- qt:5 tar:xz
+ qt:5 tar:xz xorg
USE_QT= concurrent core dbus gui multimedia network svg widgets \
x11extras xml buildtools_build qmake_build imageformats_run
USE_XORG= ice sm x11 xcb xext xscrnsaver
diff --git a/net-im/ricochet/Makefile b/net-im/ricochet/Makefile
index d731c72ce9b6..d72da7b92f59 100644
--- a/net-im/ricochet/Makefile
+++ b/net-im/ricochet/Makefile
@@ -17,7 +17,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libprotobuf.so:devel/protobuf
-USES= compiler:c++11-lib gmake pkgconfig qmake qt:5 ssl
+USES= compiler:c++11-lib gl gmake pkgconfig qmake qt:5 ssl
USE_GITHUB= yes
GH_ACCOUNT= ricochet-im
USE_QT= core declarative gui multimedia network quickcontrols widgets \
diff --git a/net-im/spectral/Makefile b/net-im/spectral/Makefile
index fb9929181b10..20097eb56a5c 100644
--- a/net-im/spectral/Makefile
+++ b/net-im/spectral/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= libqmatrixclient>=0.5:net-im/libqmatrixclient
-USES= compiler:c++17-lang pkgconfig qmake qt:5 tar:bz2
+USES= compiler:c++17-lang gl pkgconfig qmake qt:5 tar:bz2
USE_GL= gl
USE_QT= core dbus declarative graphicaleffects gui imageformats \
multimedia network quickcontrols2 svg widgets \
diff --git a/net-im/vqcc-gtk/Makefile b/net-im/vqcc-gtk/Makefile
index 72a804e8b435..25b5e027d025 100644
--- a/net-im/vqcc-gtk/Makefile
+++ b/net-im/vqcc-gtk/Makefile
@@ -12,7 +12,7 @@ COMMENT= LAN chat client compatible with quickChat and Vypress Chat (TM)
LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification
-USES= pathfix gmake gettext pkgconfig
+USES= pathfix gmake gnome gettext pkgconfig xorg
USE_GNOME= gnomeprefix gtk20
USE_XORG= x11 xext xscrnsaver
GNU_CONFIGURE= yes
diff --git a/net-mgmt/wifimgr/Makefile b/net-mgmt/wifimgr/Makefile
index 86f78e14c86b..eb62f15edcf0 100644
--- a/net-mgmt/wifimgr/Makefile
+++ b/net-mgmt/wifimgr/Makefile
@@ -13,7 +13,7 @@ COMMENT= WiFi Networks Manager
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= desktop-file-utils pkgconfig tar:bzip2
+USES= desktop-file-utils gnome pkgconfig tar:bzip2 xorg
USE_XORG= x11
USE_GNOME= gtk20
INSTALLS_ICONS= yes
diff --git a/net-p2p/awgg/Makefile b/net-p2p/awgg/Makefile
index 8614fd25eb03..e5e11228e77a 100644
--- a/net-p2p/awgg/Makefile
+++ b/net-p2p/awgg/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= aria2c:www/aria2 \
gtk2_CONFLICTS_INSTALL= ${PORTNAME}-qt5
qt5_CONFLICTS_INSTALL= ${PORTNAME}-gtk2
-USES= fpc lazarus:flavors
+USES= fpc lazarus:flavors xorg
USE_FPC= chm fcl-base fcl-db fcl-image fcl-json fcl-registry fcl-xml \
pasjpeg regexpr rtl-extra rtl-objpas x11
USE_XORG= x11
diff --git a/net-p2p/retroshare/Makefile b/net-p2p/retroshare/Makefile
index 8587db8bb5a3..16e788e5dae7 100644
--- a/net-p2p/retroshare/Makefile
+++ b/net-p2p/retroshare/Makefile
@@ -29,7 +29,7 @@ LIB_DEPENDS= libsqlcipher.so:databases/sqlcipher \
libminiupnpc.so:net/miniupnpc
USES= compiler:features desktop-file-utils dos2unix \
- gnome pkgconfig qmake qt:5 ssl
+ gl gnome pkgconfig qmake qt:5 ssl
USE_GITHUB= yes
GH_ACCOUNT= RetroShare
GH_PROJECT= RetroShare
diff --git a/net/drawterm/Makefile b/net/drawterm/Makefile
index 7b7d2d514524..1bb0b9e72033 100644
--- a/net/drawterm/Makefile
+++ b/net/drawterm/Makefile
@@ -13,7 +13,7 @@ COMMENT= Plan9 cpu client
# Additionally the Lucent Public License
LICENSE= MIT
-USES= tar:tgz
+USES= tar:tgz xorg
USE_XORG= x11 xt
PLIST_FILES= bin/drawterm
diff --git a/net/gkrellmwireless2/Makefile b/net/gkrellmwireless2/Makefile
index e77e11425cf1..d28382e34863 100644
--- a/net/gkrellmwireless2/Makefile
+++ b/net/gkrellmwireless2/Makefile
@@ -16,8 +16,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:sysutils/gkrellm2
RUN_DEPENDS= gkrellm:sysutils/gkrellm2
WRKSRC= ${WRKDIR}/gkrellmwireless
+USES= gmake pkgconfig xorg
USE_XORG= x11
-USES= gmake pkgconfig
pre-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
diff --git a/net/gtk-vnc/Makefile b/net/gtk-vnc/Makefile
index b15459c8bb8f..d50f6df187e9 100644
--- a/net/gtk-vnc/Makefile
+++ b/net/gtk-vnc/Makefile
@@ -19,8 +19,9 @@ LIB_DEPENDS= libgnutls.so:security/gnutls \
libgpg-error.so:security/libgpg-error \
libsasl2.so:security/cyrus-sasl2
+USES= gettext gmake gnome libtool localbase pathfix pkgconfig python \
+ tar:xz xorg
USE_GNOME= cairo gdkpixbuf2 gtk30 intltool introspection:build
-USES= gettext gmake gnome libtool localbase pathfix pkgconfig python tar:xz
USE_XORG= x11
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index 196cb69399b9..ee5cbfe65502 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -124,6 +124,7 @@ CONFIGURE_ARGS+= --disable-graphics
PLIST_SUB+= X11="@comment "
.else
CONFIGURE_ARGS+= --x-includes=${LOCALBASE}/include --x-libraries==${LOCALBASE}/lib
+USES+= xorg
USE_XORG= x11 xt
PLIST_SUB+= X11=${PLX11}
.endif
diff --git a/net/opennx/Makefile b/net/opennx/Makefile
index ea525eea0d48..3ca826dd5d7a 100644
--- a/net/opennx/Makefile
+++ b/net/opennx/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/zip:archivers/zip
LIB_DEPENDS= libcups.so:print/cups \
libcurl.so:ftp/curl
-USES= gmake gnome samba:lib
+USES= gmake gnome samba:lib xorg
USE_XORG= ice sm x11 xau xmu
USE_WX= 2.8+
diff --git a/net/pload/Makefile b/net/pload/Makefile
index fe990c064581..7d05c5518853 100644
--- a/net/pload/Makefile
+++ b/net/pload/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= LOCAL/pav \
MAINTAINER= fbsd@opal.com
COMMENT= X11 program to display network traffic graphs
-USES= imake:env
+USES= imake:env xorg
USE_XORG= ice sm x11 xaw xext xmu xpm xt
HAS_CONFIGURE= yes
LATE_INSTALL_ARGS= install.man
diff --git a/net/rdesktop/Makefile b/net/rdesktop/Makefile
index 7190325c57d2..c1b264800c01 100644
--- a/net/rdesktop/Makefile
+++ b/net/rdesktop/Makefile
@@ -11,7 +11,7 @@ COMMENT= RDP client for Windows NT/2000/2003 Terminal Server
LICENSE= GPLv3
-USES= autoreconf gmake iconv pkgconfig ssl
+USES= autoreconf gmake iconv pkgconfig ssl xorg
USE_XORG= x11 xrandr
USE_GITHUB= yes
diff --git a/net/remmina-plugin-nx/Makefile b/net/remmina-plugin-nx/Makefile
index 72a705ec22e7..a20a1319e3b7 100644
--- a/net/remmina-plugin-nx/Makefile
+++ b/net/remmina-plugin-nx/Makefile
@@ -5,7 +5,7 @@ PKGNAMESUFFIX= -nx
COMMENT= Remmina plugin for NX
-USES= gnome
+USES= gnome xorg
USE_GNOME= cairo
USE_XORG= x11 xkbfile
diff --git a/net/remmina-plugin-rdp/Makefile b/net/remmina-plugin-rdp/Makefile
index 26ee8579ef96..7c924a91f80a 100644
--- a/net/remmina-plugin-rdp/Makefile
+++ b/net/remmina-plugin-rdp/Makefile
@@ -7,7 +7,7 @@ COMMENT= Remmina plugin for RDP protocol
LIB_DEPENDS= libfreerdp2.so:net/freerdp
-USES= gnome
+USES= gnome xorg
USE_GNOME= cairo
USE_XORG= ice sm x11 xext
diff --git a/net/remmina/Makefile b/net/remmina/Makefile
index 42a00cb1d9c1..7fadc062ecf5 100644
--- a/net/remmina/Makefile
+++ b/net/remmina/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libjson-glib-1.0.so:devel/json-glib \
libsoup-2.4.so:devel/libsoup
USES= cmake compiler:c11 desktop-file-utils gettext gnome localbase:ldflags pathfix \
- pkgconfig shared-mime-info ssl shebangfix
+ pkgconfig shared-mime-info ssl shebangfix xorg
USE_GITLAB= yes
GL_ACCOUNT= Remmina
diff --git a/net/ssvnc/Makefile b/net/ssvnc/Makefile
index 3877c535cefc..afb7d5176a49 100644
--- a/net/ssvnc/Makefile
+++ b/net/ssvnc/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= stunnel:security/stunnel \
xterm:x11/xterm
-USES= gmake imake:env jpeg perl5 ssl tk:wrapper
+USES= gmake imake:env jpeg perl5 ssl tk:wrapper xorg
USE_PERL5= run
USE_XORG= ice sm x11 xaw xext xi xmu xpm xt
diff --git a/net/tcpflow/Makefile b/net/tcpflow/Makefile
index 3abfaa11f5e5..7e778c67a20b 100644
--- a/net/tcpflow/Makefile
+++ b/net/tcpflow/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libcairo.so:graphics/cairo \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= python:2.7 ssl
+USES= python:2.7 ssl xorg
USE_XORG= pixman
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_lib_md_MD5=no \
diff --git a/net/tcpillust/Makefile b/net/tcpillust/Makefile
index 7de4bc9a1a7d..5a955ddd50a0 100644
--- a/net/tcpillust/Makefile
+++ b/net/tcpillust/Makefile
@@ -13,7 +13,7 @@ COMMENT= Graphical TCP connection analysis tool
BROKEN= unfetchable
-USES= motif tk
+USES= motif tk xorg
USE_XORG= xt
PORTDOCS= tcpclient.log tcpserver.log
diff --git a/net/tigervnc-server/Makefile b/net/tigervnc-server/Makefile
index 83308303dffe..f59a0c10892b 100644
--- a/net/tigervnc-server/Makefile
+++ b/net/tigervnc-server/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libxshmfence.so:x11/libxshmfence
RUN_DEPENDS+= ${LOCALBASE}/share/X11/xkb/rules/base:x11/xkeyboard-config \
xkbcomp:x11/xkbcomp
-USES+= autoreconf:build gl jpeg libtool pkgconfig ssl
+USES+= autoreconf:build gl jpeg libtool pkgconfig ssl xorg
USE_LDCONFIG= yes
USE_GL+= gl
USE_XORG+= ice pixman sm x11 xau xdamage xdmcp xext xfixes xfont xkbfile \
diff --git a/net/tigervnc-viewer/Makefile b/net/tigervnc-viewer/Makefile
index 4e4ffcd45a75..3209fd73d830 100644
--- a/net/tigervnc-viewer/Makefile
+++ b/net/tigervnc-viewer/Makefile
@@ -6,7 +6,7 @@ CATEGORIES= net
COMMENT= TigerVNC Viewer
-USES+= gnome iconv jpeg
+USES+= gnome iconv jpeg xorg
USE_XORG+= ice sm x11 xcursor xext xfixes xft xinerama xrender
BUILD_DEPENDS+= convert:graphics/ImageMagick7 # to generate icons during build
diff --git a/net/tightvnc/Makefile b/net/tightvnc/Makefile
index 00bac0c448ac..60316669ec4c 100644
--- a/net/tightvnc/Makefile
+++ b/net/tightvnc/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENCE.TXT
BROKEN_aarch64= Fails to build: invokes x86 asm
-USES= cpe imake jpeg shebangfix perl5 tar:bzip2
+USES= cpe imake jpeg shebangfix perl5 tar:bzip2 xorg
USE_XORG= ice sm x11 xaw xext xmu xt xpm
RUN_DEPENDS= showrgb:x11/rgb \
diff --git a/net/twitux/Makefile b/net/twitux/Makefile
index 94dada3caf5c..fc03eb20f9a7 100644
--- a/net/twitux/Makefile
+++ b/net/twitux/Makefile
@@ -15,11 +15,11 @@ LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
libnotify.so:devel/libnotify \
libcanberra.so:audio/libcanberra
+USES= gettext gmake gnome pkgconfig tar:bzip2 xorg
USE_XORG= x11
USE_GNOME= glib20 gtk20 gconf2 intltool libxml2 gnomedocutils
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
-USES= gettext gmake pkgconfig tar:bzip2
CONFIGURE_ENV+= GMSGFMT="${LOCALBASE}/bin/msgfmt"
GCONF_SCHEMAS= twitux.schemas
INSTALLS_ICONS= yes
diff --git a/net/vinagre/Makefile b/net/vinagre/Makefile
index e9c74d1dc559..e6a510c0d05d 100644
--- a/net/vinagre/Makefile
+++ b/net/vinagre/Makefile
@@ -31,7 +31,7 @@ RUN_DEPENDS= gnome-icon-theme>=0:misc/gnome-icon-theme
PORTSCOUT= limitw:1,even
USES= autoreconf desktop-file-utils gettext gmake gnome localbase \
- pathfix pkgconfig shared-mime-info tar:xz
+ pathfix pkgconfig shared-mime-info tar:xz xorg
USE_GNOME= cairo gtk30 intlhack libxml2 vte3
USE_XORG= x11
GNU_CONFIGURE= yes
diff --git a/net/vino/Makefile b/net/vino/Makefile
index dd5025a02864..9eb032d51b6a 100644
--- a/net/vino/Makefile
+++ b/net/vino/Makefile
@@ -27,7 +27,7 @@ LIB_DEPENDS= libgnutls.so:security/gnutls \
PORTSCOUT= limitw:1,even
USES= cpe gettext gmake gnome jpeg localbase pathfix \
- pkgconfig tar:xz
+ pkgconfig tar:xz xorg
CPE_VENDOR= david_king
USE_GNOME= cairo gtk30 intlhack
USE_XORG= ice x11 xdamage xext xfixes sm xtst
diff --git a/net/wmnd/Makefile b/net/wmnd/Makefile
index 060b581f6434..4800a8b2b194 100644
--- a/net/wmnd/Makefile
+++ b/net/wmnd/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
OPTIONS_DEFINE= EXAMPLES
-USES= gmake
+USES= gmake xorg
USE_XORG= ice sm x11 xext xpm
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dummy-driver
diff --git a/net/wmnet/Makefile b/net/wmnet/Makefile
index 7acf01fb841b..7f38c91a24de 100644
--- a/net/wmnet/Makefile
+++ b/net/wmnet/Makefile
@@ -11,6 +11,7 @@ MASTER_SITES= ftp://ftp.enteract.com/users/rneswold/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Network bandwidth monitor intended for the WindowMaker dock
+USES= xorg
USE_XORG= xpm
.include <bsd.port.mk>
diff --git a/net/wmnetload/Makefile b/net/wmnetload/Makefile
index 818f5811523b..bb3dc1410573 100644
--- a/net/wmnetload/Makefile
+++ b/net/wmnetload/Makefile
@@ -16,7 +16,7 @@ BROKEN= unfetchable
LIB_DEPENDS= libdockapp.so:x11-wm/libdockapp
-USES= tar:bzip2
+USES= tar:bzip2 xorg
USE_XORG= xpm x11
GNU_CONFIGURE= yes
diff --git a/net/wmnetmon/Makefile b/net/wmnetmon/Makefile
index 8e17eb660285..a0f935b3016c 100644
--- a/net/wmnetmon/Makefile
+++ b/net/wmnetmon/Makefile
@@ -12,6 +12,7 @@ COMMENT= Host availability monitor intended for the WindowMaker dock
BROKEN= unfetchable
+USES= xorg
USE_XORG= xpm
GNU_CONFIGURE= yes
diff --git a/net/wmpiki/Makefile b/net/wmpiki/Makefile
index e80429687601..09bab8c9aeca 100644
--- a/net/wmpiki/Makefile
+++ b/net/wmpiki/Makefile
@@ -13,6 +13,7 @@ COMMENT= Multiping host checker dockapp
BROKEN= unfetchable
+USES= xorg
USE_XORG= xpm
OPTIONS_DEFINE= DOCS
diff --git a/net/wmping/Makefile b/net/wmping/Makefile
index 1ba896df1022..62046e077a95 100644
--- a/net/wmping/Makefile
+++ b/net/wmping/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= serg@cad.kiev.ua
COMMENT= Windowmaker dock app to display network hosts status
+USES= gmake xorg
USE_XORG= xpm
-USES= gmake
GNU_CONFIGURE= yes
PORTDOCS= BUGS CHANGES README TODO
diff --git a/net/wmwave/Makefile b/net/wmwave/Makefile
index 359e61ab59d8..26e3be8815df 100644
--- a/net/wmwave/Makefile
+++ b/net/wmwave/Makefile
@@ -11,6 +11,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= benjsc@FreeBSD.org
COMMENT= Display 802.11 status in the WindowMaker Dock
+USES= xorg
USE_XORG= xpm
PLIST_FILES= bin/wmwave man/man1/wmwave.1.gz
diff --git a/net/wmwifi/Makefile b/net/wmwifi/Makefile
index 6498b133676c..695d1b44664d 100644
--- a/net/wmwifi/Makefile
+++ b/net/wmwifi/Makefile
@@ -15,7 +15,7 @@ COMMENT= Dockapp displaying the signal strength of WiFi connection
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake localbase
+USES= gmake localbase xorg
USE_XORG= x11 xext xpm
CONFIGURE_ENV= X_CFLAGS="${CFLAGS}"
diff --git a/net/wmwlmon/Makefile b/net/wmwlmon/Makefile
index 6b7f33945d72..402e9394c909 100644
--- a/net/wmwlmon/Makefile
+++ b/net/wmwlmon/Makefile
@@ -9,6 +9,7 @@ MASTER_SITES= http://www.nazgul.ch/dev/
MAINTAINER= LukeD@pobox.com
COMMENT= DockApp showing the state of a wireless network device
+USES= xorg
USE_XORG= x11 xext xpm
PLIST_FILES= bin/wmwlmon man/man1/wmwlmon.1.gz
diff --git a/net/x11vnc/Makefile b/net/x11vnc/Makefile
index 0cded093a157..67f39c652927 100644
--- a/net/x11vnc/Makefile
+++ b/net/x11vnc/Makefile
@@ -14,11 +14,11 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
LIB_DEPENDS= libvncserver.so:net/libvncserver
+USES= iconv pkgconfig jpeg ssl gmake autoreconf xorg
USE_XORG= x11 xcb xdamage xfixes xrandr xinerama xext xtst xau xrender \
xdmcp xi xorgproto
# Sets LDFLAGS and adds to CONFIGURE_ENV, therefore we set LDFLAGS
LDFLAGS+= -L${LOCALBASE}/lib
-USES= iconv pkgconfig jpeg ssl gmake autoreconf
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/x2goclient/Makefile b/net/x2goclient/Makefile
index 030de8ca1e35..9e9f75ce85e4 100644
--- a/net/x2goclient/Makefile
+++ b/net/x2goclient/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libcups.so:print/cups \
RUN_DEPENDS= nxproxy:net/nxproxy \
x2goclient-cli:net/x2goclient-cli
-USES= compiler:c++11-lang gl qmake qt:5
+USES= compiler:c++11-lang gl qmake qt:5 xorg
USE_GL= gl
USE_XORG= x11 xpm
USE_QT= core gui network svg widgets x11extras \
diff --git a/net/xipmsg/Makefile b/net/xipmsg/Makefile
index e04a61f43d15..80f29a867027 100644
--- a/net/xipmsg/Makefile
+++ b/net/xipmsg/Makefile
@@ -13,7 +13,7 @@ COMMENT= Popup style message communication tool for X11
BROKEN= unfetchable
-USES= imake
+USES= imake xorg
USE_XORG= ice sm x11 xaw xext xmu xpm xt
post-patch:
diff --git a/net/xisp/Makefile b/net/xisp/Makefile
index 07bc2f31f248..b9797d1798e1 100644
--- a/net/xisp/Makefile
+++ b/net/xisp/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libforms.so:x11-toolkits/xforms
-USES= alias ssl
+USES= alias ssl xorg
USE_XORG= x11 xpm
CFLAGS+= -DUSE_OPENSSL -I${OPENSSLINC}
diff --git a/net/xrdp/Makefile b/net/xrdp/Makefile
index f544b191fdc2..d02e10579c31 100644
--- a/net/xrdp/Makefile
+++ b/net/xrdp/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= xterm:x11/xterm \
${LOCALBASE}/lib/xorg/modules/libxorgxrdp.so:x11-drivers/xorgxrdp \
${LOCALBASE}/lib/pulse-13.0/modules/module-xrdp-sink.so:audio/pulseaudio-module-xrdp
-USES= autoreconf:build jpeg localbase libtool pkgconfig ssl
+USES= autoreconf:build jpeg localbase libtool pkgconfig ssl xorg
USE_XORG= ice pixman sm x11 xfixes xrandr
USE_LDCONFIG= ${PREFIX}/lib/xrdp
USE_GITHUB= yes
diff --git a/news/knews/Makefile b/news/knews/Makefile
index 5dbcee650d0b..43561e6c5688 100644
--- a/news/knews/Makefile
+++ b/news/knews/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= newsp:print/mp-letter
LICENSE= GPLv2
-USES= imake jpeg
+USES= imake jpeg xorg
USE_XORG= xmu xpm xt sm ice xext x11
MAKE_FLAGS= BINDIR=${PREFIX}/bin MANDIR=${PREFIX}/man/man1 CC="${CC}" \
XAPPLOADDIR=${PREFIX}/lib/X11/app-defaults -f
diff --git a/news/slrnface/Makefile b/news/slrnface/Makefile
index f87cf8a05394..6203321f88c0 100644
--- a/news/slrnface/Makefile
+++ b/news/slrnface/Makefile
@@ -18,6 +18,7 @@ ALL_TARGET= slrnface
MAKE_ARGS= CC="${CC}" C_FLAGS="${CFLAGS}" \
X_INCL=-I${LOCALBASE}/include \
XF_LIB="-L${LOCALBASE}/lib -lcompface"
+USES= xorg
USE_XORG= xt
PLIST_FILES= bin/slrnface man/man1/slrnface.1.gz %%DATADIR%%/slrnface.sl
diff --git a/news/xrn/Makefile b/news/xrn/Makefile
index 6fdf5e48aff8..03b82e9f83c3 100644
--- a/news/xrn/Makefile
+++ b/news/xrn/Makefile
@@ -12,7 +12,7 @@ COMMENT= Usenet News reader for the X Window System
BROKEN= unfetchable
-USES= bison gmake pkgconfig
+USES= bison gmake pkgconfig xorg
GNU_CONFIGURE= yes
USE_XORG= ice sm x11 xaw xext xmu xpm xt