aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-04-14 16:27:25 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-04-14 16:27:25 +0000
commit8a40adf64d9c1155e3f6334b6a1a98057a9c5bab (patch)
treec5e01ea22c3b53cc34975877acecba7dab5f0f71
parent7ead9b90431659a98361edeb5d4a92c700606bb3 (diff)
downloadports-8a40adf64d9c1155e3f6334b6a1a98057a9c5bab.tar.gz
ports-8a40adf64d9c1155e3f6334b6a1a98057a9c5bab.zip
Notes
-rw-r--r--lang/python36/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/python36/Makefile b/lang/python36/Makefile
index 3b69dde4872b..32909682651c 100644
--- a/lang/python36/Makefile
+++ b/lang/python36/Makefile
@@ -130,6 +130,12 @@ post-install:
.if ${CC} == /nxb-bin/usr/bin/cc
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -O -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/config-${PYTHON_VER}m/Makefile
.endif