aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2020-02-06 16:25:01 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2020-02-06 16:25:01 +0000
commit8a8594166003c0067cf6d474f560d2238f96d58c (patch)
tree58ec05171e504877f5c5ec2f52d5cd46c9df3e02
parent7877d010b1a8822e0b14a3c1df865178f899fc42 (diff)
Notes
-rw-r--r--net-mgmt/resource-agents/Makefile36
-rw-r--r--net-mgmt/resource-agents/distinfo6
-rw-r--r--net-mgmt/resource-agents/pkg-plist28
3 files changed, 55 insertions, 15 deletions
diff --git a/net-mgmt/resource-agents/Makefile b/net-mgmt/resource-agents/Makefile
index 20b7f19630e8..626d48b37552 100644
--- a/net-mgmt/resource-agents/Makefile
+++ b/net-mgmt/resource-agents/Makefile
@@ -2,38 +2,37 @@
# $FreeBSD$
PORTNAME= resource-agents
-PORTVERSION= 4.1.1
+PORTVERSION= 4.4.0
DISTVERSIONPREFIX=v
-PORTREVISION= 2
CATEGORIES= net-mgmt
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= egypcio@FreeBSD.org
COMMENT= OCF Compliant Resource Agents
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= bash:shells/bash
RUN_DEPENDS= bash:shells/bash
-CONFLICTS= heartbeat-[0-9]*
-
+USES= autoreconf gmake gnome pkgconfig python shebangfix
+USE_GNOME= glib20
USE_GITHUB= yes
GH_ACCOUNT= ClusterLabs
-USES= autoreconf gmake gnome pkgconfig python shebangfix
-USE_GNOME= glib20
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-fatal-warnings
+CONFIGURE_ARGS= --disable-fatal-warnings --with-version=${PORTVERSION} \
+ PACKAGE_STRING="${PORTNAME} ${PORTVERSION}" \
+ PACKAGE_VERSION="${PORTVERSION}"
+
+CONFLICTS= heartbeat-[0-9]*
SHEBANG_LANG= sh
sh_OLD_CMD= /bin/sh
sh_CMD= ${LOCALBASE}/bin/bash
SHEBANG_FILES= heartbeat/* \
ldirectord/ldirectord.in \
- rgmanager/src/resources/*.sh \
rgmanager/src/resources/*.sh.in \
- rgmanager/src/resources/ocf-shellfuncs \
- rgmanager/src/resources/svclib_nfslock \
rgmanager/src/resources/utils/*.pl \
rgmanager/src/resources/utils/*.sh \
tools/ocft/ocft.in \
@@ -46,4 +45,19 @@ OPTIONS_SUB= yes
MANPAGES_BUILD_DEPENDS= docbook-xsl>0:textproc/docbook-xsl \
xsltproc:textproc/libxslt
+post-patch:
+ ${REINPLACE_CMD} 's|v=UNKNOWN|v=${PORTVERSION}|g' \
+ ${WRKSRC}/make/git-version-gen
+ ${REINPLACE_CMD} 's|/etc/cluster|${LOCALBASE}/etc/cluster|g' \
+ ${WRKSRC}/heartbeat/sybaseASE.in \
+ ${WRKSRC}/rgmanager/src/resources/utils/config-utils.sh.in \
+ ${WRKSRC}/rgmanager/src/resources/ASEHAagent.sh.in
+
+post-configure:
+ ${REINPLACE_CMD} 's|md5sum|md5|g' \
+ ${WRKSRC}/heartbeat/iSCSILogicalUnit
+
+post-install:
+ ${RM} ${STAGEDIR}/${LOCALBASE}/resource-agents.conf
+
.include <bsd.port.mk>
diff --git a/net-mgmt/resource-agents/distinfo b/net-mgmt/resource-agents/distinfo
index a5a7a2209001..f57c754bfd1d 100644
--- a/net-mgmt/resource-agents/distinfo
+++ b/net-mgmt/resource-agents/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1525901739
-SHA256 (ClusterLabs-resource-agents-v4.1.1_GH0.tar.gz) = decc370bce20ee7a034886eb19ddb54d823f5e95c58f4d121f53cc965147f736
-SIZE (ClusterLabs-resource-agents-v4.1.1_GH0.tar.gz) = 717079
+TIMESTAMP = 1580896683
+SHA256 (ClusterLabs-resource-agents-v4.4.0_GH0.tar.gz) = 256b7fbcd1ed71c69e082626f7439d5a6e90b7495a03f598d0b0a2b14c9b7f03
+SIZE (ClusterLabs-resource-agents-v4.4.0_GH0.tar.gz) = 783702
diff --git a/net-mgmt/resource-agents/pkg-plist b/net-mgmt/resource-agents/pkg-plist
index b0f51f025b75..29f6f94af681 100644
--- a/net-mgmt/resource-agents/pkg-plist
+++ b/net-mgmt/resource-agents/pkg-plist
@@ -16,6 +16,7 @@ lib/ocf/lib/heartbeat/ocf-distro
lib/ocf/lib/heartbeat/ocf-rarun
lib/ocf/lib/heartbeat/ocf-returncodes
lib/ocf/lib/heartbeat/ocf-shellfuncs
+lib/ocf/lib/heartbeat/ocf.py
lib/ocf/lib/heartbeat/ora-common.sh
lib/ocf/lib/heartbeat/sapdb-nosha.sh
lib/ocf/lib/heartbeat/sapdb.sh
@@ -62,6 +63,7 @@ lib/ocf/resource.d/heartbeat/WinPopup
lib/ocf/resource.d/heartbeat/Xen
lib/ocf/resource.d/heartbeat/Xinetd
lib/ocf/resource.d/heartbeat/ZFS
+lib/ocf/resource.d/heartbeat/aliyun-vpc-move-ip
lib/ocf/resource.d/heartbeat/anything
lib/ocf/resource.d/heartbeat/apache
lib/ocf/resource.d/heartbeat/asterisk
@@ -69,6 +71,7 @@ lib/ocf/resource.d/heartbeat/aws-vpc-move-ip
lib/ocf/resource.d/heartbeat/aws-vpc-route53
lib/ocf/resource.d/heartbeat/awseip
lib/ocf/resource.d/heartbeat/awsvip
+lib/ocf/resource.d/heartbeat/azure-events
lib/ocf/resource.d/heartbeat/azure-lb
lib/ocf/resource.d/heartbeat/clvm
lib/ocf/resource.d/heartbeat/conntrackd
@@ -76,12 +79,14 @@ lib/ocf/resource.d/heartbeat/db2
lib/ocf/resource.d/heartbeat/dhcpd
lib/ocf/resource.d/heartbeat/dnsupdate
lib/ocf/resource.d/heartbeat/docker
+lib/ocf/resource.d/heartbeat/dovecot
lib/ocf/resource.d/heartbeat/eDir88
lib/ocf/resource.d/heartbeat/ethmonitor
lib/ocf/resource.d/heartbeat/exportfs
lib/ocf/resource.d/heartbeat/fio
lib/ocf/resource.d/heartbeat/galera
lib/ocf/resource.d/heartbeat/garbd
+lib/ocf/resource.d/heartbeat/gcp-vpc-move-ip
lib/ocf/resource.d/heartbeat/iSCSILogicalUnit
lib/ocf/resource.d/heartbeat/iSCSITarget
lib/ocf/resource.d/heartbeat/ids
@@ -107,6 +112,9 @@ lib/ocf/resource.d/heartbeat/named
lib/ocf/resource.d/heartbeat/nfsnotify
lib/ocf/resource.d/heartbeat/nfsserver
lib/ocf/resource.d/heartbeat/nginx
+lib/ocf/resource.d/heartbeat/openstack-cinder-volume
+lib/ocf/resource.d/heartbeat/openstack-floating-ip
+lib/ocf/resource.d/heartbeat/openstack-info
lib/ocf/resource.d/heartbeat/oraasm
lib/ocf/resource.d/heartbeat/oracle
lib/ocf/resource.d/heartbeat/oralsnr
@@ -114,6 +122,7 @@ lib/ocf/resource.d/heartbeat/ovsmonitor
lib/ocf/resource.d/heartbeat/pgagent
lib/ocf/resource.d/heartbeat/pgsql
lib/ocf/resource.d/heartbeat/pingd
+lib/ocf/resource.d/heartbeat/podman
lib/ocf/resource.d/heartbeat/portblock
lib/ocf/resource.d/heartbeat/postfix
lib/ocf/resource.d/heartbeat/pound
@@ -127,10 +136,12 @@ lib/ocf/resource.d/heartbeat/scsi2reservation
lib/ocf/resource.d/heartbeat/sfex
lib/ocf/resource.d/heartbeat/sg_persist
lib/ocf/resource.d/heartbeat/slapd
+lib/ocf/resource.d/heartbeat/sybaseASE
lib/ocf/resource.d/heartbeat/symlink
lib/ocf/resource.d/heartbeat/syslog-ng
lib/ocf/resource.d/heartbeat/tomcat
lib/ocf/resource.d/heartbeat/varnish
+lib/ocf/resource.d/heartbeat/vdo-vol
lib/ocf/resource.d/heartbeat/vmware
lib/ocf/resource.d/heartbeat/vsftpd
lib/ocf/resource.d/heartbeat/zabbixserver
@@ -174,13 +185,16 @@ libexec/heartbeat/findif
%%MANPAGES%%man/man7/ocf_heartbeat_WinPopup.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_Xen.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_Xinetd.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_ZFS.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_aliyun-vpc-move-ip.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_anything.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_apache.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_asterisk.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_aws-vpc-move-ip.7.gz
-%%MANPAGES%%man/man7/ocf_heartbeat_aws-vpc-route53.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_aws-vpc-route5%%PYTHON_VER%%.gz
%%MANPAGES%%man/man7/ocf_heartbeat_awseip.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_awsvip.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_azure-events.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_azure-lb.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_clvm.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_conntrackd.7.gz
@@ -188,12 +202,14 @@ libexec/heartbeat/findif
%%MANPAGES%%man/man7/ocf_heartbeat_dhcpd.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_dnsupdate.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_docker.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_dovecot.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_eDir88.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_ethmonitor.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_exportfs.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_fio.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_galera.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_garbd.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_gcp-vpc-move-ip.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_iSCSILogicalUnit.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_iSCSITarget.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_ids.7.gz
@@ -209,6 +225,7 @@ libexec/heartbeat/findif
%%MANPAGES%%man/man7/ocf_heartbeat_lxd-info.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_machine-info.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_mariadb.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_minio.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_mpathpersist.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_mysql-proxy.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_mysql.7.gz
@@ -217,29 +234,38 @@ libexec/heartbeat/findif
%%MANPAGES%%man/man7/ocf_heartbeat_nfsnotify.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_nfsserver.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_nginx.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_openstack-cinder-volume.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_openstack-floating-ip.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_openstack-info.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_oraasm.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_oracle.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_oralsnr.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_ovsmonitor.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_pgagent.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_pgsql.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_pingd.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_podman.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_portblock.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_postfix.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_pound.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_proftpd.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_rabbitmq-cluster.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_redis.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_rkt.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_rsyncd.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_rsyslog.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_scsi2reservation.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_sfex.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_sg_persist.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_slapd.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_sybaseASE.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_symlink.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_syslog-ng.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_tomcat.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_varnish.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_vdo-vol.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_vmware.7.gz
+%%MANPAGES%%man/man7/ocf_heartbeat_vsftpd.7.gz
%%MANPAGES%%man/man7/ocf_heartbeat_zabbixserver.7.gz
%%MANPAGES%%man/man8/ldirectord.8.gz
%%MANPAGES%%man/man8/ocf-tester.8.gz