aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-20 14:26:46 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-20 14:26:46 +0000
commit8ad9fd338e18c7333c669841ecb1cc31204644a7 (patch)
tree25054be32b29718b65e819a2890693238a4558b5
parent10b8e2ee8d14c6f2b4d637a39e3c03d891a0217a (diff)
downloadports-8ad9fd338e18c7333c669841ecb1cc31204644a7.tar.gz
ports-8ad9fd338e18c7333c669841ecb1cc31204644a7.zip
Notes
-rw-r--r--emulators/fuse/Makefile33
-rw-r--r--emulators/libspectrum/Makefile24
-rw-r--r--games/deng/Makefile5
-rw-r--r--x11-themes/icon-naming-utils/Makefile15
-rw-r--r--x11-themes/icons-tango/Makefile13
5 files changed, 39 insertions, 51 deletions
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index 0266ed326d99..1ecac2750648 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fuse
-# Date created: 2003-10-28
-# Whom: Alexey V. Antipovsky <kemm@in-line.ru>
-#
+# Created by: Alexey V. Antipovsky <kemm@in-line.ru>
# $FreeBSD$
-#
PORTNAME= fuse
PORTVERSION= 1.0.0.1
@@ -11,16 +7,15 @@ PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}-emulator/${PORTNAME}/${PORTVERSION}
-MAINTAINER= yuri.pankov@gmail.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Free Unix (Sinclair ZX-)Spectrum Emulator
+LICENSE= GPLv2
+
LIB_DEPENDS= spectrum.8:${PORTSDIR}/emulators/libspectrum \
png15:${PORTSDIR}/graphics/png \
gcrypt.18:${PORTSDIR}/security/libgcrypt
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-
GNU_CONFIGURE= yes
USE_GNOME= libxml2 glib20 gtk20
@@ -30,27 +25,33 @@ CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
MAN1= fuse.1
-OPTIONS= AO "Use libao for audio output" off \
- SAMPLERATE "Support for better beeper sound quality" on
+OPTIONS_DEFINE= AO SAMPLERATE
+OPTIONS_DEFAULT= SAMPLERATE
+AO_DESC= Use libao for audio output
+SAMPLERATE_DESC= Better beeper sound quality
+
+BROKEN= does not build (presumably after recent glib update)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_AO)
+.if ${PORT_OPTIONS:MAO}
CONFIGURE_ARGS+=--with-libao
LIB_DEPENDS+= ao.4:${PORTSDIR}/audio/libao
+.else
+CONFIGURE_ARGS+=--without-libao
.endif
-.if !defined(WITHOUT_SAMPLERATE)
+.if ${PORT_OPTIONS:MSAMPLERATE}
LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
.else
CONFIGURE_ARGS+=--without-libsamplerate
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS ChangeLog README THANKS \
${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/libspectrum/Makefile b/emulators/libspectrum/Makefile
index 5d64a3c6f326..48ed2f2bc917 100644
--- a/emulators/libspectrum/Makefile
+++ b/emulators/libspectrum/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libspectrum
-# Date created: 2003-10-27
-# Whom: Alexey V. Antipovsky <kemm@in-line.ru>
-#
+# Created by: Alexey V. Antipovsky <kemm@in-line.ru>
# $FreeBSD$
-#
PORTNAME= libspectrum
PORTVERSION= 1.0.0
@@ -11,13 +7,12 @@ PORTREVISION= 1
CATEGORIES= emulators devel
MASTER_SITES= SF/fuse-emulator/${PORTNAME}/${PORTVERSION}
-MAINTAINER= yuri.pankov@gmail.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Handling of ZX-Spectrum emulator files formats
-LIB_DEPENDS= gcrypt.18:${PORTSDIR}/security/libgcrypt
-
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= gcrypt.18:${PORTSDIR}/security/libgcrypt
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -26,21 +21,22 @@ USE_LDCONFIG= yes
MAN3= libspectrum.3
-OPTIONS= AUDIOFILE "Support loading from .wav files" on
+OPTIONS_DEFINE= AUDIOFILE
+AUDIOFILE_DESC= Support loading from .wav files
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_AUDIOFILE)
+.if ${PORT_OPTIONS:MAUDIOFILE}
LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
.else
CONFIGURE_ARGS+=--without-libaudiofile
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} \
AUTHORS ChangeLog README THANKS doc/libspectrum.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/deng/Makefile b/games/deng/Makefile
index fa06a02058d9..136d5e7df189 100644
--- a/games/deng/Makefile
+++ b/games/deng/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Doomsday%20Engine/1.9.0-beta6.9
DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/-beta/}
-MAINTAINER= yuri.pankov@gmail.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Enhanced Doom, Heretic, and Hexen source port
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
@@ -21,8 +21,7 @@ USE_LDCONFIG= yes
USE_SDL= sdl mixer net
USE_XORG= x11
USE_PYTHON= yes
-USE_CMAKE= yes
-CMAKE_OUTSOURCE= yes
+USES= cmake:outsource
CMAKE_SOURCE_PATH= ${WRKSRC}/doomsday
CFLAGS+= -I${LOCALBASE}/include/libpng15
CMAKE_ARGS+= -DCMAKE_EXE_LINKER_FLAGS:STRING="-Wl,--export-dynamic"
diff --git a/x11-themes/icon-naming-utils/Makefile b/x11-themes/icon-naming-utils/Makefile
index be2e316c1861..d344d53193b1 100644
--- a/x11-themes/icon-naming-utils/Makefile
+++ b/x11-themes/icon-naming-utils/Makefile
@@ -1,17 +1,14 @@
-# New ports collection makefile for: icon-naming-utils
-# Date created: 2005-11-05
-# Whom: Phillip Neumann <pneumann@gmail.com>
-#
+# Created by: Phillip Neumann <pneumann@gmail.com>
# $FreeBSD$
-#
PORTNAME= icon-naming-utils
PORTVERSION= 0.8.90
+PORTREVISION= 1
CATEGORIES= x11-themes
MASTER_SITES= GENTOO
MASTER_SITE_SUBDIR= distfiles
-MAINTAINER= yuri.pankov@gmail.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Utilities of the Tango project
BUILD_DEPENDS= p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
@@ -20,9 +17,7 @@ RUN_DEPENDS= p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
USE_PERL5= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig
-
-pre-configure:
- @ ${REINPLACE_CMD} -e "s|[(]datadir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g" ${WRKSRC}/Makefile.in
+USE_PKGCONFIG= build
+USES+= pathfix
.include <bsd.port.mk>
diff --git a/x11-themes/icons-tango/Makefile b/x11-themes/icons-tango/Makefile
index fea68932857e..4c6941c55269 100644
--- a/x11-themes/icons-tango/Makefile
+++ b/x11-themes/icons-tango/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: icons-tango
-# Date created: 2005-11-05
-# Whom: Phillip Neumann <pneumann@gmail.com>
-#
+# Created by: Phillip Neumann <pneumann@gmail.com>
# $FreeBSD$
-#
PORTNAME= icons-tango
PORTVERSION= 0.8.90
@@ -13,8 +9,8 @@ MASTER_SITES= ${MASTER_SITE_GENTOO}
MASTER_SITE_SUBDIR= distfiles
DISTNAME= tango-icon-theme-${PORTVERSION}
-MAINTAINER= yuri.pankov@gmail.com
-COMMENT= A basic set of icons for the most common usage
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Basic set of icons for the most common usage
BUILD_DEPENDS= ${LOCALBASE}/libexec/icon-name-mapping:${PORTSDIR}/x11-themes/icon-naming-utils \
Magick-config:${PORTSDIR}/graphics/ImageMagick
@@ -22,7 +18,8 @@ BUILD_DEPENDS= ${LOCALBASE}/libexec/icon-name-mapping:${PORTSDIR}/x11-themes/ico
GNU_CONFIGURE= yes
USE_GZIP= yes
USE_GMAKE= yes
-USE_GNOME= intlhack gnomehack
+USE_GNOME= intlhack
+USES+= pathfix
INSTALLS_ICONS= yes
.include <bsd.port.mk>