aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-22 20:06:06 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-22 20:06:06 +0000
commit8af26cfe5dea14d481f030077ce9513e9e19ab33 (patch)
tree7b6bf015afc2d1c629b6783c2011f1fffefb951b
parent3e1396bb558cdbb97ab948f07d79c97d5e77931c (diff)
downloadports-8af26cfe5dea14d481f030077ce9513e9e19ab33.tar.gz
ports-8af26cfe5dea14d481f030077ce9513e9e19ab33.zip
Notes
-rw-r--r--audio/rhythmbox-devel/Makefile3
-rw-r--r--audio/rhythmbox-devel/distinfo2
-rw-r--r--audio/rhythmbox-devel/files/patch-configure33
-rw-r--r--audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-by-age.c40
-rw-r--r--audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-equal-weights.c18
-rw-r--r--audio/rhythmbox-devel/files/patch-shell_rb-play-order-shuffle.c17
-rw-r--r--audio/rhythmbox-devel/files/patch-shell_rb-play-order.c13
-rw-r--r--audio/rhythmbox/Makefile3
-rw-r--r--audio/rhythmbox/distinfo2
-rw-r--r--audio/rhythmbox/files/patch-configure33
-rw-r--r--audio/rhythmbox/files/patch-shell_rb-play-order-random-by-age.c40
-rw-r--r--audio/rhythmbox/files/patch-shell_rb-play-order-random-equal-weights.c18
-rw-r--r--audio/rhythmbox/files/patch-shell_rb-play-order-shuffle.c17
-rw-r--r--audio/rhythmbox/files/patch-shell_rb-play-order.c13
14 files changed, 4 insertions, 248 deletions
diff --git a/audio/rhythmbox-devel/Makefile b/audio/rhythmbox-devel/Makefile
index 3f05de739252..986bd73c9d58 100644
--- a/audio/rhythmbox-devel/Makefile
+++ b/audio/rhythmbox-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= rhythmbox
-PORTVERSION= 0.6.2
-PORTREVISION= 1
+PORTVERSION= 0.6.3
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
diff --git a/audio/rhythmbox-devel/distinfo b/audio/rhythmbox-devel/distinfo
index 9ce60c7bcbc6..72e6becda406 100644
--- a/audio/rhythmbox-devel/distinfo
+++ b/audio/rhythmbox-devel/distinfo
@@ -1 +1 @@
-MD5 (gnome2/rhythmbox-0.6.2.tar.bz2) = a6d05830abf45cda229270b0e5ab5ca4
+MD5 (gnome2/rhythmbox-0.6.3.tar.bz2) = 24edcdae89367e6acd1b087f2970e3c2
diff --git a/audio/rhythmbox-devel/files/patch-configure b/audio/rhythmbox-devel/files/patch-configure
index 2ecff7bd2a0f..263b7720fbf4 100644
--- a/audio/rhythmbox-devel/files/patch-configure
+++ b/audio/rhythmbox-devel/files/patch-configure
@@ -8,36 +8,3 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -21080,20 +21081,20 @@
- echo "$as_me:$LINENO: checking for id3tag >= 0.15.0b" >&5
- echo $ECHO_N "checking for id3tag >= 0.15.0b... $ECHO_C" >&6
-
-- if $PKG_CONFIG --exists "id3tag >= 0.15.0b" ; then
-+ if true ; then
- echo "$as_me:$LINENO: result: yes" >&5
- echo "${ECHO_T}yes" >&6
- succeeded=yes
-
- echo "$as_me:$LINENO: checking ID3TAG_CFLAGS" >&5
- echo $ECHO_N "checking ID3TAG_CFLAGS... $ECHO_C" >&6
-- ID3TAG_CFLAGS=`$PKG_CONFIG --cflags "id3tag >= 0.15.0b"`
-+ ID3TAG_CFLAGS=""
- echo "$as_me:$LINENO: result: $ID3TAG_CFLAGS" >&5
- echo "${ECHO_T}$ID3TAG_CFLAGS" >&6
-
- echo "$as_me:$LINENO: checking ID3TAG_LIBS" >&5
- echo $ECHO_N "checking ID3TAG_LIBS... $ECHO_C" >&6
-- ID3TAG_LIBS=`$PKG_CONFIG --libs "id3tag >= 0.15.0b"`
-+ ID3TAG_LIBS="-L$LOCALBASE/lib -lid3tag -lz"
- echo "$as_me:$LINENO: result: $ID3TAG_LIBS" >&5
- echo "${ECHO_T}$ID3TAG_LIBS" >&6
- else
-@@ -21101,7 +21102,7 @@
- ID3TAG_LIBS=""
- ## If we have a custom action on failure, don't print errors, but
- ## do set a variable so people can do so.
-- ID3TAG_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "id3tag >= 0.15.0b"`
-+ ID3TAG_PKG_ERRORS=
-
- fi
-
diff --git a/audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-by-age.c b/audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-by-age.c
deleted file mode 100644
index 6778884c75ef..000000000000
--- a/audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-by-age.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- shell/rb-play-order-random-by-age.c.orig Thu Dec 18 02:59:50 2003
-+++ shell/rb-play-order-random-by-age.c Thu Dec 18 03:00:34 2003
-@@ -87,6 +87,7 @@
- rb_random_play_order_by_age_class_init (RBRandomPlayOrderByAgeClass *klass)
- {
- GObjectClass *object_class = G_OBJECT_CLASS (klass);
-+ RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
-
- parent_class = g_type_class_peek_parent (klass);
-
-@@ -94,7 +95,6 @@
- object_class->finalize = rb_random_play_order_by_age_finalize;
-
-
-- RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
- porder->get_next = rb_random_play_order_by_age_get_next;
- porder->go_next = rb_random_play_order_by_age_go_next;
- porder->get_previous = rb_random_play_order_by_age_get_previous;
-@@ -265,6 +265,8 @@
- RhythmDBEntry *result = NULL;
- GArray *entries = get_entry_view_contents (entry_view);
- int i;
-+ double rnd;
-+ double total_weight = 0;
-
- if (entries->len == 0) {
- /* entry view empty */
-@@ -273,11 +275,10 @@
-
- /* Algorithm due to treed */
-
-- double total_weight = 0;
- for (i=0; i<entries->len; ++i) {
- total_weight += g_array_index (entries, EntryWeight, i).weight;
- }
-- double rnd = g_random_double_range (0, total_weight);
-+ rnd = g_random_double_range (0, total_weight);
- for (i=0; i<entries->len; ++i) {
- if (rnd < g_array_index (entries, EntryWeight, i).weight) {
- result = g_array_index (entries, EntryWeight, i).entry;
diff --git a/audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-equal-weights.c b/audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-equal-weights.c
deleted file mode 100644
index bc81e005e11c..000000000000
--- a/audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-equal-weights.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- shell/rb-play-order-random-equal-weights.c.orig Thu Dec 18 02:59:09 2003
-+++ shell/rb-play-order-random-equal-weights.c Thu Dec 18 02:59:16 2003
-@@ -85,6 +85,7 @@
- rb_random_play_order_equal_weights_class_init (RBRandomPlayOrderEqualWeightsClass *klass)
- {
- GObjectClass *object_class = G_OBJECT_CLASS (klass);
-+ RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
-
- parent_class = g_type_class_peek_parent (klass);
-
-@@ -92,7 +93,6 @@
- object_class->finalize = rb_random_play_order_equal_weights_finalize;
-
-
-- RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
- porder->get_next = rb_random_play_order_equal_weights_get_next;
- porder->go_next = rb_random_play_order_equal_weights_go_next;
- porder->get_previous = rb_random_play_order_equal_weights_get_previous;
diff --git a/audio/rhythmbox-devel/files/patch-shell_rb-play-order-shuffle.c b/audio/rhythmbox-devel/files/patch-shell_rb-play-order-shuffle.c
deleted file mode 100644
index 33d0c3fcedb4..000000000000
--- a/audio/rhythmbox-devel/files/patch-shell_rb-play-order-shuffle.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- shell/rb-play-order-shuffle.c.orig Thu Dec 18 02:58:17 2003
-+++ shell/rb-play-order-shuffle.c Thu Dec 18 02:58:34 2003
-@@ -111,13 +111,13 @@
- rb_shuffle_play_order_class_init (RBShufflePlayOrderClass *klass)
- {
- GObjectClass *object_class = G_OBJECT_CLASS (klass);
-+ RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
-
- parent_class = g_type_class_peek_parent (klass);
-
- object_class->constructor = rb_shuffle_play_order_constructor;
- object_class->finalize = rb_shuffle_play_order_finalize;
-
-- RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
- porder->get_next = rb_shuffle_play_order_get_next;
- porder->go_next = rb_shuffle_play_order_go_next;
- porder->get_previous = rb_shuffle_play_order_get_previous;
diff --git a/audio/rhythmbox-devel/files/patch-shell_rb-play-order.c b/audio/rhythmbox-devel/files/patch-shell_rb-play-order.c
deleted file mode 100644
index 5e7990b0038d..000000000000
--- a/audio/rhythmbox-devel/files/patch-shell_rb-play-order.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- shell/rb-play-order.c.orig Thu Dec 18 02:57:29 2003
-+++ shell/rb-play-order.c Thu Dec 18 02:57:41 2003
-@@ -195,9 +195,9 @@
- rb_play_order_get_entry_view (RBPlayOrder *porder)
- {
- RBShellPlayer *player = porder->priv->player;
-+ RBSource *source = rb_shell_player_get_source (player);
- if (player == NULL)
- return NULL;
-- RBSource *source = rb_shell_player_get_source (player);
- if (source == NULL)
- return NULL;
- return rb_source_get_entry_view (source);
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index 3f05de739252..986bd73c9d58 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= rhythmbox
-PORTVERSION= 0.6.2
-PORTREVISION= 1
+PORTVERSION= 0.6.3
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
diff --git a/audio/rhythmbox/distinfo b/audio/rhythmbox/distinfo
index 9ce60c7bcbc6..72e6becda406 100644
--- a/audio/rhythmbox/distinfo
+++ b/audio/rhythmbox/distinfo
@@ -1 +1 @@
-MD5 (gnome2/rhythmbox-0.6.2.tar.bz2) = a6d05830abf45cda229270b0e5ab5ca4
+MD5 (gnome2/rhythmbox-0.6.3.tar.bz2) = 24edcdae89367e6acd1b087f2970e3c2
diff --git a/audio/rhythmbox/files/patch-configure b/audio/rhythmbox/files/patch-configure
index 2ecff7bd2a0f..263b7720fbf4 100644
--- a/audio/rhythmbox/files/patch-configure
+++ b/audio/rhythmbox/files/patch-configure
@@ -8,36 +8,3 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -21080,20 +21081,20 @@
- echo "$as_me:$LINENO: checking for id3tag >= 0.15.0b" >&5
- echo $ECHO_N "checking for id3tag >= 0.15.0b... $ECHO_C" >&6
-
-- if $PKG_CONFIG --exists "id3tag >= 0.15.0b" ; then
-+ if true ; then
- echo "$as_me:$LINENO: result: yes" >&5
- echo "${ECHO_T}yes" >&6
- succeeded=yes
-
- echo "$as_me:$LINENO: checking ID3TAG_CFLAGS" >&5
- echo $ECHO_N "checking ID3TAG_CFLAGS... $ECHO_C" >&6
-- ID3TAG_CFLAGS=`$PKG_CONFIG --cflags "id3tag >= 0.15.0b"`
-+ ID3TAG_CFLAGS=""
- echo "$as_me:$LINENO: result: $ID3TAG_CFLAGS" >&5
- echo "${ECHO_T}$ID3TAG_CFLAGS" >&6
-
- echo "$as_me:$LINENO: checking ID3TAG_LIBS" >&5
- echo $ECHO_N "checking ID3TAG_LIBS... $ECHO_C" >&6
-- ID3TAG_LIBS=`$PKG_CONFIG --libs "id3tag >= 0.15.0b"`
-+ ID3TAG_LIBS="-L$LOCALBASE/lib -lid3tag -lz"
- echo "$as_me:$LINENO: result: $ID3TAG_LIBS" >&5
- echo "${ECHO_T}$ID3TAG_LIBS" >&6
- else
-@@ -21101,7 +21102,7 @@
- ID3TAG_LIBS=""
- ## If we have a custom action on failure, don't print errors, but
- ## do set a variable so people can do so.
-- ID3TAG_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "id3tag >= 0.15.0b"`
-+ ID3TAG_PKG_ERRORS=
-
- fi
-
diff --git a/audio/rhythmbox/files/patch-shell_rb-play-order-random-by-age.c b/audio/rhythmbox/files/patch-shell_rb-play-order-random-by-age.c
deleted file mode 100644
index 6778884c75ef..000000000000
--- a/audio/rhythmbox/files/patch-shell_rb-play-order-random-by-age.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- shell/rb-play-order-random-by-age.c.orig Thu Dec 18 02:59:50 2003
-+++ shell/rb-play-order-random-by-age.c Thu Dec 18 03:00:34 2003
-@@ -87,6 +87,7 @@
- rb_random_play_order_by_age_class_init (RBRandomPlayOrderByAgeClass *klass)
- {
- GObjectClass *object_class = G_OBJECT_CLASS (klass);
-+ RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
-
- parent_class = g_type_class_peek_parent (klass);
-
-@@ -94,7 +95,6 @@
- object_class->finalize = rb_random_play_order_by_age_finalize;
-
-
-- RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
- porder->get_next = rb_random_play_order_by_age_get_next;
- porder->go_next = rb_random_play_order_by_age_go_next;
- porder->get_previous = rb_random_play_order_by_age_get_previous;
-@@ -265,6 +265,8 @@
- RhythmDBEntry *result = NULL;
- GArray *entries = get_entry_view_contents (entry_view);
- int i;
-+ double rnd;
-+ double total_weight = 0;
-
- if (entries->len == 0) {
- /* entry view empty */
-@@ -273,11 +275,10 @@
-
- /* Algorithm due to treed */
-
-- double total_weight = 0;
- for (i=0; i<entries->len; ++i) {
- total_weight += g_array_index (entries, EntryWeight, i).weight;
- }
-- double rnd = g_random_double_range (0, total_weight);
-+ rnd = g_random_double_range (0, total_weight);
- for (i=0; i<entries->len; ++i) {
- if (rnd < g_array_index (entries, EntryWeight, i).weight) {
- result = g_array_index (entries, EntryWeight, i).entry;
diff --git a/audio/rhythmbox/files/patch-shell_rb-play-order-random-equal-weights.c b/audio/rhythmbox/files/patch-shell_rb-play-order-random-equal-weights.c
deleted file mode 100644
index bc81e005e11c..000000000000
--- a/audio/rhythmbox/files/patch-shell_rb-play-order-random-equal-weights.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- shell/rb-play-order-random-equal-weights.c.orig Thu Dec 18 02:59:09 2003
-+++ shell/rb-play-order-random-equal-weights.c Thu Dec 18 02:59:16 2003
-@@ -85,6 +85,7 @@
- rb_random_play_order_equal_weights_class_init (RBRandomPlayOrderEqualWeightsClass *klass)
- {
- GObjectClass *object_class = G_OBJECT_CLASS (klass);
-+ RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
-
- parent_class = g_type_class_peek_parent (klass);
-
-@@ -92,7 +93,6 @@
- object_class->finalize = rb_random_play_order_equal_weights_finalize;
-
-
-- RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
- porder->get_next = rb_random_play_order_equal_weights_get_next;
- porder->go_next = rb_random_play_order_equal_weights_go_next;
- porder->get_previous = rb_random_play_order_equal_weights_get_previous;
diff --git a/audio/rhythmbox/files/patch-shell_rb-play-order-shuffle.c b/audio/rhythmbox/files/patch-shell_rb-play-order-shuffle.c
deleted file mode 100644
index 33d0c3fcedb4..000000000000
--- a/audio/rhythmbox/files/patch-shell_rb-play-order-shuffle.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- shell/rb-play-order-shuffle.c.orig Thu Dec 18 02:58:17 2003
-+++ shell/rb-play-order-shuffle.c Thu Dec 18 02:58:34 2003
-@@ -111,13 +111,13 @@
- rb_shuffle_play_order_class_init (RBShufflePlayOrderClass *klass)
- {
- GObjectClass *object_class = G_OBJECT_CLASS (klass);
-+ RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
-
- parent_class = g_type_class_peek_parent (klass);
-
- object_class->constructor = rb_shuffle_play_order_constructor;
- object_class->finalize = rb_shuffle_play_order_finalize;
-
-- RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
- porder->get_next = rb_shuffle_play_order_get_next;
- porder->go_next = rb_shuffle_play_order_go_next;
- porder->get_previous = rb_shuffle_play_order_get_previous;
diff --git a/audio/rhythmbox/files/patch-shell_rb-play-order.c b/audio/rhythmbox/files/patch-shell_rb-play-order.c
deleted file mode 100644
index 5e7990b0038d..000000000000
--- a/audio/rhythmbox/files/patch-shell_rb-play-order.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- shell/rb-play-order.c.orig Thu Dec 18 02:57:29 2003
-+++ shell/rb-play-order.c Thu Dec 18 02:57:41 2003
-@@ -195,9 +195,9 @@
- rb_play_order_get_entry_view (RBPlayOrder *porder)
- {
- RBShellPlayer *player = porder->priv->player;
-+ RBSource *source = rb_shell_player_get_source (player);
- if (player == NULL)
- return NULL;
-- RBSource *source = rb_shell_player_get_source (player);
- if (source == NULL)
- return NULL;
- return rb_source_get_entry_view (source);