aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-24 15:02:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-24 15:02:14 +0000
commit8b7b3c59f87ac19bedbe8dc63febe8d17537aa99 (patch)
tree7632a54dcf4a9a52ec7ac84ab705ee521813101e
parent0ea154e61b4f115c18873e7355ac84d476e39eda (diff)
downloadports-8b7b3c59f87ac19bedbe8dc63febe8d17537aa99.tar.gz
ports-8b7b3c59f87ac19bedbe8dc63febe8d17537aa99.zip
Notes
-rw-r--r--sysutils/fusefs-unionfs/Makefile18
-rw-r--r--sysutils/fusefs-unionfs/distinfo4
-rw-r--r--sysutils/fusefs-unionfs/files/patch-src__hashtable_itr.h27
3 files changed, 10 insertions, 39 deletions
diff --git a/sysutils/fusefs-unionfs/Makefile b/sysutils/fusefs-unionfs/Makefile
index c675f9583e91..238bf7c79463 100644
--- a/sysutils/fusefs-unionfs/Makefile
+++ b/sysutils/fusefs-unionfs/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= unionfs
-PORTVERSION= 0.24
+PORTVERSION= 0.26
CATEGORIES= sysutils
MASTER_SITES= http://podgorny.cz/unionfs-fuse/releases/
PKGNAMEPREFIX= fusefs-
@@ -12,17 +12,15 @@ MAINTAINER= clsung@FreeBSD.org
COMMENT= FUSE based implementation of the well-known unionfs
PLIST_FILES= bin/unionfs
+MAN8+= unionfs-fuse.8
-USES= fuse
-USE_BZIP2= yes
+USES= fuse cmake
+USE_XZ= yes
-do-build:
- (cd ${WRKSRC}/src && \
- ${CC} ${CFLAGS} -I${LOCALBASE}/include/fuse \
- -D_FILE_OFFSET_BITS=64 -DFUSE_USE_VERSION=26 -U_POSIX_SYNCHRONIZED_IO \
- -o unionfs *.c -L${LOCALBASE}/lib -pthread -lfuse -lm)
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/unionfs ${PREFIX}/bin
+post-patch:
+ @${REINPLACE_CMD} "s,share/man,man,g" ${WRKSRC}/man/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-unionfs/distinfo b/sysutils/fusefs-unionfs/distinfo
index 02255ca30852..ace19a45eb1e 100644
--- a/sysutils/fusefs-unionfs/distinfo
+++ b/sysutils/fusefs-unionfs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (unionfs-fuse-0.24.tar.bz2) = d8abc855eb618ac356b1e716599c82f8f0f74dbaee36d4062edc707567121937
-SIZE (unionfs-fuse-0.24.tar.bz2) = 30381
+SHA256 (unionfs-fuse-0.26.tar.xz) = 8d5c9dcb51ecb9a9b03890e16d17e37d602b0c1f23ed6a9ddec2b0f719c9f662
+SIZE (unionfs-fuse-0.26.tar.xz) = 38600
diff --git a/sysutils/fusefs-unionfs/files/patch-src__hashtable_itr.h b/sysutils/fusefs-unionfs/files/patch-src__hashtable_itr.h
deleted file mode 100644
index ab4f85100427..000000000000
--- a/sysutils/fusefs-unionfs/files/patch-src__hashtable_itr.h
+++ /dev/null
@@ -1,27 +0,0 @@
---- ./src/hashtable_itr.h.orig 2010-05-20 13:04:08.000000000 +0200
-+++ ./src/hashtable_itr.h 2013-05-27 18:27:15.594067901 +0200
-@@ -28,20 +28,14 @@
- /* hashtable_iterator_key
- * - return the value of the (key,value) pair at the current position */
-
--extern inline void *
--hashtable_iterator_key(struct hashtable_itr *i)
--{
-- return i->e->k;
--}
-+void *
-+hashtable_iterator_key(struct hashtable_itr *i);
-
- /*****************************************************************************/
- /* value - return the value of the (key,value) pair at the current position */
-
--extern inline void *
--hashtable_iterator_value(struct hashtable_itr *i)
--{
-- return i->e->v;
--}
-+void *
-+hashtable_iterator_value(struct hashtable_itr *i);
-
- /*****************************************************************************/
- /* advance - advance the iterator to the next element