aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-07-21 04:17:58 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-07-21 04:17:58 +0000
commit8c12f790cf6b06f3098a6b962ae52143e69e5a25 (patch)
tree2ee39e6bf075d37d209a48eb79e2126640ecf49d
parentee27b6e61d098de11f93aa594ee6d3dd3cad0038 (diff)
downloadports-8c12f790cf6b06f3098a6b962ae52143e69e5a25.tar.gz
ports-8c12f790cf6b06f3098a6b962ae52143e69e5a25.zip
Notes
-rw-r--r--games/megaglest/Makefile23
-rw-r--r--games/megaglest/distinfo4
-rw-r--r--games/megaglest/files/glest-wrapper.in27
-rw-r--r--games/megaglest/files/patch-CMakeLists.txt23
-rw-r--r--games/megaglest/files/pkg-message.in15
-rw-r--r--games/megaglest/pkg-plist6
6 files changed, 28 insertions, 70 deletions
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index eb33945ba7eb..0c93247d35ab 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= megaglest
-PORTVERSION= 3.4.0
+PORTVERSION= 3.5.2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/current_release/
-DISTNAME= ${PORTNAME}-source-${PORTVERSION}
+DISTNAME= ${PORTNAME}-source-${PORTVERSION}.3
MAINTAINER= smoeller@nichthelfer.de
COMMENT= Open source 3D real-time strategy game
@@ -21,9 +21,9 @@ LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
vorbis.4:${PORTSDIR}/audio/libvorbis
RUN_DEPENDS= ${DATADIR}/tutorials/basic_tutorial/basic_tutorial.xml:${PORTSDIR}/games/megaglest-data
-SUB_FILES= glest-wrapper pkg-message
+SUB_FILES= pkg-message
-USE_BZIP2= yes
+USE_XZ= yes
USE_CMAKE= yes
USE_DOS2UNIX= yes
USE_GL= yes
@@ -32,6 +32,8 @@ USE_OPENAL= al alut
USE_SDL= yes
USE_WX= 2.8+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
OPTIONS= EDITOR "Install MegaGlest Editor" off
.include <bsd.port.options.mk>
@@ -43,21 +45,20 @@ PLIST_SUB+= EDITOR="@comment "
.endif
do-install:
- ${STRIP_CMD} ${WRKSRC}/mk/linux/glest.bin
+ ${STRIP_CMD} ${WRKSRC}/mk/linux/megaglest
@${MKDIR} ${DATADIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.endif
- ${INSTALL_PROGRAM} ${WRKSRC}/mk/linux/glest.bin ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/mk/linux/megaglest ${PREFIX}/bin/${PORTNAME}
.for f in glest.ini glestkeys.ini servers.ini
${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
.endfor
- ${INSTALL_SCRIPT} ${WRKDIR}/glest-wrapper ${PREFIX}/bin/${PORTNAME}
-.if !defined(NOPORTDOCS)
- ${INSTALL_DATA} ${WRKSRC}/code_license.txt ${DOCSDIR}
-.endif
+.for f in AUTHORS.source_code.txt CHANGELOG.txt README.txt COPYRIGHT.source_code.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
.if defined(WITH_EDITOR)
- ${INSTALL_PROGRAM} ${WRKSRC}/mk/linux/glest_editor ${PREFIX}/bin/megaglest_editor
+ ${INSTALL_PROGRAM} ${WRKSRC}/mk/linux/megaglest_editor ${PREFIX}/bin/megaglest_editor
.endif
post-install:
diff --git a/games/megaglest/distinfo b/games/megaglest/distinfo
index 921542cc3ad0..6bd3e3ff5256 100644
--- a/games/megaglest/distinfo
+++ b/games/megaglest/distinfo
@@ -1,2 +1,2 @@
-SHA256 (megaglest-source-3.4.0.tar.bz2) = da17c210fb6c3c366bf0e2b44e243740008c3a6ad62f27d631002e46f0210654
-SIZE (megaglest-source-3.4.0.tar.bz2) = 899312
+SHA256 (megaglest-source-3.5.2.3.tar.xz) = 76e1c899aeffa54cbf0de38104a7bc4d6abcc5a504922636bfba4c44d9d40454
+SIZE (megaglest-source-3.5.2.3.tar.xz) = 1185872
diff --git a/games/megaglest/files/glest-wrapper.in b/games/megaglest/files/glest-wrapper.in
deleted file mode 100644
index 3b589277a91b..000000000000
--- a/games/megaglest/files/glest-wrapper.in
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-
-# The executable needs to be run from its data directory, and needs to store
-# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.megaglest3.4.0, and create symlinks to the data files.
-
-if [ -d ~/.megaglest3.4.0 ]
-then
- echo "Using existing ~/.megaglest3.4.0 directory."
-else
- echo "Creating ~/.megaglest3.4.0 directory."
- cd %%DATADIR%% || exit 1
- find * -type d -exec mkdir -p ~/.megaglest3.4.0/{} \;
- find * -type f -exec ln -s %%DATADIR%%/{} ~/.megaglest3.4.0/{} \; 2>/dev/null
- mkdir -p ~/.megaglest3.4.0/screens
- mkdir -p ~/.megaglest3.4.0/shaders/standard
- touch ~/.megaglest3.4.0/megaglest.log
- rm ~/.megaglest3.4.0/glest.ini ~/.megaglest3.4.0/megaglest ~/.megaglest3.4.0/servers.ini
- cp -f %%DATADIR%%/glest.ini ~/.megaglest3.4.0/
- cp -f %%DATADIR%%/glestkeys.ini ~/.megaglest3.4.0/
- cp -f %%DATADIR%%/servers.ini ~/.megaglest3.4.0/
- chmod 640 ~/.megaglest3.4.0/glest.ini ~/.megaglest3.4.0/servers.ini
-fi
-
-cd ~/.megaglest3.4.0 || exit 1
-echo "Please be patient while loading MegaGlest..."
-exec %%DATADIR%%/glest.bin "$@"
diff --git a/games/megaglest/files/patch-CMakeLists.txt b/games/megaglest/files/patch-CMakeLists.txt
deleted file mode 100644
index 1eff5478cda5..000000000000
--- a/games/megaglest/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,23 +0,0 @@
-*** CMakeLists.txt 2011-02-10 17:41:19.000000000 +0100
---- CMakeLists.txt_FreeBSD 2011-02-10 17:41:56.000000000 +0100
-*************** IF(CMAKE_COMPILER_IS_GNUCXX OR MINGW)
-*** 59,76 ****
-- OPTION(WANT_SVN_STAMP "use svn stamp" ON)
-- IF(WANT_SVN_STAMP)
-- # The stuff below gets SVN Global Revision # but ONLY when calling cmake!
-- # the FindSubversion.cmake module is part of the standard distribution
-- include(FindSubversion)
-- # extract working copy information for SOURCE_DIR into MY_XXX variables
-- Subversion_WC_INFO(${PROJECT_SOURCE_DIR} MG)
-- #add_definitions(-DSVNVERSION="${MG_WC_REVISION}")
-- ENDIF()
--
-- SET(SVN_VERSION_CMD "-DSVNVERSION='\\\"${MG_WC_REVISION}\\\"'")
--
-- IF(UNIX AND NOT APPLE)
-- # We do some funky character escaping to get the right stuff written out to
-- # the final Makefile so we get the SVN Global Revsion #
-- SET(SVN_VERSION_CMD "-DSVNVERSION='\\\"`svnversion -n ${PROJECT_SOURCE_DIR}`\\\"'")
-- ENDIF()
--
---- 58 ----
diff --git a/games/megaglest/files/pkg-message.in b/games/megaglest/files/pkg-message.in
index 892fefb92ca1..e07e44b0fc2c 100644
--- a/games/megaglest/files/pkg-message.in
+++ b/games/megaglest/files/pkg-message.in
@@ -1,16 +1,21 @@
###############################################################################
-The megaglest game has been installed:
+The megaglest game has been installed.
-1) You will find the megaglest configuration files in ~/.megaglest
+1) The megaglest configuration files are stored in ~/.megaglest.
-2) If you instlled the megaglest map editor you could lounch it like this:
+2) If you installed the megaglest map editor, you can launch it using the
+ command:
# megaglest_editor
-3) If you have problems running megaglest, you should remove your ~/.megaglest
- directory and try again
+3) If you have problems running megaglest, remove your ~/.megaglest directory
+ and try again.
4) Enjoy it ;)
+5) If you upgraded from version 3.4.0, your personal settings are stored in
+ ~/.megaglest3.4.0. If you copy glestuser.ini and glestuserkeys.ini to
+ ~/.megaglest, you will have your old settings again.
+
###############################################################################
diff --git a/games/megaglest/pkg-plist b/games/megaglest/pkg-plist
index dc026589fc99..c3c7eb50ee1d 100644
--- a/games/megaglest/pkg-plist
+++ b/games/megaglest/pkg-plist
@@ -1,9 +1,11 @@
%%EDITOR%%bin/megaglest_editor
bin/megaglest
-%%DATADIR%%/glest.bin
%%DATADIR%%/glest.ini
%%DATADIR%%/glestkeys.ini
%%DATADIR%%/servers.ini
-%%PORTDOCS%%%%DOCSDIR%%/code_license.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT.source_code.txt
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.txt
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.source_code.txt
%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
@dirrmtry %%DATADIR%%