aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-11-13 18:54:15 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-11-13 18:54:15 +0000
commit8c5957c9662fbc591589d4a8872d62537e880eef (patch)
tree48d897bf1a19672791912cffae6cf34334ccb9a2
parentfe3e63dcfc0468a6a907d8ebe1fca828365fe354 (diff)
downloadports-8c5957c9662fbc591589d4a8872d62537e880eef.tar.gz
ports-8c5957c9662fbc591589d4a8872d62537e880eef.zip
Notes
-rw-r--r--security/nikto/Makefile67
-rw-r--r--security/nikto/distinfo4
-rw-r--r--security/nikto/pkg-plist46
3 files changed, 67 insertions, 50 deletions
diff --git a/security/nikto/Makefile b/security/nikto/Makefile
index 62d2d92a260c..1ebcc0066900 100644
--- a/security/nikto/Makefile
+++ b/security/nikto/Makefile
@@ -1,14 +1,8 @@
-# New ports collection makefile for: nikto
-# Date created: 23 September 2002
-# Whom: pandzilla
-#
+# Created by: pandzilla
# $FreeBSD$
-#
-# $Tecnik: ports/security/nikto/Makefile,v 1.7 2005/12/13 16:26:20 itetcu Exp $
-#
PORTNAME= nikto
-PORTVERSION= 2.1.4
+PORTVERSION= 2.1.5
PORTEPOCH= 1
CATEGORIES= security www
MASTER_SITES= http://www.cirt.net/${PORTNAME}/ \
@@ -17,44 +11,53 @@ MASTER_SITES= http://www.cirt.net/${PORTNAME}/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Web and CGI vulnerability scanner with SSL support
-MAN1= nikto.1
+LICENSE= GPLv2
+
+OPTIONS_DEFINE= SSLEAY DOCS
+OPTIONS_DEFAULT=SSLEAY
+SSLEAY_DESC= Use NET::SSLeay for ssl scanning
-USE_BZIP2= yes
-USE_PERL5_RUN= yes
NO_BUILD= yes
-PORTDOCS= CHANGES.txt LICENSE.txt nikto.dtd nikto_manual.html
+USE_BZIP2= yes
+USE_PERL5_RUN= yes
-OPTIONS+= SSLEAY "Use NET::SSLeay for ssl scanning" on
+MAN1= nikto.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.ifdef(WITH_SSLEAY)
+.if ${PORT_OPTIONS:MSSLEAY}
RUN_DEPENDS+= p5-Net-SSLeay>0:${PORTSDIR}/security/p5-Net-SSLeay
.endif
post-patch:
- @${REINPLACE_CMD} -e "s|/usr/local/bin/perl|${PERL}|" \
- -e "s|/etc/nikto.conf|${PREFIX}/etc/nikto.conf|" ${WRKSRC}/nikto.pl
- @${REINPLACE_CMD} -Ee "s|# (EXECDIR=)/usr/local/nikto|\1${DATADIR}|g" \
- -e "s|# (PLUGINDIR=)/opt/nikto/plugins|\1${DATADIR}/plugins|g" \
- -e "s|# (TEMPLATEDIR=)/opt/nikto/templates|\1${DATADIR}/templates|g" \
- -e "s|# (DOCDIR=)/opt/nikto/docs|\1${DOCSDIR}|g" ${WRKSRC}/nikto.conf
+ @${REINPLACE_CMD} -e \
+ 's|/usr/local/bin/perl|${PERL}| ; \
+ s|/etc/nikto.conf|${PREFIX}/etc/nikto.conf|' ${WRKSRC}/nikto.pl
+ @${REINPLACE_CMD} -Ee \
+ 's|# (EXECDIR=).*/nikto|\1${DATADIR}| ; \
+ s|# (DBDIR=).*/databases|\1${DATADIR}/databases| ; \
+ s|# (PLUGINDIR=).*/plugins|\1${DATADIR}/plugins| ; \
+ s|# (TEMPLATEDIR=).*/templates|\1${DATADIR}/templates| ; \
+ s|# (DOCDIR=).*/docs|\1${DOCSDIR}|' ${WRKSRC}/nikto.conf
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/nikto.pl ${PREFIX}/bin/nikto
+ ${INSTALL_MAN} ${WRKSRC}/docs/nikto.1 ${PREFIX}/man/man1/nikto.1
${INSTALL_DATA} ${WRKSRC}/nikto.conf ${PREFIX}/etc/nikto.conf.sample
- ${INSTALL_MAN} ${WRKSRC}/docs/nikto.1 ${PREFIX}/man/man1/
- [ -f ${PREFIX}/etc/nikto.conf ] || \
- ${INSTALL_DATA} ${WRKSRC}/nikto.conf ${PREFIX}/etc/nikto.conf
-
- ( cd ${WRKSRC}/plugins && ${COPYTREE_SHARE} . ${DATADIR}/plugins )
- ( cd ${WRKSRC}/templates && ${COPYTREE_SHARE} . ${DATADIR}/templates )
-.if !defined(NOPORTDOCS)
+.if !exists(${PREFIX}/etc/nikto.conf)
+ (cd ${PREFIX}/etc && ${CP} -p nikto.conf.sample nikto.conf)
+.endif
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/replay.pl ${DATADIR}
+.for i in databases plugins templates
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${i} ${DATADIR})
+.endfor
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-. for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${DOCSDIR}
-. endfor
+.for i in CHANGES.txt LICENSE.txt nikto.dtd nikto_manual.html
+ ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${DOCSDIR}
+.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/nikto/distinfo b/security/nikto/distinfo
index 2c181769152e..c54aed058472 100644
--- a/security/nikto/distinfo
+++ b/security/nikto/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nikto-2.1.4.tar.bz2) = 9af930fea3f124e262d0e63977244b6bd19e22749f4defa818bb4d9b107ad603
-SIZE (nikto-2.1.4.tar.bz2) = 288160
+SHA256 (nikto-2.1.5.tar.bz2) = 65b99c1fdec14d1d5e7cbc964f70fce162cbec50aee878e1500e2d22df079b34
+SIZE (nikto-2.1.5.tar.bz2) = 311580
diff --git a/security/nikto/pkg-plist b/security/nikto/pkg-plist
index 71c5e7855963..a895226779ff 100644
--- a/security/nikto/pkg-plist
+++ b/security/nikto/pkg-plist
@@ -1,36 +1,47 @@
bin/nikto
-etc/nikto.conf
+@unexec if cmp -s %D/etc/nikto.conf %D/etc/nikto.conf.sample; then rm -f %D/etc/nikto.conf; fi
etc/nikto.conf.sample
+@exec if [ ! -f %D/etc/nikto.conf ] ; then cp -p %D/%F %B/nikto.conf; fi
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/nikto.dtd
+%%PORTDOCS%%%%DOCSDIR%%/nikto_manual.html
+%%DATADIR%%/databases/db_404_strings
+%%DATADIR%%/databases/db_content_search
+%%DATADIR%%/databases/db_dictionary
+%%DATADIR%%/databases/db_embedded
+%%DATADIR%%/databases/db_favicon
+%%DATADIR%%/databases/db_headers
+%%DATADIR%%/databases/db_httpoptions
+%%DATADIR%%/databases/db_multiple_index
+%%DATADIR%%/databases/db_outdated
+%%DATADIR%%/databases/db_parked_strings
+%%DATADIR%%/databases/db_realms
+%%DATADIR%%/databases/db_server_msgs
+%%DATADIR%%/databases/db_subdomains
+%%DATADIR%%/databases/db_tests
+%%DATADIR%%/databases/db_variables
+%%DATADIR%%/plugins/JSON-PP.pm
%%DATADIR%%/plugins/LW2.pm
-%%DATADIR%%/plugins/db_404_strings
-%%DATADIR%%/plugins/db_content_search
-%%DATADIR%%/plugins/db_embedded
-%%DATADIR%%/plugins/db_favicon
-%%DATADIR%%/plugins/db_headers
-%%DATADIR%%/plugins/db_httpoptions
-%%DATADIR%%/plugins/db_multiple_index
-%%DATADIR%%/plugins/db_outdated
-%%DATADIR%%/plugins/db_realms
-%%DATADIR%%/plugins/db_server_msgs
-%%DATADIR%%/plugins/db_subdomains
-%%DATADIR%%/plugins/db_tests
-%%DATADIR%%/plugins/db_variables
%%DATADIR%%/plugins/nikto_apache_expect_xss.plugin
%%DATADIR%%/plugins/nikto_apacheusers.plugin
%%DATADIR%%/plugins/nikto_auth.plugin
%%DATADIR%%/plugins/nikto_cgi.plugin
+%%DATADIR%%/plugins/nikto_clientaccesspolicy.plugin
%%DATADIR%%/plugins/nikto_content_search.plugin
%%DATADIR%%/plugins/nikto_cookies.plugin
%%DATADIR%%/plugins/nikto_core.plugin
-%%DATADIR%%/plugins/nikto_core.plugin.debug
%%DATADIR%%/plugins/nikto_dictionary_attack.plugin
%%DATADIR%%/plugins/nikto_embedded.plugin
%%DATADIR%%/plugins/nikto_favicon.plugin
+%%DATADIR%%/plugins/nikto_fileops.plugin
%%DATADIR%%/plugins/nikto_headers.plugin
%%DATADIR%%/plugins/nikto_httpoptions.plugin
%%DATADIR%%/plugins/nikto_msgs.plugin
%%DATADIR%%/plugins/nikto_multiple_index.plugin
%%DATADIR%%/plugins/nikto_outdated.plugin
+%%DATADIR%%/plugins/nikto_parked.plugin
+%%DATADIR%%/plugins/nikto_paths.plugin
%%DATADIR%%/plugins/nikto_put_del_test.plugin
%%DATADIR%%/plugins/nikto_report_csv.plugin
%%DATADIR%%/plugins/nikto_report_html.plugin
@@ -39,10 +50,11 @@ etc/nikto.conf.sample
%%DATADIR%%/plugins/nikto_report_text.plugin
%%DATADIR%%/plugins/nikto_report_xml.plugin
%%DATADIR%%/plugins/nikto_robots.plugin
-%%DATADIR%%/plugins/nikto_single.plugin
+%%DATADIR%%/plugins/nikto_siebel.plugin
%%DATADIR%%/plugins/nikto_ssl.plugin
%%DATADIR%%/plugins/nikto_subdomain.plugin
%%DATADIR%%/plugins/nikto_tests.plugin
+%%DATADIR%%/replay.pl
%%DATADIR%%/templates/htm_close.tmpl
%%DATADIR%%/templates/htm_end.tmpl
%%DATADIR%%/templates/htm_host_head.tmpl
@@ -60,4 +72,6 @@ etc/nikto.conf.sample
%%DATADIR%%/templates/xml_summary.tmpl
@dirrm %%DATADIR%%/templates
@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/databases
@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%