aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-06-20 16:58:07 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-06-20 16:58:07 +0000
commit8c604d65434089c0567c6c88ac6ed18e9bd4808f (patch)
tree96b1bc76d676964de59b217abd97f92fba8d12d5
parent6b7f34837ba4377869782d99d0d7acca73ec9887 (diff)
Notes
-rw-r--r--devel/cdk/Makefile3
-rw-r--r--devel/libcli/files/patch-Makefile8
2 files changed, 7 insertions, 4 deletions
diff --git a/devel/cdk/Makefile b/devel/cdk/Makefile
index c5c0412cf291..e046f6d80b8d 100644
--- a/devel/cdk/Makefile
+++ b/devel/cdk/Makefile
@@ -40,7 +40,8 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Makefile.in
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/doc/cdk|/share/doc/cdk| ; s|VERSION)|VERSION_MAJOR)|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|/doc/cdk|/share/doc/cdk| ; s|VERSION)|VERSION_MAJOR)|' \
+ -e 's|gcc|${CC}|g' ${WRKSRC}/Makefile.in
pre-install:
.if !defined(NOPORTEXAMPLES)
diff --git a/devel/libcli/files/patch-Makefile b/devel/libcli/files/patch-Makefile
index 099dab36e1b7..7b4683465af8 100644
--- a/devel/libcli/files/patch-Makefile
+++ b/devel/libcli/files/patch-Makefile
@@ -1,12 +1,14 @@
--- ./Makefile.orig 2011-05-04 04:52:15.000000000 +0200
-+++ ./Makefile 2011-05-04 06:51:14.794591784 +0200
-@@ -8,16 +8,14 @@
++++ ./Makefile 2011-06-20 18:57:17.703992054 +0200
+@@ -7,17 +7,15 @@
+ REVISION = 5
LIB = libcli.so
- CC = gcc
+-CC = gcc
-DEBUG = -g
-OPTIM = -O3
-CFLAGS += $(DEBUG) $(OPTIM) -Wall -Wformat-security -Wno-format-zero-length
++CC ?= gcc
+CFLAGS += -Wall -Wformat-security -Wno-format-zero-length
LDFLAGS += -shared
LIBPATH += -L.