aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-13 13:59:17 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-13 13:59:17 +0000
commit8c8318c1f8e3814042637acb7428b5881793d75f (patch)
tree2a3af2d73def63c15bf5e71e9d83631994398ec1
parent8d04c43989eb1a60fb47454be57234ec4e8b6a7a (diff)
security/amap: Fix harder
The arguments passed to the configuration script were getting initialized, so convert these to environment variables and augment the configure script patch to allow them to work as intended. Also fix a typo.
Notes
Notes: svn path=/head/; revision=422000
-rw-r--r--security/amap/Makefile6
-rw-r--r--security/amap/files/patch-configure22
2 files changed, 22 insertions, 6 deletions
diff --git a/security/amap/Makefile b/security/amap/Makefile
index e714f2d949a8..8a4a92deff25 100644
--- a/security/amap/Makefile
+++ b/security/amap/Makefile
@@ -12,9 +12,9 @@ COMMENT= Application mapper
USES= ssl
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- SSL_PATH=${OPENSSLLIB} \
- CRYPTO_PATH=${OPENSSLIB} \
+CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ENV= SSL_PATH=${OPENSSLLIB} \
+ CRYPTO_PATH=${OPENSSLLIB} \
SSL_IPATH=${OPENSSLINC}
MAKE_JOBS_UNSAFE= yes
diff --git a/security/amap/files/patch-configure b/security/amap/files/patch-configure
index 27dc668c031c..88889d20ed1c 100644
--- a/security/amap/files/patch-configure
+++ b/security/amap/files/patch-configure
@@ -1,6 +1,13 @@
---- configure.orig Wed Jun 29 17:40:57 2005
-+++ configure Wed Jun 29 17:41:18 2005
-@@ -29,7 +29,7 @@
+--- configure.orig 2005-06-03 13:34:19 UTC
++++ configure
+@@ -22,14 +22,11 @@ echo
+ echo "Starting amap auto configuration ..."
+ rm -f Makefile.in
+ PREFIX=""
+-SSL_PATH=""
+-SSL_IPATH=""
+-CRYPTO_PATH=""
+ NSL_PATH=""
SOCKET_PATH=""
MANDIR=""
LIBDIRS=`cat /etc/ld.so.conf 2> /dev/null`
@@ -9,3 +16,12 @@
echo
echo "Checking for openssl ..."
+@@ -80,7 +77,7 @@ if [ "X" = "X$SSL_IPATH" ]; then
+ CRYPTO_PATH=""
+ fi
+ if [ -n "$SSL_PATH" ]; then
+- echo " ... found"
++ echo " ... found: $SSL_PATH"
+ fi
+ if [ "X" = "X$SSL_PATH" ]; then
+ echo " ... NOT found, SSL support disabled"