aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-02-02 01:21:21 +0000
committerSteve Wills <swills@FreeBSD.org>2016-02-02 01:21:21 +0000
commit8d77480356f58d6d8d1c69884d1ba9cc98ed383a (patch)
tree3fb94109ce8b10a0157aeca70bbbd90cc8db7819
parentf0d6ce87a89b3b4e33c164564c6cd25e580b70ca (diff)
downloadports-8d77480356f58d6d8d1c69884d1ba9cc98ed383a.tar.gz
ports-8d77480356f58d6d8d1c69884d1ba9cc98ed383a.zip
Remove source and intermediate build output from intalled rubygem- ports
PR: 192949
Notes
Notes: svn path=/head/; revision=407788
-rw-r--r--Mk/bsd.ruby.mk5
-rw-r--r--accessibility/rubygem-atk/Makefile1
-rw-r--r--devel/rubygem-cairo-gobject/Makefile1
-rw-r--r--devel/rubygem-cairo-gobject/files/patch-ext_cairo-gobject_extconf.rb11
-rw-r--r--devel/rubygem-gio2/Makefile1
-rw-r--r--devel/rubygem-glib2/Makefile1
-rw-r--r--devel/rubygem-glib2/files/patch-lib_mkmf-gnome2.rb11
-rw-r--r--devel/rubygem-gobject-introspection/Makefile1
-rw-r--r--devel/rubygem-pkg-config/Makefile1
-rw-r--r--devel/rubygem-rbtrace/Makefile5
-rw-r--r--graphics/rubygem-cairo/Makefile2
-rw-r--r--graphics/rubygem-clutter-gtk/Makefile1
-rw-r--r--graphics/rubygem-clutter/Makefile1
-rw-r--r--graphics/rubygem-gdk_pixbuf2/Makefile1
-rw-r--r--graphics/rubygem-goocanvas/files/patch-ext_goocanvas_extconf.rb10
-rw-r--r--graphics/rubygem-rsvg2/Makefile1
-rw-r--r--graphics/rubygem-rsvg2/files/patch-ext_rsvg2_extconf.rb11
-rw-r--r--mail/milter-manager/Makefile6
-rw-r--r--mail/milter-manager/files/patch-configure11
-rw-r--r--multimedia/rubygem-clutter-gstreamer/Makefile1
-rw-r--r--multimedia/rubygem-gstreamer/Makefile1
-rw-r--r--textproc/rubygem-nokogiri/files/patch-ext_nokogiri_extconf.rb46
-rw-r--r--textproc/rubygem-nokogumbo/files/patch-ext_nokogumboc_extconf.rb16
-rw-r--r--www/rubygem-webkit-gtk/Makefile1
-rw-r--r--www/rubygem-webkit-gtk2/Makefile1
-rw-r--r--x11-toolkits/rubygem-gdk3/Makefile1
-rw-r--r--x11-toolkits/rubygem-gtk2/Makefile1
-rw-r--r--x11-toolkits/rubygem-gtk2/files/patch-ext_gtk2_extconf.rb11
-rw-r--r--x11-toolkits/rubygem-gtk3/Makefile1
-rw-r--r--x11-toolkits/rubygem-gtk3/files/patch-ext_gtk3_extconf.rb10
-rw-r--r--x11-toolkits/rubygem-gtksourceview2/Makefile1
-rw-r--r--x11-toolkits/rubygem-gtksourceview2/files/patch-ext_gtksourceview2_extconf.rb11
-rw-r--r--x11-toolkits/rubygem-gtksourceview3/Makefile1
-rw-r--r--x11-toolkits/rubygem-pango/Makefile1
-rw-r--r--x11-toolkits/rubygem-pango/files/patch-ext_pango_extconf.rb11
-rw-r--r--x11-toolkits/rubygem-poppler/Makefile2
-rw-r--r--x11-toolkits/rubygem-poppler/files/patch-ext_poppler_extconf.rb11
-rw-r--r--x11-toolkits/rubygem-vte/Makefile1
-rw-r--r--x11/rubygem-gnome2/Makefile1
39 files changed, 205 insertions, 7 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index f7b14399e966..c9750b7bbb3a 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -501,6 +501,10 @@ do-build:
do-install:
(cd ${BUILD_WRKSRC}; ${SETENV} ${GEM_ENV} ${RUBYGEMBIN} install ${RUBYGEM_ARGS} ${GEMFILES} -- --build-args ${CONFIGURE_ARGS})
${RM} -r ${STAGEDIR}${PREFIX}/${GEMS_BASE_DIR}/build_info/
+ ${FIND} ${STAGEDIR}${PREFIX}/${GEMS_BASE_DIR} -type f -name '*.so' -exec ${STRIP_CMD} {} +
+ ${FIND} ${STAGEDIR}${PREFIX}/${GEMS_BASE_DIR} -type f \( -name mkmf.log -or -name gem_make.out \) -print -delete
+ ${RM} -rf ${STAGEDIR}${PREFIX}/${GEM_LIB_DIR}/ext \
+ ${STAGEDIR}${PREFIX}/${CACHE_DIR} 2> /dev/null || ${TRUE}
${RMDIR} ${STAGEDIR}${PREFIX}/${EXT_DIR} 2> /dev/null || ${TRUE}
.if defined(NOPORTDOCS)
-@${RMDIR} ${STAGEDIR}${PREFIX}/${DOC_DIR}
@@ -509,7 +513,6 @@ do-install:
. if defined(RUBYGEM_AUTOPLIST)
. if !target(post-install-script)
post-install-script:
- @${ECHO} ${GEM_CACHE} >> ${TMPPLIST}
@${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
@${FIND} -ds ${STAGEDIR}${PREFIX}/${DOC_DIR} -type f -print | ${SED} -E -e \
diff --git a/accessibility/rubygem-atk/Makefile b/accessibility/rubygem-atk/Makefile
index 272a7f10b3f5..0fcdc5cf89ae 100644
--- a/accessibility/rubygem-atk/Makefile
+++ b/accessibility/rubygem-atk/Makefile
@@ -2,6 +2,7 @@
PORTNAME= atk
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= accessibility rubygems
MASTER_SITES= RG
diff --git a/devel/rubygem-cairo-gobject/Makefile b/devel/rubygem-cairo-gobject/Makefile
index 0c273dfebebd..02eaa1fa7883 100644
--- a/devel/rubygem-cairo-gobject/Makefile
+++ b/devel/rubygem-cairo-gobject/Makefile
@@ -2,6 +2,7 @@
PORTNAME= cairo-gobject
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
diff --git a/devel/rubygem-cairo-gobject/files/patch-ext_cairo-gobject_extconf.rb b/devel/rubygem-cairo-gobject/files/patch-ext_cairo-gobject_extconf.rb
new file mode 100644
index 000000000000..5b5403581805
--- /dev/null
+++ b/devel/rubygem-cairo-gobject/files/patch-ext_cairo-gobject_extconf.rb
@@ -0,0 +1,11 @@
+--- ext/cairo-gobject/extconf.rb.orig 2016-01-19 21:24:25 UTC
++++ ext/cairo-gobject/extconf.rb
+@@ -45,7 +45,7 @@ rescue LoadError
+ require "mkmf-gnome2"
+ end
+
+-["glib2"].each do |package|
++["glib2", "cairo"].each do |package|
+ directory = "#{package}#{version_suffix}"
+ build_dir = "#{directory}/tmp/#{RUBY_PLATFORM}/#{package}/#{RUBY_VERSION}"
+ add_depend_package(package, "#{directory}/ext/#{package}",
diff --git a/devel/rubygem-gio2/Makefile b/devel/rubygem-gio2/Makefile
index b3b1eb13ab12..e9d120fc9a3f 100644
--- a/devel/rubygem-gio2/Makefile
+++ b/devel/rubygem-gio2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gio2
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
diff --git a/devel/rubygem-glib2/Makefile b/devel/rubygem-glib2/Makefile
index fe23499627ee..14e938468c7f 100644
--- a/devel/rubygem-glib2/Makefile
+++ b/devel/rubygem-glib2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= glib2
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
diff --git a/devel/rubygem-glib2/files/patch-lib_mkmf-gnome2.rb b/devel/rubygem-glib2/files/patch-lib_mkmf-gnome2.rb
new file mode 100644
index 000000000000..0049361aa827
--- /dev/null
+++ b/devel/rubygem-glib2/files/patch-lib_mkmf-gnome2.rb
@@ -0,0 +1,11 @@
+--- lib/mkmf-gnome2.rb.orig 2016-01-19 21:17:20 UTC
++++ lib/mkmf-gnome2.rb
+@@ -152,7 +152,7 @@ end
+ def add_depend_package(target_name, target_srcdir, top_srcdir, options={})
+ gem_spec = find_gem_spec(target_name)
+ if gem_spec
+- target_source_dir = File.join(gem_spec.full_gem_path, "ext/#{target_name}")
++ target_source_dir = File.join(gem_spec.full_gem_path, "lib")
+ target_build_dir = target_source_dir
+ add_depend_package_path(target_name,
+ target_source_dir,
diff --git a/devel/rubygem-gobject-introspection/Makefile b/devel/rubygem-gobject-introspection/Makefile
index c5c51cf7e01b..61cedf64f6eb 100644
--- a/devel/rubygem-gobject-introspection/Makefile
+++ b/devel/rubygem-gobject-introspection/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gobject-introspection
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
diff --git a/devel/rubygem-pkg-config/Makefile b/devel/rubygem-pkg-config/Makefile
index cbb6082e1a4e..5f839e610a4a 100644
--- a/devel/rubygem-pkg-config/Makefile
+++ b/devel/rubygem-pkg-config/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pkg-config
PORTVERSION= 1.1.7
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
diff --git a/devel/rubygem-rbtrace/Makefile b/devel/rubygem-rbtrace/Makefile
index 855167bb3701..511bebe9f5aa 100644
--- a/devel/rubygem-rbtrace/Makefile
+++ b/devel/rubygem-rbtrace/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rbtrace
PORTVERSION= 0.4.8
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
@@ -20,8 +21,6 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-PLIST_FILES= bin/rbtrace \
- %%GEM_LIB_DIR%%/ext/src/msgpack-1.1.0/src/.libs/libmsgpack.la \
- %%GEM_LIB_DIR%%/ext/src/msgpack-1.1.0/src/.libs/libmsgpackc.la
+PLIST_FILES= bin/rbtrace
.include <bsd.port.mk>
diff --git a/graphics/rubygem-cairo/Makefile b/graphics/rubygem-cairo/Makefile
index 4d426c4c33e1..f4675da810f9 100644
--- a/graphics/rubygem-cairo/Makefile
+++ b/graphics/rubygem-cairo/Makefile
@@ -2,6 +2,7 @@
PORTNAME= cairo
PORTVERSION= 1.14.3
+PORTREVISION= 1
CATEGORIES= graphics rubygems
MASTER_SITES= RG
@@ -13,6 +14,7 @@ LICENSE_COMB= dual
RUN_DEPENDS= rubygem-pkg-config>=1.1.5:${PORTSDIR}/devel/rubygem-pkg-config
+USES= pkgconfig
USE_GNOME= cairo
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/graphics/rubygem-clutter-gtk/Makefile b/graphics/rubygem-clutter-gtk/Makefile
index 7d16ea4e04c0..06a2b86a038c 100644
--- a/graphics/rubygem-clutter-gtk/Makefile
+++ b/graphics/rubygem-clutter-gtk/Makefile
@@ -2,6 +2,7 @@
PORTNAME= clutter-gtk
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= graphics rubygems
MASTER_SITES= RG
diff --git a/graphics/rubygem-clutter/Makefile b/graphics/rubygem-clutter/Makefile
index 4fbba03240d2..a2696ed75ed6 100644
--- a/graphics/rubygem-clutter/Makefile
+++ b/graphics/rubygem-clutter/Makefile
@@ -2,6 +2,7 @@
PORTNAME= clutter
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= graphics rubygems
MASTER_SITES= RG
diff --git a/graphics/rubygem-gdk_pixbuf2/Makefile b/graphics/rubygem-gdk_pixbuf2/Makefile
index 1002828a9cb9..e9a64648b32a 100644
--- a/graphics/rubygem-gdk_pixbuf2/Makefile
+++ b/graphics/rubygem-gdk_pixbuf2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gdk_pixbuf2
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= graphics rubygems
MASTER_SITES= RG
diff --git a/graphics/rubygem-goocanvas/files/patch-ext_goocanvas_extconf.rb b/graphics/rubygem-goocanvas/files/patch-ext_goocanvas_extconf.rb
new file mode 100644
index 000000000000..d2de25a093ed
--- /dev/null
+++ b/graphics/rubygem-goocanvas/files/patch-ext_goocanvas_extconf.rb
@@ -0,0 +1,10 @@
+--- ext/goocanvas/extconf.rb.orig 2016-01-19 22:58:55 UTC
++++ ext/goocanvas/extconf.rb
+@@ -31,6 +31,7 @@ rescue LoadError
+ end
+
+ [
++ "cairo",
+ "glib2",
+ "atk",
+ "pango",
diff --git a/graphics/rubygem-rsvg2/Makefile b/graphics/rubygem-rsvg2/Makefile
index 8b70ddbd48ed..8ee7a5fb7900 100644
--- a/graphics/rubygem-rsvg2/Makefile
+++ b/graphics/rubygem-rsvg2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= rsvg2
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= graphics rubygems
MASTER_SITES= RG
diff --git a/graphics/rubygem-rsvg2/files/patch-ext_rsvg2_extconf.rb b/graphics/rubygem-rsvg2/files/patch-ext_rsvg2_extconf.rb
new file mode 100644
index 000000000000..f932833389cb
--- /dev/null
+++ b/graphics/rubygem-rsvg2/files/patch-ext_rsvg2_extconf.rb
@@ -0,0 +1,11 @@
+--- ext/rsvg2/extconf.rb.orig 2016-01-19 22:20:58 UTC
++++ ext/rsvg2/extconf.rb
+@@ -30,7 +30,7 @@ rescue LoadError
+ require 'mkmf-gnome2'
+ end
+
+-["glib2", "gdk_pixbuf2"].each do |package|
++["cairo", "glib2", "gdk_pixbuf2"].each do |package|
+ directory = "#{package}#{version_suffix}"
+ build_dir = "#{directory}/tmp/#{RUBY_PLATFORM}/#{package}/#{RUBY_VERSION}"
+ add_depend_package(package, "#{directory}/ext/#{package}",
diff --git a/mail/milter-manager/Makefile b/mail/milter-manager/Makefile
index fa4e72d8e03b..a4f5add55a93 100644
--- a/mail/milter-manager/Makefile
+++ b/mail/milter-manager/Makefile
@@ -3,6 +3,7 @@
PORTNAME= milter-manager
PORTVERSION= 2.0.7
+PORTREVERSION= 1
CATEGORIES= mail ruby
MASTER_SITES= SF/${PORTNAME}/${PORTNAME:S/-/%20/}/${PORTVERSION}
@@ -46,9 +47,10 @@ EXAMPLESDIR= ${WRKDIR}/examples
.endif
post-patch:
- ${FIND} ${WRKSRC} -type f -name Makefile.in -exec \
+ @${FIND} ${WRKSRC} -type f -name Makefile.in -exec \
${REINPLACE_CMD} -e "s#\$$(datadir)/@PACKAGE@#${DATADIR}#" \
-e "s#\$$(datarootdir)/\$$(PACKAGE)#${DATADIR}#" {} +
- ${REINPLACE_CMD} -e "s#\\\\\$$(pkgdatadir)/sample#${EXAMPLESDIR}#" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s#\\\\\$$(pkgdatadir)/sample#${EXAMPLESDIR}#" ${WRKSRC}/configure
+ @${RM} -r ${WRKSRC}/binding/ruby/glib-2.2.5
.include <bsd.port.mk>
diff --git a/mail/milter-manager/files/patch-configure b/mail/milter-manager/files/patch-configure
new file mode 100644
index 000000000000..73b3749bdcc6
--- /dev/null
+++ b/mail/milter-manager/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2016-01-20 02:07:12 UTC
++++ configure
+@@ -14169,7 +14169,7 @@ fi
+ end
+ end
+ ruby_glib2_path = ruby_glib2_gem.full_gem_path
+- print("-I ", File.join(ruby_glib2_path, "ext", "glib2"))')
++ print("-I ", File.join(ruby_glib2_path, "lib"))')
+ if test $? -eq 0; then
+ CFLAGS="$CFLAGS $RUBY_GLIB2_CFLAGS"
+ else
diff --git a/multimedia/rubygem-clutter-gstreamer/Makefile b/multimedia/rubygem-clutter-gstreamer/Makefile
index 043a7880b084..f10a90344daf 100644
--- a/multimedia/rubygem-clutter-gstreamer/Makefile
+++ b/multimedia/rubygem-clutter-gstreamer/Makefile
@@ -2,6 +2,7 @@
PORTNAME= clutter-gstreamer
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= multimedia rubygems
MASTER_SITES= RG
diff --git a/multimedia/rubygem-gstreamer/Makefile b/multimedia/rubygem-gstreamer/Makefile
index 0505bb02774a..e56cb87eeb4f 100644
--- a/multimedia/rubygem-gstreamer/Makefile
+++ b/multimedia/rubygem-gstreamer/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gstreamer
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= multimedia rubygems
MASTER_SITES= RG
diff --git a/textproc/rubygem-nokogiri/files/patch-ext_nokogiri_extconf.rb b/textproc/rubygem-nokogiri/files/patch-ext_nokogiri_extconf.rb
new file mode 100644
index 000000000000..bc615bd91578
--- /dev/null
+++ b/textproc/rubygem-nokogiri/files/patch-ext_nokogiri_extconf.rb
@@ -0,0 +1,46 @@
+--- ext/nokogiri/extconf.rb.orig 2015-07-26 20:13:45 UTC
++++ ext/nokogiri/extconf.rb
+@@ -584,6 +584,43 @@ if ENV['CPUPROFILE']
+ end
+ end
+
++$INSTALLFILES = [
++ ['html_document.h', '$(archdir)'],
++ ['html_element_description.h', '$(archdir)'],
++ ['html_entity_lookup.h', '$(archdir)'],
++ ['html_sax_parser_context.h', '$(archdir)'],
++ ['html_sax_push_parser.h', '$(archdir)'],
++ ['nokogiri.h', '$(archdir)'],
++ ['xml_attr.h', '$(archdir)'],
++ ['xml_attribute_decl.h', '$(archdir)'],
++ ['xml_cdata.h', '$(archdir)'],
++ ['xml_comment.h', '$(archdir)'],
++ ['xml_document.h', '$(archdir)'],
++ ['xml_document_fragment.h', '$(archdir)'],
++ ['xml_dtd.h', '$(archdir)'],
++ ['xml_element_content.h', '$(archdir)'],
++ ['xml_element_decl.h', '$(archdir)'],
++ ['xml_encoding_handler.h', '$(archdir)'],
++ ['xml_entity_decl.h', '$(archdir)'],
++ ['xml_entity_reference.h', '$(archdir)'],
++ ['xml_io.h', '$(archdir)'],
++ ['xml_libxml2_hacks.h', '$(archdir)'],
++ ['xml_namespace.h', '$(archdir)'],
++ ['xml_node.h', '$(archdir)'],
++ ['xml_node_set.h', '$(archdir)'],
++ ['xml_processing_instruction.h', '$(archdir)'],
++ ['xml_reader.h', '$(archdir)'],
++ ['xml_relax_ng.h', '$(archdir)'],
++ ['xml_sax_parser.h', '$(archdir)'],
++ ['xml_sax_parser_context.h', '$(archdir)'],
++ ['xml_sax_push_parser.h', '$(archdir)'],
++ ['xml_schema.h', '$(archdir)'],
++ ['xml_syntax_error.h', '$(archdir)'],
++ ['xml_text.h', '$(archdir)'],
++ ['xml_xpath_context.h', '$(archdir)'],
++ ['xslt_stylesheet.h', '$(archdir)'],
++]
++
+ create_makefile('nokogiri/nokogiri')
+
+ if enable_config('clean', true)
diff --git a/textproc/rubygem-nokogumbo/files/patch-ext_nokogumboc_extconf.rb b/textproc/rubygem-nokogumbo/files/patch-ext_nokogumboc_extconf.rb
new file mode 100644
index 000000000000..65ab7235d9a4
--- /dev/null
+++ b/textproc/rubygem-nokogumbo/files/patch-ext_nokogumboc_extconf.rb
@@ -0,0 +1,16 @@
+--- ext/nokogumboc/extconf.rb.orig 2015-07-26 21:04:54 UTC
++++ ext/nokogumboc/extconf.rb
+@@ -1,3 +1,4 @@
++require 'rubygems'
+ require 'mkmf'
+ $CFLAGS += " -std=c99"
+
+@@ -10,7 +11,7 @@ if have_library('xml2', 'xmlNewDoc')
+ select { |name| name.match(%r{gems/nokogiri-([\d.]+)/lib/nokogiri}) }.
+ sort_by {|name| name[/nokogiri-([\d.]+)/,1].split('.').map(&:to_i)}.last
+ if nokogiri_lib
+- nokogiri_ext = nokogiri_lib.sub(%r(lib/nokogiri(.rb)?$), 'ext/nokogiri')
++ nokogiri_ext = Gem::Specification.find_by_name('nokogiri').extension_dir + "/nokogiri"
+
+ # if that doesn't work, try workarounds found in Nokogiri's extconf
+ unless find_header('nokogiri.h', nokogiri_ext)
diff --git a/www/rubygem-webkit-gtk/Makefile b/www/rubygem-webkit-gtk/Makefile
index ea25b42b45a0..96094dac3822 100644
--- a/www/rubygem-webkit-gtk/Makefile
+++ b/www/rubygem-webkit-gtk/Makefile
@@ -2,6 +2,7 @@
PORTNAME= webkit-gtk
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= www rubygems
MASTER_SITES= RG
diff --git a/www/rubygem-webkit-gtk2/Makefile b/www/rubygem-webkit-gtk2/Makefile
index 8b508ddf285f..e98b6d8abd89 100644
--- a/www/rubygem-webkit-gtk2/Makefile
+++ b/www/rubygem-webkit-gtk2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= webkit-gtk2
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= www rubygems
MASTER_SITES= RG
diff --git a/x11-toolkits/rubygem-gdk3/Makefile b/x11-toolkits/rubygem-gdk3/Makefile
index 712eaddeec2a..937b39722bb4 100644
--- a/x11-toolkits/rubygem-gdk3/Makefile
+++ b/x11-toolkits/rubygem-gdk3/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gdk3
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= x11-toolkits rubygems
MASTER_SITES= RG
diff --git a/x11-toolkits/rubygem-gtk2/Makefile b/x11-toolkits/rubygem-gtk2/Makefile
index 128bbdc19325..309ea009a881 100644
--- a/x11-toolkits/rubygem-gtk2/Makefile
+++ b/x11-toolkits/rubygem-gtk2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gtk2
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= x11-toolkits rubygems
MASTER_SITES= RG
diff --git a/x11-toolkits/rubygem-gtk2/files/patch-ext_gtk2_extconf.rb b/x11-toolkits/rubygem-gtk2/files/patch-ext_gtk2_extconf.rb
new file mode 100644
index 000000000000..5c474edb399b
--- /dev/null
+++ b/x11-toolkits/rubygem-gtk2/files/patch-ext_gtk2_extconf.rb
@@ -0,0 +1,11 @@
+--- ext/gtk2/extconf.rb.orig 2016-01-19 22:27:15 UTC
++++ ext/gtk2/extconf.rb
+@@ -33,7 +33,7 @@ end
+
+ have_func("rb_errinfo")
+
+-["glib2", "atk", "pango", "gdk_pixbuf2"].each do |package|
++["cairo", "glib2", "atk", "pango", "gdk_pixbuf2"].each do |package|
+ directory = "#{package}#{version_suffix}"
+ build_dir = "#{directory}/tmp/#{RUBY_PLATFORM}/#{package}/#{RUBY_VERSION}"
+ add_depend_package(package, "#{directory}/ext/#{package}",
diff --git a/x11-toolkits/rubygem-gtk3/Makefile b/x11-toolkits/rubygem-gtk3/Makefile
index f754937d4a2d..c3197f48fdd5 100644
--- a/x11-toolkits/rubygem-gtk3/Makefile
+++ b/x11-toolkits/rubygem-gtk3/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gtk3
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= x11-toolkits rubygems
MASTER_SITES= RG
diff --git a/x11-toolkits/rubygem-gtk3/files/patch-ext_gtk3_extconf.rb b/x11-toolkits/rubygem-gtk3/files/patch-ext_gtk3_extconf.rb
new file mode 100644
index 000000000000..58d36bbc1abf
--- /dev/null
+++ b/x11-toolkits/rubygem-gtk3/files/patch-ext_gtk3_extconf.rb
@@ -0,0 +1,10 @@
+--- ext/gtk3/extconf.rb.orig 2016-01-22 18:41:23.871812000 +0000
++++ ext/gtk3/extconf.rb 2016-01-22 18:43:47.587265000 +0000
+@@ -39,6 +39,7 @@
+ require "mkmf-gnome2"
+
+ depended_packages = [
++ "cairo",
+ "glib2",
+ "gobject-introspection",
+ "cairo-gobject",
diff --git a/x11-toolkits/rubygem-gtksourceview2/Makefile b/x11-toolkits/rubygem-gtksourceview2/Makefile
index 98f875696600..771ed7cea4a6 100644
--- a/x11-toolkits/rubygem-gtksourceview2/Makefile
+++ b/x11-toolkits/rubygem-gtksourceview2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gtksourceview2
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= x11-toolkits rubygems
MASTER_SITES= RG
diff --git a/x11-toolkits/rubygem-gtksourceview2/files/patch-ext_gtksourceview2_extconf.rb b/x11-toolkits/rubygem-gtksourceview2/files/patch-ext_gtksourceview2_extconf.rb
new file mode 100644
index 000000000000..83af7f9ab269
--- /dev/null
+++ b/x11-toolkits/rubygem-gtksourceview2/files/patch-ext_gtksourceview2_extconf.rb
@@ -0,0 +1,11 @@
+--- ext/gtksourceview2/extconf.rb.orig 2016-01-19 22:46:22 UTC
++++ ext/gtksourceview2/extconf.rb
+@@ -30,7 +30,7 @@ rescue LoadError
+ require 'mkmf-gnome2'
+ end
+
+-["glib2", "atk", "pango", "gdk_pixbuf2", "gtk2"].each do |package|
++["cairo", "glib2", "atk", "pango", "gdk_pixbuf2", "gtk2"].each do |package|
+ directory = "#{package}#{version_suffix}"
+ build_dir = "#{directory}/tmp/#{RUBY_PLATFORM}/#{package}/#{RUBY_VERSION}"
+ add_depend_package(package, "#{directory}/ext/#{package}",
diff --git a/x11-toolkits/rubygem-gtksourceview3/Makefile b/x11-toolkits/rubygem-gtksourceview3/Makefile
index 6d11ebcb51ec..52a51b23113e 100644
--- a/x11-toolkits/rubygem-gtksourceview3/Makefile
+++ b/x11-toolkits/rubygem-gtksourceview3/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gtksourceview3
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= x11-toolkits rubygems
MASTER_SITES= RG
diff --git a/x11-toolkits/rubygem-pango/Makefile b/x11-toolkits/rubygem-pango/Makefile
index 52fab6867fb2..c75a0e652cc0 100644
--- a/x11-toolkits/rubygem-pango/Makefile
+++ b/x11-toolkits/rubygem-pango/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pango
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= x11-toolkits rubygems
MASTER_SITES= RG
diff --git a/x11-toolkits/rubygem-pango/files/patch-ext_pango_extconf.rb b/x11-toolkits/rubygem-pango/files/patch-ext_pango_extconf.rb
new file mode 100644
index 000000000000..e88fb0378100
--- /dev/null
+++ b/x11-toolkits/rubygem-pango/files/patch-ext_pango_extconf.rb
@@ -0,0 +1,11 @@
+--- ext/pango/extconf.rb.orig 2016-01-19 22:13:22 UTC
++++ ext/pango/extconf.rb
+@@ -33,7 +33,7 @@ end
+ ruby_header = "ruby.h"
+ have_func("rb_errinfo", ruby_header)
+
+-["glib2"].each do |package|
++["cairo", "pango", "glib2"].each do |package|
+ directory = "#{package}#{version_suffix}"
+ build_dir = "#{directory}/tmp/#{RUBY_PLATFORM}/#{package}/#{RUBY_VERSION}"
+ add_depend_package(package, "#{directory}/ext/#{package}",
diff --git a/x11-toolkits/rubygem-poppler/Makefile b/x11-toolkits/rubygem-poppler/Makefile
index 4be3dba5a21d..4ed0a609c15e 100644
--- a/x11-toolkits/rubygem-poppler/Makefile
+++ b/x11-toolkits/rubygem-poppler/Makefile
@@ -2,7 +2,7 @@
PORTNAME= poppler
PORTVERSION= 3.0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits rubygems
MASTER_SITES= RG
diff --git a/x11-toolkits/rubygem-poppler/files/patch-ext_poppler_extconf.rb b/x11-toolkits/rubygem-poppler/files/patch-ext_poppler_extconf.rb
new file mode 100644
index 000000000000..bd197107833b
--- /dev/null
+++ b/x11-toolkits/rubygem-poppler/files/patch-ext_poppler_extconf.rb
@@ -0,0 +1,11 @@
+--- ext/poppler/extconf.rb.orig 2016-01-19 22:11:59 UTC
++++ ext/poppler/extconf.rb
+@@ -30,7 +30,7 @@ rescue LoadError
+ require 'mkmf-gnome2'
+ end
+
+-["glib2", "atk", "gdk_pixbuf2"].each do |package|
++["cairo", "glib2", "atk", "gdk_pixbuf2"].each do |package|
+ directory = "#{package}#{version_suffix}"
+ build_dir = "#{directory}/tmp/#{RUBY_PLATFORM}/#{package}/#{RUBY_VERSION}"
+ add_depend_package(package, "#{directory}/ext/#{package}",
diff --git a/x11-toolkits/rubygem-vte/Makefile b/x11-toolkits/rubygem-vte/Makefile
index 87ce8d295f60..7e8310bbf190 100644
--- a/x11-toolkits/rubygem-vte/Makefile
+++ b/x11-toolkits/rubygem-vte/Makefile
@@ -2,6 +2,7 @@
PORTNAME= vte
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= x11-toolkits rubygems
MASTER_SITES= RG
diff --git a/x11/rubygem-gnome2/Makefile b/x11/rubygem-gnome2/Makefile
index 057e81d60126..1d6143f9f878 100644
--- a/x11/rubygem-gnome2/Makefile
+++ b/x11/rubygem-gnome2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gnome2
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= x11 gnome rubygems
PKGNAMEPREFIX= rubygem-