aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2014-05-31 05:07:19 +0000
committerWen Heping <wen@FreeBSD.org>2014-05-31 05:07:19 +0000
commit8ddd44229bf2b62ca9413319d6f624db46966fb0 (patch)
tree7532454d30852324165c739998688c7f22d4b6dc
parent7869f4665f9e8dd6d0982b90846953e793f9fcee (diff)
downloadports-8ddd44229bf2b62ca9413319d6f624db46966fb0.tar.gz
ports-8ddd44229bf2b62ca9413319d6f624db46966fb0.zip
Notes
-rw-r--r--textproc/py-paragrep/Makefile19
-rw-r--r--textproc/py-paragrep/distinfo4
-rw-r--r--textproc/py-paragrep/files/patch-setup.py22
3 files changed, 11 insertions, 34 deletions
diff --git a/textproc/py-paragrep/Makefile b/textproc/py-paragrep/Makefile
index 44f222dc5acb..2c5f8d02be25 100644
--- a/textproc/py-paragrep/Makefile
+++ b/textproc/py-paragrep/Makefile
@@ -2,26 +2,25 @@
# $FreeBSD$
PORTNAME= paragrep
-PORTVERSION= 3.0.5
+PORTVERSION= 3.1.1
CATEGORIES= textproc python
-MASTER_SITES= http://github.com/bmc/paragrep/zipball/release-3.0.5/
+MASTER_SITES= http://github.com/bmc/paragrep/zipball/release-${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= bmc-${PORTNAME}-48708ef
MAINTAINER= wen@FreeBSD.org
COMMENT= Paragraph Grep Utility
+LICENSE= BSD3CLAUSE
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}grizzled>=0.8.1:${PORTSDIR}/devel/py-grizzled
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= zip
+WRKSRC= ${WRKDIR}/bmc-${PORTNAME}-e7d5553
USE_PYTHON= yes
-USE_PYDISTUTILS=easy_install
-
-MAN1= paragrep.1
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST=yes
-NO_STAGE= yes
-post-install:
- @${INSTALL_MAN} ${WRKSRC}/man/paragrep.1 ${PREFIX}/man/man1/
+post-patch:
+ @${REINPLACE_CMD} -e "s|'man'|'man/man1'|g" ${WRKSRC}/setup.py
.include <bsd.port.mk>
diff --git a/textproc/py-paragrep/distinfo b/textproc/py-paragrep/distinfo
index e0e9ea8a264a..1302c6fb18b6 100644
--- a/textproc/py-paragrep/distinfo
+++ b/textproc/py-paragrep/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bmc-paragrep-48708ef.zip) = f86ed36d8168c68beff3a82fd3e61b6b0afbefb3eac82540429d98e120caa86e
-SIZE (bmc-paragrep-48708ef.zip) = 24068
+SHA256 (paragrep-3.1.1.tar.gz) = 4bbe39dd7cdf9d39212b75a5536bbf73f43e59911abde1f8c8ae208a42f1091a
+SIZE (paragrep-3.1.1.tar.gz) = 17284
diff --git a/textproc/py-paragrep/files/patch-setup.py b/textproc/py-paragrep/files/patch-setup.py
deleted file mode 100644
index 6ba55d34ca08..000000000000
--- a/textproc/py-paragrep/files/patch-setup.py
+++ /dev/null
@@ -1,22 +0,0 @@
---- setup.py.orig 2010-03-28 18:26:24.000000000 +0800
-+++ setup.py 2010-03-29 15:07:17.000000000 +0800
-@@ -9,8 +9,8 @@
- import os
- sys.path += [os.getcwd()]
-
--import ez_setup
--ez_setup.use_setuptools(download_delay=2)
-+#import ez_setup
-+#ez_setup.use_setuptools(download_delay=2)
- from setuptools import setup, find_packages
- import re
- import imp
-@@ -54,7 +54,7 @@
- author_email = info['__email__'],
- entry_points = {'console_scripts' : 'paragrep=paragrep:main'},
- install_requires = ['grizzled>=0.8.1', ],
-- data_files = [('man', ['man/paragrep.1'])],
-+# data_files = [('man', ['man/paragrep.1'])],
- classifiers = [
- 'Intended Audience :: Developers',
- 'Intended Audience :: System Administrators',