aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-04-17 19:23:40 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-04-17 19:23:40 +0000
commit8e84e20a52ef6f75962e2f4e6153c4aae1e6fe8d (patch)
tree68e1882f30a4f2e5bc1c9058a031680b2cc8e00c
parentb1515bc1cd6beb6916b54082f94ed267615320e7 (diff)
downloadports-8e84e20a52ef6f75962e2f4e6153c4aae1e6fe8d.tar.gz
ports-8e84e20a52ef6f75962e2f4e6153c4aae1e6fe8d.zip
Notes
-rw-r--r--audio/xmms-eq/Makefile24
-rw-r--r--audio/xmms-eq/distinfo6
-rw-r--r--audio/xmms-eq/files/patch-configure79
-rw-r--r--audio/xmms-eq/pkg-descr3
-rw-r--r--audio/xmms-eq/pkg-message27
5 files changed, 59 insertions, 80 deletions
diff --git a/audio/xmms-eq/Makefile b/audio/xmms-eq/Makefile
index 8b8d06013245..c96cd7497826 100644
--- a/audio/xmms-eq/Makefile
+++ b/audio/xmms-eq/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= eq
-PORTVERSION= 0.6
-PORTREVISION= 1
+PORTVERSION= 0.7
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= equ
@@ -19,28 +18,35 @@ COMMENT= A realtime graphical equalizer plugin for XMMS
LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
-USE_BZIP2= yes
-USE_REINPLACE= yes
USE_X_PREFIX= yes
+USE_BZIP2= yes
USE_GNOME= gtk12
GNU_CONFIGURE= yes
PLIST_FILES= lib/xmms/Effect/libeq.la \
lib/xmms/Effect/libeq.so
-OPTIONS= OPTIMIZED_CFLAGS "use optimized C flags" on \
- EXT_INSTRUCTIONS "use MMX/SSE/SSE2 instructions if available" on
+OPTIONS= BENCHMARK "Enable counting the cycles used by the IIR" off \
+ EXT_INS "Use MMX/SSE/SSE2 instructions if available" on \
+ OPTIMIZED_CFLAGS "Enable compilation optimizations" on
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_EXT_INSTRUCTIONS) || defined(PACKAGE_BUILDING)
+.if defined(WITH_BENCHMARK)
+CONFIGURE_ARGS+= --enable-benchmark
+.endif
+
+.if defined(WITHOUT_EXT_INS) || defined(PACKAGE_BUILDING)
CONFIGURE_ARGS+= --disable-autodetect
.endif
.if defined(WITHOUT_OPTIMIZED_CFLAGS)
post-patch:
- @${REINPLACE_CMD} -e 's|-O3||g; s|-fomit-frame-pointer||g; \
- s|-finline-functions||g; s|-ffast-math||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O3||g; \
+ s|-fomit-frame-pointer||g; \
+ s|-finline-functions||g; \
+ s|-ffast-math||g' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif
post-install:
diff --git a/audio/xmms-eq/distinfo b/audio/xmms-eq/distinfo
index bb85b7dadf2a..651fec34f9e8 100644
--- a/audio/xmms-eq/distinfo
+++ b/audio/xmms-eq/distinfo
@@ -1,3 +1,3 @@
-MD5 (eq-xmms-0.6.tar.bz2) = 9176ecf7a4d3e7016ce662c207844ec8
-SHA256 (eq-xmms-0.6.tar.bz2) = b3913cf612bc95de5f64cc2aa37491f678ba6104eaec394f0732bde476bbc20c
-SIZE (eq-xmms-0.6.tar.bz2) = 421407
+MD5 (eq-xmms-0.7.tar.bz2) = 6f904428d8580eef8e82afbf81c61ee5
+SHA256 (eq-xmms-0.7.tar.bz2) = 3efffeeb299fadb9f315618d51118f653c1fa8d86a5766c22823d7c47e86ad21
+SIZE (eq-xmms-0.7.tar.bz2) = 500447
diff --git a/audio/xmms-eq/files/patch-configure b/audio/xmms-eq/files/patch-configure
index 899d96e624fa..061c3e8bff53 100644
--- a/audio/xmms-eq/files/patch-configure
+++ b/audio/xmms-eq/files/patch-configure
@@ -1,56 +1,25 @@
---- configure.orig Sun May 16 03:59:17 2004
-+++ configure Thu Jun 30 02:09:17 2005
-@@ -9664,7 +9664,7 @@
- sse2=no
- fi;
+--- configure.orig Sun Oct 16 15:36:00 2005
++++ configure Wed Apr 12 23:30:52 2006
+@@ -21457,6 +21457,9 @@
+ case "$host" in
+ i386-*-freebsd*)
+ ARCH_DEFINES="-DARCH_X86"
++ if test "x$benchmark" = xyes -a -n "`grep '^CPU:.*[56]86-class' /var/run/dmesg.boot`"; then
++ XF_CFLAGS="$XF_CFLAGS -DBENCHMARK"
++ fi
+ ;;
+ i386-*-openbsd* | i386-*-netbsd*)
+ ARCH_DEFINES="-DARCH_X86"
+@@ -21527,9 +21530,9 @@
--ARCH_DEFINES_DEFAULT="-DARCH_X86"
-+ARCH_DEFINES_DEFAULT=""
- if test "x$debug" = xyes; then
- XF_CFLAGS="-Wall -g -O2 -DDEBUG $XF_CFLAGS"
- else
-@@ -9689,10 +9689,10 @@
- fi
-
- have_solaris=no
--arch_type=ix86
--SSE_RES=`cat /proc/cpuinfo|grep sse`
--SSE2_RES=`cat /proc/cpuinfo|grep sse2`
--MMX_RES=`cat /proc/cpuinfo|grep mmx`
-+arch_type=unknown
-+SSE_RES=`grep 'Features=.*[<,]SSE[>,]' /var/run/dmesg.boot`
-+SSE2_RES=`grep 'Features=.*[<,]SSE2[>,]' /var/run/dmesg.boot`
-+MMX_RES=`grep 'Features=.*[<,]MMX[>,]' /var/run/dmesg.boot`
- ARCH_DEFINES=""
-
- if test "x$mmx" = xyes; then
-@@ -9708,27 +9708,8 @@
- if test "x$debug" = xno; then
- case "$host" in
- i386-*-* | i86pc-*-*)
-- ;;
-- i486-*-*)
-- ARCH_DEFINES="-march=i486"
-- ;;
-- i586-*-*)
-- ARCH_DEFINES="-march=i586"
-- if test "x$benchmark" = xyes; then
-- XF_CFLAGS="$XF_CFLAGS -DBENCHMARK"
-- fi
-- if test "x$autodetect" = xyes; then
-- if test "x$MMX_RES" != x; then
-- mmx=yes
-- fi
-- fi
-- if test "x$mmx" = xyes; then
-- autodetect=no
-- ARCH_DEFINES="$ARCH_DEFINES -m3dnow -mmmx"
-- fi
-- ;;
-- i686-*-*)
-- ARCH_DEFINES="-march=i686"
-+ ARCH_DEFINES_DEFAULT="-DARCH_X86"
-+ arch_type=ix86
- if test "x$benchmark" = xyes; then
- XF_CFLAGS="$XF_CFLAGS -DBENCHMARK"
- fi
+ case "$host" in
+ i386-*-freebsd*)
+- SSE_RES=`grep 'Features=.*<,SSE>,' /var/run/dmesg.boot`
+- SSE2_RES=`grep 'Features=.*<,SSE2>,' /var/run/dmesg.boot`
+- MMX_RES=`grep 'Features=.*<,MMX>,' /var/run/dmesg.boot`
++ SSE_RES=`grep 'Features=.*[<,]SSE[>,]' /var/run/dmesg.boot`
++ SSE2_RES=`grep 'Features=.*[<,]SSE2[>,]' /var/run/dmesg.boot`
++ MMX_RES=`grep 'Features=.*[<,]MMX[>,]' /var/run/dmesg.boot`
+ ;;
+ i386-*-openbsd* | i386-*-netbsd*)
+ autodetect=no
diff --git a/audio/xmms-eq/pkg-descr b/audio/xmms-eq/pkg-descr
index 7b00164a1339..831603888ed4 100644
--- a/audio/xmms-eq/pkg-descr
+++ b/audio/xmms-eq/pkg-descr
@@ -1,6 +1,3 @@
EQ is a realtime graphical equalizer plugin for XMMS.
WWW: http://equ.sourceforge.net/
-
-- Alejandro Pulver
-alejandro@varnet.biz
diff --git a/audio/xmms-eq/pkg-message b/audio/xmms-eq/pkg-message
index b6cb4775db08..832f24883c8b 100644
--- a/audio/xmms-eq/pkg-message
+++ b/audio/xmms-eq/pkg-message
@@ -1,19 +1,26 @@
+==============================================================================
+
XMMS-EQ has been installed.
-***WARNING***
+*** WARNING ***
+
+This plugin crashes XMMS when you try to disable it from the GUI.
-This plugin may crash XMMS with the message "Segmentation fault" when enabling
-or disabling it from the GUI.
+The temporary solution for this is to manually edit the XMMS configuration
+file (usually "~/.xmms/config") and remove "libeq.so" from the variable
+"enabled_eplugins" in the section "xmms". For example:
-The temporary solution for this is to edit the XMMS configuration file
-directly. It is usually located at "~/.xmms/config". The section that
-indicates the effect plugins to load is called "xmms". To enable or disable it
-just add or remove the string "libeq.so" to the variable "enabled_eplugins".
+When it is enabled it looks like this.
+
+[xmms]
+enabled_eplugins=libeq.so,libecho.so
-For example (XMMS-EQ is enabled):
+To disable it remove "libeq.so". Like this.
[xmms]
+enabled_eplugins=libecho.so
-enabled_eplugins=libeq.so
+If "libeq.so" is the only component of the variable, you can remove the whole
+line.
-***WARNING***
+==============================================================================