aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-05-08 17:05:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-05-08 17:05:39 +0000
commit8e94c4eb8b07dbe083b28a18c49c443328755f3c (patch)
treed07ea930e22a21cc40cd022006c8b074df819f7b
parentb7f44fcd2dc39c7394cee7b66a269a8e9e375ad0 (diff)
downloadports-8e94c4eb8b07dbe083b28a18c49c443328755f3c.tar.gz
ports-8e94c4eb8b07dbe083b28a18c49c443328755f3c.zip
Notes
-rw-r--r--sysutils/pacman/Makefile7
-rw-r--r--sysutils/pacman/distinfo5
-rw-r--r--sysutils/pacman/files/patch-lib_libalpm_util.c10
-rw-r--r--sysutils/pacman/pkg-plist74
4 files changed, 84 insertions, 12 deletions
diff --git a/sysutils/pacman/Makefile b/sysutils/pacman/Makefile
index 30a06af7953a..5b087ae3d6ba 100644
--- a/sysutils/pacman/Makefile
+++ b/sysutils/pacman/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= pacman
-PORTVERSION= 4.2.0
-PORTREVISION= 3
+PORTVERSION= 5.0.2
CATEGORIES= sysutils
-MASTER_SITES= ftp://ftp.archlinux.org/other/pacman/ \
- http://mirror.amdmi3.ru/distfiles/
+MASTER_SITES= https://sources.archlinux.org/other/${PORTNAME}/ \
+ https://mirror.amdmi3.ru/distfiles/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Package manager from ArchLinux
diff --git a/sysutils/pacman/distinfo b/sysutils/pacman/distinfo
index 180409b9d1de..842d90d432ac 100644
--- a/sysutils/pacman/distinfo
+++ b/sysutils/pacman/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pacman-4.2.0.tar.gz) = 941aca897db3218f0cb4036de13422d74212afbcdbf4a7cd7074a7128e196a22
-SIZE (pacman-4.2.0.tar.gz) = 2934713
+TIMESTAMP = 1524684365
+SHA256 (pacman-5.0.2.tar.gz) = dfd36086ad68564bcd977f4a1fafe51dd328acd4a95093ac4bf1249be9c41f0e
+SIZE (pacman-5.0.2.tar.gz) = 3361701
diff --git a/sysutils/pacman/files/patch-lib_libalpm_util.c b/sysutils/pacman/files/patch-lib_libalpm_util.c
new file mode 100644
index 000000000000..427d5dd4c7aa
--- /dev/null
+++ b/sysutils/pacman/files/patch-lib_libalpm_util.c
@@ -0,0 +1,10 @@
+--- lib/libalpm/util.c.orig 2017-05-18 11:10:47 UTC
++++ lib/libalpm/util.c
+@@ -32,6 +32,7 @@
+ #include <sys/wait.h>
+ #include <fnmatch.h>
+ #include <poll.h>
++#include <signal.h>
+
+ /* libarchive */
+ #include <archive.h>
diff --git a/sysutils/pacman/pkg-plist b/sysutils/pacman/pkg-plist
index e8c1cab51619..d50f02096d28 100644
--- a/sysutils/pacman/pkg-plist
+++ b/sysutils/pacman/pkg-plist
@@ -11,21 +11,22 @@ bin/pkgdelta
bin/repo-add
bin/repo-elephant
bin/repo-remove
-bin/testdb
bin/testpkg
bin/vercmp
+etc/bash_completion.d/pacman
@sample etc/makepkg.conf.sample
@sample etc/pacman.conf.sample
include/alpm.h
include/alpm_list.h
lib/libalpm.a
lib/libalpm.so
-lib/libalpm.so.9
-lib/libalpm.so.9.0.0
+lib/libalpm.so.10
+lib/libalpm.so.10.0.2
libdata/pkgconfig/libalpm.pc
man/man1/makepkg-template.1.gz
man/man3/libalpm.3.gz
man/man5/PKGBUILD.5.gz
+man/man5/alpm-hooks.5.gz
man/man5/makepkg.conf.5.gz
man/man5/pacman.conf.5.gz
man/man8/makepkg.8.gz
@@ -39,6 +40,11 @@ man/man8/vercmp.8.gz
%%NLS%%share/locale/ar/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/ar/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/ar/LC_MESSAGES/pacman.mo
+%%NLS%%share/locale/az_AZ/LC_MESSAGES/pacman-scripts.mo
+%%NLS%%share/locale/az_AZ/LC_MESSAGES/pacman.mo
+%%NLS%%share/locale/br/LC_MESSAGES/libalpm.mo
+%%NLS%%share/locale/br/LC_MESSAGES/pacman-scripts.mo
+%%NLS%%share/locale/br/LC_MESSAGES/pacman.mo
%%NLS%%share/locale/ca/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/ca/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/ca/LC_MESSAGES/pacman.mo
@@ -57,10 +63,15 @@ man/man8/vercmp.8.gz
%%NLS%%share/locale/en_GB/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/pacman.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/libalpm.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/eo/LC_MESSAGES/pacman.mo
%%NLS%%share/locale/es/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/es/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/es/LC_MESSAGES/pacman.mo
+%%NLS%%share/locale/es_419/LC_MESSAGES/libalpm.mo
+%%NLS%%share/locale/es_419/LC_MESSAGES/pacman-scripts.mo
+%%NLS%%share/locale/es_419/LC_MESSAGES/pacman.mo
%%NLS%%share/locale/fa/LC_MESSAGES/pacman.mo
%%NLS%%share/locale/fi/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/fi/LC_MESSAGES/pacman-scripts.mo
@@ -80,21 +91,24 @@ man/man8/vercmp.8.gz
%%NLS%%share/locale/id/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/id/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/id/LC_MESSAGES/pacman.mo
+%%NLS%%share/locale/is/LC_MESSAGES/libalpm.mo
+%%NLS%%share/locale/is/LC_MESSAGES/pacman-scripts.mo
+%%NLS%%share/locale/is/LC_MESSAGES/pacman.mo
%%NLS%%share/locale/it/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/it/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/it/LC_MESSAGES/pacman.mo
%%NLS%%share/locale/ja/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/ja/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/ja/LC_MESSAGES/pacman.mo
+%%NLS%%share/locale/ka/LC_MESSAGES/libalpm.mo
+%%NLS%%share/locale/ka/LC_MESSAGES/pacman-scripts.mo
+%%NLS%%share/locale/ka/LC_MESSAGES/pacman.mo
%%NLS%%share/locale/kk/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/kk/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/kk/LC_MESSAGES/pacman.mo
%%NLS%%share/locale/ko/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/ko/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/ko/LC_MESSAGES/pacman.mo
-%%NLS%%share/locale/ko_KR/LC_MESSAGES/libalpm.mo
-%%NLS%%share/locale/ko_KR/LC_MESSAGES/pacman-scripts.mo
-%%NLS%%share/locale/ko_KR/LC_MESSAGES/pacman.mo
%%NLS%%share/locale/lt/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/lt/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/lt/LC_MESSAGES/pacman.mo
@@ -134,6 +148,7 @@ man/man8/vercmp.8.gz
%%NLS%%share/locale/sv/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/sv/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/sv/LC_MESSAGES/pacman.mo
+%%NLS%%share/locale/th/LC_MESSAGES/pacman.mo
%%NLS%%share/locale/tr/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/tr/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/tr/LC_MESSAGES/pacman.mo
@@ -147,10 +162,57 @@ man/man8/vercmp.8.gz
%%NLS%%share/locale/zh_TW/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/pacman.mo
+share/makepkg/lint_package.sh
+share/makepkg/lint_package/build_references.sh
+share/makepkg/lint_package/missing_backup.sh
+share/makepkg/lint_pkgbuild.sh
+share/makepkg/lint_pkgbuild/arch.sh
+share/makepkg/lint_pkgbuild/backup.sh
+share/makepkg/lint_pkgbuild/changelog.sh
+share/makepkg/lint_pkgbuild/epoch.sh
+share/makepkg/lint_pkgbuild/install.sh
+share/makepkg/lint_pkgbuild/optdepends.sh
+share/makepkg/lint_pkgbuild/options.sh
+share/makepkg/lint_pkgbuild/package_function.sh
+share/makepkg/lint_pkgbuild/pkgbase.sh
+share/makepkg/lint_pkgbuild/pkglist.sh
+share/makepkg/lint_pkgbuild/pkgname.sh
+share/makepkg/lint_pkgbuild/pkgrel.sh
+share/makepkg/lint_pkgbuild/pkgver.sh
+share/makepkg/lint_pkgbuild/provides.sh
+share/makepkg/lint_pkgbuild/source.sh
+share/makepkg/lint_pkgbuild/util.sh
+share/makepkg/lint_pkgbuild/variable.sh
+share/makepkg/source.sh
+share/makepkg/source/bzr.sh
+share/makepkg/source/file.sh
+share/makepkg/source/git.sh
+share/makepkg/source/hg.sh
+share/makepkg/source/local.sh
+share/makepkg/source/svn.sh
+share/makepkg/tidy.sh
+share/makepkg/tidy/docs.sh
+share/makepkg/tidy/emptydirs.sh
+share/makepkg/tidy/libtool.sh
+share/makepkg/tidy/optipng.sh
+share/makepkg/tidy/purge.sh
+share/makepkg/tidy/staticlibs.sh
+share/makepkg/tidy/strip.sh
+share/makepkg/tidy/upx.sh
+share/makepkg/tidy/zipman.sh
+share/makepkg/util.sh
+share/makepkg/util/message.sh
+share/makepkg/util/option.sh
+share/makepkg/util/pkgbuild.sh
+share/makepkg/util/source.sh
+share/makepkg/util/util.sh
%%DATADIR%%/PKGBUILD-split.proto
%%DATADIR%%/PKGBUILD-vcs.proto
%%DATADIR%%/PKGBUILD.proto
%%DATADIR%%/proto.install
+share/zsh/site-functions/_pacman
+@dir share/libalpm/hooks
+@dir share/makepkg-template
@dir %%PACMAN_ROOT%%
@dir /var/cache/pacman/pkg
@dir /var/cache/pacman