aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Lehey <grog@FreeBSD.org>2016-09-22 02:34:07 +0000
committerGreg Lehey <grog@FreeBSD.org>2016-09-22 02:34:07 +0000
commit8f67e45f476a75e871fc163a96c3e0abf407e67a (patch)
tree405dd1647b82c09c0c7c3dba405eab21c38ed297
parent66b6251e34f57f5a100566f356d0ee12aa6992c1 (diff)
downloadports-8f67e45f476a75e871fc163a96c3e0abf407e67a.tar.gz
ports-8f67e45f476a75e871fc163a96c3e0abf407e67a.zip
Update to 2016.2.0.
MFC after: 2 weeks
Notes
Notes: svn path=/head/; revision=422587
-rw-r--r--graphics/hugin/Makefile8
-rw-r--r--graphics/hugin/distinfo5
-rw-r--r--graphics/hugin/files/patch-src__hugin_script_interface__CMakeLists.txt11
-rw-r--r--graphics/hugin/files/patch-src__tools__align_image_stack.cpp20
-rw-r--r--graphics/hugin/files/patch-src_hugin__cpfind_localfeatures_RansacFiltering.cpp19
-rw-r--r--graphics/hugin/pkg-plist2
6 files changed, 9 insertions, 56 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index fb3d0c7b6d93..8f5a21a8923d 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -2,8 +2,10 @@
# $FreeBSD$
PORTNAME= hugin
-PORTVERSION= 2016.0.0
-PORTREVISION= 3
+PORTVERSION= 2016.2.0
+DISTVERSION= 2016.2.0
+WRKSRC= ${WRKDIR}/hugin-2016.2.0
+PORTREVISION= 0
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
@@ -29,7 +31,7 @@ RUN_DEPENDS= enblend>=4.1.4:graphics/enblend \
USES= cmake compiler:c++11-lib desktop-file-utils \
gettext jpeg pkgconfig shared-mime-info tar:bzip2
CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE=${WX_CONFIG}
-USE_WX= 2.8+
+USE_WX= 3.0+
USE_GL= glew glut
INSTALLS_ICONS= yes
diff --git a/graphics/hugin/distinfo b/graphics/hugin/distinfo
index db2e1478fbc2..8870a64203a7 100644
--- a/graphics/hugin/distinfo
+++ b/graphics/hugin/distinfo
@@ -1,2 +1,3 @@
-SHA256 (hugin-2016.0.0.tar.bz2) = b030b05b248b583cf9a26817f5b350303e3ce2c8bc4b43d45f697fbdf55b65e6
-SIZE (hugin-2016.0.0.tar.bz2) = 10508576
+TIMESTAMP = 1474439221
+SHA256 (hugin-2016.2.0.tar.bz2) = 54ab1bc8dd94d83c02bfd4082c4454b3b33f0fa56bc17b45cf3e89be87691f15
+SIZE (hugin-2016.2.0.tar.bz2) = 10386216
diff --git a/graphics/hugin/files/patch-src__hugin_script_interface__CMakeLists.txt b/graphics/hugin/files/patch-src__hugin_script_interface__CMakeLists.txt
deleted file mode 100644
index b68bc28eb218..000000000000
--- a/graphics/hugin/files/patch-src__hugin_script_interface__CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/hugin_script_interface/CMakeLists.txt~ 2015-07-18 02:44:01.000000000 +1000
-+++ src/hugin_script_interface/CMakeLists.txt 2015-11-24 12:49:59.000000000 +1100
-@@ -201,7 +201,7 @@
- # Linux/MacOS
- # install Python related files into folder depending on used Python version
-
-- EXECUTE_PROCESS( COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))"
-+ EXECUTE_PROCESS( COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1).replace(\"/usr/local/\", \"\"))"
- OUTPUT_VARIABLE pyinstalldir
- OUTPUT_STRIP_TRAILING_WHITESPACE)
-
diff --git a/graphics/hugin/files/patch-src__tools__align_image_stack.cpp b/graphics/hugin/files/patch-src__tools__align_image_stack.cpp
deleted file mode 100644
index b9c6c98e0484..000000000000
--- a/graphics/hugin/files/patch-src__tools__align_image_stack.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/tools/align_image_stack.cpp~ 2015-10-31 11:10:56.000000000 +1100
-+++ src/tools/align_image_stack.cpp 2015-10-29 13:09:52.000000000 +1100
-@@ -121,7 +121,7 @@
- }
-
- typedef std::multimap<double, vigra::Diff2D> MapPoints;
--static hugin_omp::Lock lock;
-+static hugin_omp::Lock slock;
-
- template <class ImageType>
- void FineTuneInterestPoints(Panorama& pano,
-@@ -193,7 +193,7 @@
- res.maxpos.y,
- stereo ? ControlPoint::Y : ControlPoint::X_Y);
- {
-- hugin_omp::ScopedLock sl(lock);
-+ hugin_omp::ScopedLock sl(slock);
- pano.addCtrlPoint(p);
- };
- }
diff --git a/graphics/hugin/files/patch-src_hugin__cpfind_localfeatures_RansacFiltering.cpp b/graphics/hugin/files/patch-src_hugin__cpfind_localfeatures_RansacFiltering.cpp
deleted file mode 100644
index 10b9b1e92fcf..000000000000
--- a/graphics/hugin/files/patch-src_hugin__cpfind_localfeatures_RansacFiltering.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
-Fixes the build on 9.x:
-
-/wrkdirs/usr/ports/graphics/hugin/work/hugin-2015.0.0/src/hugin_cpfind/localfeatures/RansacFiltering.cpp: In function 'int genint(int)':
-/wrkdirs/usr/ports/graphics/hugin/work/hugin-2015.0.0/src/hugin_cpfind/localfeatures/RansacFiltering.cpp:28:31: error: 'rand' was not declared in this scope
- return (int)((double)rand()*x/(double)RAND_MAX);
- ^
-/wrkdirs/usr/ports/graphics/hugin/work/hugin-2015.0.0/src/hugin_cpfind/localfeatures/RansacFiltering.cpp:28:43: error: 'RAND_MAX' was not declared in this scope
- return (int)((double)rand()*x/(double)RAND_MAX);
- ^
---- src/hugin_cpfind/localfeatures/RansacFiltering.cpp.orig 2015-12-04 12:57:44 UTC
-+++ src/hugin_cpfind/localfeatures/RansacFiltering.cpp
-@@ -20,6 +20,7 @@
-
- #include "RansacFiltering.h"
- #include "Homography.h"
-+#include <stdlib.h>
-
- using namespace std;
-
diff --git a/graphics/hugin/pkg-plist b/graphics/hugin/pkg-plist
index a1ad02580a5a..cec729728e7f 100644
--- a/graphics/hugin/pkg-plist
+++ b/graphics/hugin/pkg-plist
@@ -14,7 +14,7 @@
%%DATADIR%%/xrc/cp_editor_panel.xrc
%%DATADIR%%/xrc/cp_list_frame.xrc
%%DATADIR%%/xrc/cpdetector_dialog.xrc
-%%DATADIR%%/xrc/data/COPYING
+%%DATADIR%%/xrc/data/COPYING.txt
%%DATADIR%%/xrc/data/about.htm
%%DATADIR%%/xrc/data/add_project.png
%%DATADIR%%/xrc/data/add_projects.png