aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2024-04-24 18:07:09 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2024-04-24 18:07:09 +0000
commit8f7dac72c518bd1de867e78af351a4a7cf02d799 (patch)
tree94a6ec2c9ccc708a460c5ed2e56abd17e50af171
parent33b24a1dc361162e652db8772badb3897ec00789 (diff)
downloadports-8f7dac72c518bd1de867e78af351a4a7cf02d799.tar.gz
ports-8f7dac72c518bd1de867e78af351a4a7cf02d799.zip
lang/ruby33: Fix build with latest -CURRENT
post-install-DOCS-on copies all files/directories under ${WRKSRC}/doc/ into ${STAGEDIR}${RUBY_DOCDIR}/, then installs ${WRKSRC}/ChangeLog to same directory. But there is ChangeLog directory under ${WRKSRC}/doc/. As a result there is already ${STAGEDIR}${RUBY_DOCDIR}/ChangeLog directory when ${WRKSRC}/ChangeLog is tried to be installed as ${WRKSRC}/doc/ChangeLog. Previously install(1) regards it as non-fatal and build continues. But on latest -CURRENT the command regards it as fatal and results in build error. So fix it by moving ${WRKSRC}/ChangeLog to ${WRKSRC}/doc/ChangeLog/ChangeLog at extract phase. Bump PORTREVISION as plist is changed. PR: 278554 Reported by: Siva Mahadevan MFH: 2024Q2
-rw-r--r--Mk/Uses/ruby.mk2
-rw-r--r--lang/ruby33/Makefile4
-rw-r--r--lang/ruby33/pkg-plist1
3 files changed, 5 insertions, 2 deletions
diff --git a/Mk/Uses/ruby.mk b/Mk/Uses/ruby.mk
index cad327f2bd46..e1650bfe791a 100644
--- a/Mk/Uses/ruby.mk
+++ b/Mk/Uses/ruby.mk
@@ -163,7 +163,7 @@ RUBY_PORTREVISION= 0
# Ruby 3.3
#
RUBY_DISTVERSION= 3.3.1
-RUBY_PORTREVISION= 0
+RUBY_PORTREVISION= 1
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
diff --git a/lang/ruby33/Makefile b/lang/ruby33/Makefile
index e72ce6ad9c15..b2d3e8bdb269 100644
--- a/lang/ruby33/Makefile
+++ b/lang/ruby33/Makefile
@@ -112,6 +112,9 @@ RB_SET_CONF_VAR= ${SH} -c \
'${REINPLACE_CMD} -E -e "s,(CONFIG\[\"$$0\"\][[:space:]]*=[[:space:]]*)(\(?)(.*)(\)?),\1\2$$1\4," ${WRKSRC}/rbconfig.rb' \
--
+post-extract-DOCS-on:
+ ${MV} ${WRKSRC}/ChangeLog ${WRKSRC}/doc/ChangeLog
+
post-patch:
# We get these from other ports
.for d in bin/* ext/dbm ext/gdbm ext/win32* lib/bundler* libexec/bundler* \
@@ -187,7 +190,6 @@ post-install-DOCS-on:
.endfor
@(cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${RUBY_DOCDIR}/)
${INSTALL_DATA} ${WRKSRC}/COPYING* \
- ${WRKSRC}/ChangeLog \
${WRKSRC}/LEGAL \
${WRKSRC}/README* \
${STAGEDIR}${RUBY_DOCDIR}/
diff --git a/lang/ruby33/pkg-plist b/lang/ruby33/pkg-plist
index f18a365ed509..b4cc54ee25c9 100644
--- a/lang/ruby33/pkg-plist
+++ b/lang/ruby33/pkg-plist
@@ -1113,6 +1113,7 @@ libdata/pkgconfig/ruby-%%RUBY_VER%%.pc
%%NO_CAPIDOCS%%%%NO_DOCS%%%%RDOC%%@dir %%RUBY_DOCDIR%%
%%DOCS%%%%RUBY_DOCDIR%%/COPYING
%%DOCS%%%%RUBY_DOCDIR%%/COPYING.ja
+%%DOCS%%%%RUBY_DOCDIR%%/ChangeLog/ChangeLog
%%DOCS%%%%RUBY_DOCDIR%%/ChangeLog/ChangeLog-0.06_to_0.52
%%DOCS%%%%RUBY_DOCDIR%%/ChangeLog/ChangeLog-0.50_to_0.60
%%DOCS%%%%RUBY_DOCDIR%%/ChangeLog/ChangeLog-0.60_to_1.1