aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-05 17:46:12 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-05 17:46:12 +0000
commit8f88d85c5c2636299e5f386a52f58bf93edc50eb (patch)
tree44251aaeae5e521b070265b663bca13513f6b257
parentd706c3a57667ec3fa27973dc479720120cbee890 (diff)
downloadports-8f88d85c5c2636299e5f386a52f58bf93edc50eb.tar.gz
ports-8f88d85c5c2636299e5f386a52f58bf93edc50eb.zip
Notes
-rw-r--r--devel/mercurial/Makefile46
-rw-r--r--devel/mercurial/distinfo4
-rw-r--r--devel/mercurial/pkg-plist1
3 files changed, 20 insertions, 31 deletions
diff --git a/devel/mercurial/Makefile b/devel/mercurial/Makefile
index 863f9bd3606a..44a6a253a1af 100644
--- a/devel/mercurial/Makefile
+++ b/devel/mercurial/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mercurial
-PORTVERSION= 2.7.1
+PORTVERSION= 2.7.2
CATEGORIES= devel python
MASTER_SITES= http://mercurial.selenic.com/release/
@@ -11,12 +11,19 @@ COMMENT= Fast, lightweight source control management system
LICENSE= GPLv2
+NO_STAGE= yes
USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
-OPTIONS_DEFINE= CA_BUNDLE NLS
+OPTIONS_DEFINE= CA_BUNDLE DATA DOCS NLS
+OPTIONS_DEFAULT=DATA
+OPTIONS_SUB= yes
CA_BUNDLE_DESC= Install CA Certificates
+MAN1= hg.1
+MAN5= hgignore.5 hgrc.5
+SUB_FILES= pkg-message
+
CONTRIB_FILES= bash_completion \
casesmash.py \
check-code.py \
@@ -51,40 +58,21 @@ CONTRIB_FILES= bash_completion \
vim/hgtest.vim \
vim/patchreview.txt \
vim/patchreview.vim
+DOCS= CONTRIBUTORS README
-DOCS= CONTRIBUTORS README
-
-MAN1= hg.1
-MAN5= hgignore.5 hgrc.5
+CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+NLS_USES= gettext
-SUB_FILES= pkg-message
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
-post-patch:
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
+.if !${PORT_OPTIONS:MNLS}
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-setup.py
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MCA_BUNDLE}
-RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
.endif
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${PREFIX}/man/man1/
${INSTALL_MAN} ${WRKSRC}/doc/*.5 ${PREFIX}/man/man5/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- for f in ${DOCS}; do \
- ${INSTALL_DATA} ${WRKSRC}/$${f} ${DOCSDIR}; \
- done
-.endif
-.if !defined(NOPORTDATA)
+.if ${PORT_OPTIONS:MDATA}
${MKDIR} ${DATADIR}
${MKDIR} ${DATADIR}/contrib
${MKDIR} ${DATADIR}/contrib/hgfixes
@@ -97,8 +85,10 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/*.cgi ${DATADIR}/www
${INSTALL_DATA} ${WRKSRC}/contrib/hgweb.fcgi ${DATADIR}/www
${INSTALL_DATA} ${WRKSRC}/contrib/hgweb.wsgi ${DATADIR}/www
-
- @${CAT} ${PKGMESSAGE}
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/devel/mercurial/distinfo b/devel/mercurial/distinfo
index 35cc8a7d18f1..4939ca0710ee 100644
--- a/devel/mercurial/distinfo
+++ b/devel/mercurial/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mercurial-2.7.1.tar.gz) = 8472bf1302db15bdf2c4393a5e9180cdbf29b3f8ed5b06c06bf5c6ba8f433588
-SIZE (mercurial-2.7.1.tar.gz) = 3756146
+SHA256 (mercurial-2.7.2.tar.gz) = b3f067eaa9fdf6818cc78526d4815ab4332252ffa07a2488c8b6939ac6b37c0b
+SIZE (mercurial-2.7.2.tar.gz) = 3787955
diff --git a/devel/mercurial/pkg-plist b/devel/mercurial/pkg-plist
index d8ffea1802c3..fa3cd20ae470 100644
--- a/devel/mercurial/pkg-plist
+++ b/devel/mercurial/pkg-plist
@@ -1,4 +1,3 @@
-@comment $FreeBSD$
bin/hg
%%PYTHON_SITELIBDIR%%/hgext/__init__.py
%%PYTHON_SITELIBDIR%%/hgext/__init__.pyc