aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 20:06:39 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 20:06:39 +0000
commit8faf780b19841b4c37de3b19ab54d85659c1efaf (patch)
treec6c5866bbb5e2756fd2c2e644bdbb5ecddbe3d90
parente0461a471464bc950d4a82c47987306cf13a328f (diff)
downloadports-8faf780b19841b4c37de3b19ab54d85659c1efaf.tar.gz
ports-8faf780b19841b4c37de3b19ab54d85659c1efaf.zip
Notes
-rw-r--r--net/pecl-smbclient/Makefile3
-rw-r--r--net/pecl-smbclient/distinfo6
-rw-r--r--net/pecl-smbclient/files/patch-php_smbclient.h19
-rw-r--r--net/pecl-smbclient/files/patch-smb_streams.c63
4 files changed, 4 insertions, 87 deletions
diff --git a/net/pecl-smbclient/Makefile b/net/pecl-smbclient/Makefile
index b0105528660d..d6cbff8d3f2e 100644
--- a/net/pecl-smbclient/Makefile
+++ b/net/pecl-smbclient/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= smbclient
-PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTVERSION= 1.0.1
CATEGORIES= net pear
MAINTAINER= sunpoet@FreeBSD.org
diff --git a/net/pecl-smbclient/distinfo b/net/pecl-smbclient/distinfo
index cd96a2eaf6b6..5d941f78541d 100644
--- a/net/pecl-smbclient/distinfo
+++ b/net/pecl-smbclient/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1546263655
-SHA256 (PECL/smbclient-1.0.0.tgz) = c57cd1be108673ada51f9cc14d874a6b24d849d7e817d5e2774c18ebd6a389a5
-SIZE (PECL/smbclient-1.0.0.tgz) = 32017
+TIMESTAMP = 1609598875
+SHA256 (PECL/smbclient-1.0.1.tgz) = 3e96c99622daf7ded10c650a72d71240fb8d0a8637272504b3c9cc3839980f8a
+SIZE (PECL/smbclient-1.0.1.tgz) = 32364
diff --git a/net/pecl-smbclient/files/patch-php_smbclient.h b/net/pecl-smbclient/files/patch-php_smbclient.h
deleted file mode 100644
index 29d7906855c2..000000000000
--- a/net/pecl-smbclient/files/patch-php_smbclient.h
+++ /dev/null
@@ -1,19 +0,0 @@
-Obtained from: https://github.com/eduardok/libsmbclient-php/commit/a8eab234dd19e32a73740bdd5689e36324b8be5d
-
---- php_smbclient.h.orig 2018-12-24 15:25:25 UTC
-+++ php_smbclient.h
-@@ -128,6 +128,14 @@ PHP_FUNCTION(smbclient_fstatvfs);
- #endif
- #endif
-
-+#if PHP_MAJOR_VERSION >= 8
-+#define TSRMLS_D void
-+#define TSRMLS_DC
-+#define TSRMLS_C
-+#define TSRMLS_CC
-+#define TSRMLS_FETCH()
-+#endif
-+
- extern php_stream_wrapper php_stream_smb_wrapper;
- php_smbclient_state * php_smbclient_state_new (php_stream_context *context, int init TSRMLS_DC);
- void php_smbclient_state_free (php_smbclient_state *state TSRMLS_DC);
diff --git a/net/pecl-smbclient/files/patch-smb_streams.c b/net/pecl-smbclient/files/patch-smb_streams.c
deleted file mode 100644
index 3ab090dd8bfe..000000000000
--- a/net/pecl-smbclient/files/patch-smb_streams.c
+++ /dev/null
@@ -1,63 +0,0 @@
-Obtained from: https://github.com/eduardok/libsmbclient-php/commit/a8eab234dd19e32a73740bdd5689e36324b8be5d
-
---- smb_streams.c.orig 2018-12-24 15:25:25 UTC
-+++ smb_streams.c
-@@ -190,7 +190,11 @@ static int php_smb_ops_flush(php_stream *stream TSRMLS
- return 0;
- }
-
-+#if PHP_VERSION_ID < 70400
- static size_t php_smb_ops_read(php_stream *stream, char *buf, size_t count TSRMLS_DC)
-+#else
-+static ssize_t php_smb_ops_read(php_stream *stream, char *buf, size_t count TSRMLS_DC)
-+#endif
- {
- ssize_t n = 0;
- STREAM_DATA_FROM_STREAM();
-@@ -208,12 +212,20 @@ static size_t php_smb_ops_read(php_stream *stream, cha
- if (n == 0 || n < (ssize_t)count) {
- stream->eof = 1;
- }
-+#if PHP_VERSION_ID < 70400
- return (n < 1 ? 0 : (size_t)n);
-+#else
-+ return n;
-+#endif
- }
-
-+#if PHP_VERSION_ID < 70400
- static size_t php_smb_ops_write(php_stream *stream, const char *buf, size_t count TSRMLS_DC)
-+#else
-+static ssize_t php_smb_ops_write(php_stream *stream, const char *buf, size_t count TSRMLS_DC)
-+#endif
- {
-- size_t len = 0;
-+ ssize_t len = 0;
- STREAM_DATA_FROM_STREAM();
-
- if (!self || !self->handle) {
-@@ -225,7 +237,12 @@ static size_t php_smb_ops_write(php_stream *stream, co
- if (self->smbc_write) {
- len = self->smbc_write(self->state->ctx, self->handle, buf, count);
- }
-+
-+#if PHP_VERSION_ID < 70400
-+ return (len < 0 ? 0 : (size_t)len);
-+#else
- return len;
-+#endif
- }
-
- static int php_smb_ops_stat(php_stream *stream, php_stream_statbuf *ssb TSRMLS_DC) /* {{{ */
-@@ -500,7 +517,11 @@ static int php_smbdir_ops_close(php_stream *stream, in
- return EOF;
- }
-
-+#if PHP_VERSION_ID < 70400
- static size_t php_smbdir_ops_read(php_stream *stream, char *buf, size_t count TSRMLS_DC)
-+#else
-+static ssize_t php_smbdir_ops_read(php_stream *stream, char *buf, size_t count TSRMLS_DC)
-+#endif
- {
- struct smbc_dirent *dirent;
- php_stream_dirent *ent = (php_stream_dirent*)buf;