aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2018-07-03 03:33:04 +0000
committerWen Heping <wen@FreeBSD.org>2018-07-03 03:33:04 +0000
commit8fd6bd0171a1d2077757eb5c863f1af4e11765a4 (patch)
tree911f1522e952279638de5314a52a75b3de6de3a3
parent2ef5dc6a41b0c179cc841f32f6035b9043c501bd (diff)
downloadports-8fd6bd0171a1d2077757eb5c863f1af4e11765a4.tar.gz
ports-8fd6bd0171a1d2077757eb5c863f1af4e11765a4.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-UUID-URandom/Makefile21
-rw-r--r--devel/p5-UUID-URandom/distinfo3
-rw-r--r--devel/p5-UUID-URandom/pkg-descr5
-rw-r--r--devel/p5-UUID-URandom/pkg-plist2
5 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b46ae5f3043f..ce05d25539fe 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3744,6 +3744,7 @@
SUBDIR += p5-UUID-Random
SUBDIR += p5-UUID-Random-Patch-UseMRS
SUBDIR += p5-UUID-Tiny
+ SUBDIR += p5-UUID-URandom
SUBDIR += p5-Uniq
SUBDIR += p5-Unix-Groups
SUBDIR += p5-Unix-Groups-FFI
diff --git a/devel/p5-UUID-URandom/Makefile b/devel/p5-UUID-URandom/Makefile
new file mode 100644
index 000000000000..41f61a66ec55
--- /dev/null
+++ b/devel/p5-UUID-URandom/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= UUID-URandom
+PORTVERSION= 0.001
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= UUIDs based on /dev/urandom or the Windows Crypto API
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-Crypt-URandom>=0.36:security/p5-Crypt-URandom
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/devel/p5-UUID-URandom/distinfo b/devel/p5-UUID-URandom/distinfo
new file mode 100644
index 000000000000..b1ed4cd19cde
--- /dev/null
+++ b/devel/p5-UUID-URandom/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530586670
+SHA256 (UUID-URandom-0.001.tar.gz) = 3f13631b13b9604fb489e2989490c99f103743a837239bdafae9d6baf55f8f46
+SIZE (UUID-URandom-0.001.tar.gz) = 16523
diff --git a/devel/p5-UUID-URandom/pkg-descr b/devel/p5-UUID-URandom/pkg-descr
new file mode 100644
index 000000000000..8a9e46254f8c
--- /dev/null
+++ b/devel/p5-UUID-URandom/pkg-descr
@@ -0,0 +1,5 @@
+This module provides a portable, secure generator of RFC-4122 version 4 (random)
+UUIDs. It is a thin wrapper around Crypt::URandom to set the UUID version and
+variant bits required by the RFC.
+
+WWW: https://metacpan.org/release/UUID-URandom
diff --git a/devel/p5-UUID-URandom/pkg-plist b/devel/p5-UUID-URandom/pkg-plist
new file mode 100644
index 000000000000..b2de89efec0d
--- /dev/null
+++ b/devel/p5-UUID-URandom/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/UUID/URandom.pm
+%%PERL5_MAN3%%/UUID::URandom.3.gz