aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2016-06-29 14:00:33 +0000
committerWen Heping <wen@FreeBSD.org>2016-06-29 14:00:33 +0000
commit91ca14e1fa860a43e4f4e5cedc58900af28c2840 (patch)
treea70a7d7548bd789c78cfe481750da8fc0039acdb
parent94f90e74752ac6f8e052c28738427d553fc880c8 (diff)
downloadports-91ca14e1fa860a43e4f4e5cedc58900af28c2840.tar.gz
ports-91ca14e1fa860a43e4f4e5cedc58900af28c2840.zip
Notes
-rw-r--r--lang/python34/Makefile1
-rw-r--r--lang/python34/Makefile.version2
-rw-r--r--lang/python34/distinfo5
-rw-r--r--lang/python34/files/patch-Modules_zipimport.c17
-rw-r--r--lang/python34/pkg-plist11
5 files changed, 10 insertions, 26 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index 1e02026445e1..b76ef3a78663 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -3,7 +3,6 @@
PORTNAME= python34
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
diff --git a/lang/python34/Makefile.version b/lang/python34/Makefile.version
index c9192ed577df..ef465862a9b1 100644
--- a/lang/python34/Makefile.version
+++ b/lang/python34/Makefile.version
@@ -1,4 +1,4 @@
# Mk/Uses/python.mk includes this file, don't remove it!
# $FreeBSD$
-PYTHON_PORTVERSION= 3.4.4
+PYTHON_PORTVERSION= 3.4.5
diff --git a/lang/python34/distinfo b/lang/python34/distinfo
index e7ef1e9b6ab4..2edc17c251a0 100644
--- a/lang/python34/distinfo
+++ b/lang/python34/distinfo
@@ -1,2 +1,3 @@
-SHA256 (python/Python-3.4.4.tar.xz) = a797d3820155ec6cb654a652b9acfb11792d4e7d568eef1f9199009e042b6ba2
-SIZE (python/Python-3.4.4.tar.xz) = 14307620
+TIMESTAMP = 1467234707
+SHA256 (python/Python-3.4.5.tar.xz) = ee64b1c8a47461009abf25252332d29a4e587cb4f0c1c96aa793a3732e9d898a
+SIZE (python/Python-3.4.5.tar.xz) = 14516820
diff --git a/lang/python34/files/patch-Modules_zipimport.c b/lang/python34/files/patch-Modules_zipimport.c
deleted file mode 100644
index f1fe5b968da6..000000000000
--- a/lang/python34/files/patch-Modules_zipimport.c
+++ /dev/null
@@ -1,17 +0,0 @@
-
-Bug: http://bugs.python.org/issue26171
-
---- Modules/zipimport.c.orig 2015-12-21 06:01:04 UTC
-+++ Modules/zipimport.c
-@@ -1111,6 +1111,11 @@ get_data(PyObject *archive, PyObject *to
- }
- file_offset += l; /* Start of file data */
-
-+ if (data_size > LONG_MAX - 1) {
-+ fclose(fp);
-+ PyErr_NoMemory();
-+ return NULL;
-+ }
- bytes_size = compress == 0 ? data_size : data_size + 1;
- if (bytes_size == 0)
- bytes_size++;
diff --git a/lang/python34/pkg-plist b/lang/python34/pkg-plist
index 870822b62217..9b93b88ee023 100644
--- a/lang/python34/pkg-plist
+++ b/lang/python34/pkg-plist
@@ -1548,8 +1548,8 @@ lib/python3.4/ensurepip/__pycache__/__main__.cpython-34.pyc
lib/python3.4/ensurepip/__pycache__/__main__.cpython-34.pyo
lib/python3.4/ensurepip/__pycache__/_uninstall.cpython-34.pyc
lib/python3.4/ensurepip/__pycache__/_uninstall.cpython-34.pyo
-lib/python3.4/ensurepip/_bundled/pip-7.1.2-py2.py3-none-any.whl
-lib/python3.4/ensurepip/_bundled/setuptools-18.2-py2.py3-none-any.whl
+lib/python3.4/ensurepip/_bundled/pip-8.1.1-py2.py3-none-any.whl
+lib/python3.4/ensurepip/_bundled/setuptools-20.10.1-py2.py3-none-any.whl
lib/python3.4/ensurepip/_uninstall.py
lib/python3.4/enum.py
lib/python3.4/filecmp.py
@@ -1975,9 +1975,9 @@ lib/python3.4/lib-dynload/unicodedata.so
%%NO_DEBUG%%lib/python3.4/lib-dynload/xxlimited.so
lib/python3.4/lib-dynload/zlib.so
lib/python3.4/lib2to3/Grammar.txt
-lib/python3.4/lib2to3/Grammar3.4.4.final.0.pickle
+lib/python3.4/lib2to3/Grammar3.4.5.final.0.pickle
lib/python3.4/lib2to3/PatternGrammar.txt
-lib/python3.4/lib2to3/PatternGrammar3.4.4.final.0.pickle
+lib/python3.4/lib2to3/PatternGrammar3.4.5.final.0.pickle
lib/python3.4/lib2to3/__init__.py
lib/python3.4/lib2to3/__main__.py
lib/python3.4/lib2to3/__pycache__/__init__.cpython-34.pyc
@@ -3367,10 +3367,12 @@ lib/python3.4/test/badsyntax_future9.py
lib/python3.4/test/badsyntax_pep3120.py
lib/python3.4/test/buffer_tests.py
lib/python3.4/test/bytecode_helper.py
+lib/python3.4/test/capath/0e4015b9.0
lib/python3.4/test/capath/4e1295a3.0
lib/python3.4/test/capath/5ed36f99.0
lib/python3.4/test/capath/6e88d7b8.0
lib/python3.4/test/capath/99d0fa06.0
+lib/python3.4/test/capath/ce7b8643.0
lib/python3.4/test/cfgparser.1
lib/python3.4/test/cfgparser.2
lib/python3.4/test/cfgparser.3
@@ -3576,7 +3578,6 @@ lib/python3.4/test/formatfloat_testcases.txt
lib/python3.4/test/future_test1.py
lib/python3.4/test/future_test2.py
lib/python3.4/test/gdb_sample.py
-lib/python3.4/test/https_svn_python_org_root.pem
lib/python3.4/test/ieee754.txt
lib/python3.4/test/imghdrdata/python.bmp
lib/python3.4/test/imghdrdata/python.gif