aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-11-18 19:59:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-11-18 19:59:45 +0000
commit92c37d00e9964eceadc7ec99659d3f464ae82a0f (patch)
tree92f5c3cf1ef5cc3a84eee781be5e7bef0d5059b3
parent756e517ee265f9d5880a4a09b7ae5bfe582f25b9 (diff)
downloadports-92c37d00e9964eceadc7ec99659d3f464ae82a0f.tar.gz
ports-92c37d00e9964eceadc7ec99659d3f464ae82a0f.zip
Notes
-rw-r--r--math/ecos/Makefile21
-rw-r--r--math/ecos/distinfo6
-rw-r--r--math/ecos/pkg-descr5
3 files changed, 25 insertions, 7 deletions
diff --git a/math/ecos/Makefile b/math/ecos/Makefile
index 0403172082be..5faff04aff58 100644
--- a/math/ecos/Makefile
+++ b/math/ecos/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= ecos
-DISTVERSIONPREFIX= v
-DISTVERSION= 2.0.6
+DISTVERSION= 2.0.7
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -14,12 +13,28 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake
USE_GITHUB= yes
GH_ACCOUNT= embotech
-ALL_TARGET= shared
USE_LDCONFIG= yes
+ALL_TARGET= shared
+
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/include/ecos
${INSTALL_DATA} ${WRKSRC}/include/*.h ${STAGEDIR}${PREFIX}/include/ecos
${INSTALL_LIB} ${WRKSRC}/libecos.so ${STAGEDIR}${PREFIX}/lib
+do-test: # some tests are known to fail: https://github.com/embotech/ecos/issues/170
+ @cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} test && \
+ ${ECHO} "===> Running ${PORTNAME} tests: ecostester" && \
+ (./ecostester || true) && \
+ ${ECHO} "===> Running ${PORTNAME} tests: ecos_bb_test" && \
+ ./ecos_bb_test
+
+demos: build # runs the demo problems
+ @cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} demo && \
+ ./runecos && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} runecosexp && \
+ ./runecosexp
+
.include <bsd.port.mk>
diff --git a/math/ecos/distinfo b/math/ecos/distinfo
index e11bd52edc6c..4d378f4096e7 100644
--- a/math/ecos/distinfo
+++ b/math/ecos/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1528436129
-SHA256 (embotech-ecos-v2.0.6_GH0.tar.gz) = ffc4b44e813a5c68abd464b638d216f09385d9b6e40cf487ac384289e6a27988
-SIZE (embotech-ecos-v2.0.6_GH0.tar.gz) = 1266378
+TIMESTAMP = 1542565003
+SHA256 (embotech-ecos-2.0.7_GH0.tar.gz) = bdb6a84f7d150820459bd0a796cb64ffbb019afb95dc456d22acc2dafb2e70e0
+SIZE (embotech-ecos-2.0.7_GH0.tar.gz) = 1277355
diff --git a/math/ecos/pkg-descr b/math/ecos/pkg-descr
index f9eabb96b492..d6991847ba08 100644
--- a/math/ecos/pkg-descr
+++ b/math/ecos/pkg-descr
@@ -7,4 +7,7 @@ s.t. A*x = b
where the last inequality is generalized, i.e. h - G*x belongs to the cone K.
-WWW: https://github.com/embotech/ecos
+Convex optimization is used in fields as diverse as control and estimation,
+finance, signal processing and image reconstruction.
+
+WWW: https://www.embotech.com/ECOS