aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-07-18 15:35:21 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-07-18 15:35:21 +0000
commit93a8c39071ea3f83b7be171f383b403a66dbc2dd (patch)
tree687450e32f7281e19b017ce1d40a2d143f5de131
parent5198c6449d990252e1e0feadac2891fec9c8401c (diff)
downloadports-93a8c39071ea3f83b7be171f383b403a66dbc2dd.tar.gz
ports-93a8c39071ea3f83b7be171f383b403a66dbc2dd.zip
Notes
-rw-r--r--deskutils/griffith/Makefile7
-rw-r--r--deskutils/griffith/distinfo6
-rw-r--r--deskutils/griffith/pkg-descr14
-rw-r--r--deskutils/griffith/pkg-plist19
4 files changed, 39 insertions, 7 deletions
diff --git a/deskutils/griffith/Makefile b/deskutils/griffith/Makefile
index 52bc47ede52b..678b6083d6ee 100644
--- a/deskutils/griffith/Makefile
+++ b/deskutils/griffith/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= griffith
-PORTVERSION= 0.9.2
-PORTREVISION= 1
+PORTVERSION= 0.9.3.1
CATEGORIES= deskutils
MASTER_SITES= CENKES BERLIOS
MAINTAINER= infofarmer@FreeBSD.org
-COMMENT= A film collection manager
+COMMENT= Lightweight film collection manager
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23 \
${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab \
@@ -20,6 +19,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py
${PYTHON_SITELIBDIR}/_xmlplus/__init__.py:${PORTSDIR}/textproc/py-xml \
py*-sqlalchemy>=0.3.3:${PORTSDIR}/databases/py-sqlalchemy
+USE_GETTEXT= yes
USE_PYTHON= yes
USE_GNOME= pygtk2 pygnomeextras
USE_GMAKE= yes
@@ -30,6 +30,7 @@ MANLANG= "" pl pt
post-patch:
@${FIND} ${WRKSRC}/ -name Makefile |\
${XARGS} ${REINPLACE_CMD} -e '/^PREFIX/d' -e '/^MANDIR/s|=.*|=${MANPREFIX}/man|'
+ @${REINPLACE_CMD} -e '/^LANGUAGES=/s|find.*|cd i18n/\&\&ls -d *)|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|/usr/share/fonts|${X11BASE}/lib/X11/fonts|' ${WRKSRC}/${PORTNAME}
.include <bsd.port.mk>
diff --git a/deskutils/griffith/distinfo b/deskutils/griffith/distinfo
index de6de54ecf4b..3b7892c43e51 100644
--- a/deskutils/griffith/distinfo
+++ b/deskutils/griffith/distinfo
@@ -1,3 +1,3 @@
-MD5 (griffith-0.9.2.tar.gz) = 6d303d197612a8940c04693b99030bca
-SHA256 (griffith-0.9.2.tar.gz) = 7ab126adef08edda3c071d71f57e7042bae70eb2f5e90bd2e952d6d73d83e056
-SIZE (griffith-0.9.2.tar.gz) = 693398
+MD5 (griffith-0.9.3.1.tar.gz) = b0761f848756dace248135abe89459f1
+SHA256 (griffith-0.9.3.1.tar.gz) = 7da6f99d2c7b042bf68cd9681ebd162023d9b73c9cd4dab25e2a69331d5220fe
+SIZE (griffith-0.9.3.1.tar.gz) = 794385
diff --git a/deskutils/griffith/pkg-descr b/deskutils/griffith/pkg-descr
index e93f88602a93..ad8cdcced9da 100644
--- a/deskutils/griffith/pkg-descr
+++ b/deskutils/griffith/pkg-descr
@@ -3,4 +3,16 @@ movie collection is as quick and easy as typing the film title and
selecting a supported source. Griffith will then try to fetch all the
related information from the Web.
-WWW: http://griffith.vasconunes.net/
+Most important features:
+* Fetches film information from the Internet based on your locale via a
+ plug-in
+* Integrates well with a database (MySQL, PostgreSQL, SQLite3 used by
+ default) to keep tabs on your library
+* Can backup/restore your database
+* Exports to CSV, PDF, XML and HTML files
+* Imports from CSV files
+* Generates PDF from cover art
+* Keeps track of your films that are out on loan
+* Enables you to sort/filter your library
+
+WWW: http://griffith.berlios.de/
diff --git a/deskutils/griffith/pkg-plist b/deskutils/griffith/pkg-plist
index af193713f849..aee13ddc2542 100644
--- a/deskutils/griffith/pkg-plist
+++ b/deskutils/griffith/pkg-plist
@@ -83,6 +83,7 @@ share/applications/griffith.desktop
%%DATADIR%%/lib/plugins/export/PluginExportHTML.py
%%DATADIR%%/lib/plugins/export/PluginExportPDF.py
%%DATADIR%%/lib/plugins/export/PluginExportXML.py
+%%DATADIR%%/lib/plugins/export/PluginExportiPod.py
%%DATADIR%%/lib/plugins/export/__init__.py
%%DATADIR%%/lib/plugins/imp/CSV.py
%%DATADIR%%/lib/plugins/imp/__init__.py
@@ -95,11 +96,14 @@ share/applications/griffith.desktop
%%DATADIR%%/lib/plugins/movie/PluginMovieCineteka.py
%%DATADIR%%/lib/plugins/movie/PluginMovieCulturalia.py
%%DATADIR%%/lib/plugins/movie/PluginMovieDVDEmpire.py
+%%DATADIR%%/lib/plugins/movie/PluginMovieDVDPalace.py
%%DATADIR%%/lib/plugins/movie/PluginMovieE-Pipoca.py
%%DATADIR%%/lib/plugins/movie/PluginMovieFDb.py
%%DATADIR%%/lib/plugins/movie/PluginMovieFilmAffinity.py
+%%DATADIR%%/lib/plugins/movie/PluginMovieFilmDb.py
%%DATADIR%%/lib/plugins/movie/PluginMovieFilmeVonAZ.py
%%DATADIR%%/lib/plugins/movie/PluginMovieFilmweb.py
+%%DATADIR%%/lib/plugins/movie/PluginMovieIMDB-de.py
%%DATADIR%%/lib/plugins/movie/PluginMovieIMDB-es.py
%%DATADIR%%/lib/plugins/movie/PluginMovieIMDB.py
%%DATADIR%%/lib/plugins/movie/PluginMovieKinoDe.py
@@ -111,6 +115,7 @@ share/applications/griffith.desktop
%%DATADIR%%/lib/plugins/movie/PluginMovieStopklatka.py
%%DATADIR%%/lib/plugins/movie/PluginMovieTanukiAnime.py
%%DATADIR%%/lib/plugins/movie/PluginMovieWP.py
+%%DATADIR%%/lib/plugins/movie/PluginMovieZelluloid.py
%%DATADIR%%/lib/plugins/movie/__init__.py
%%DATADIR%%/lib/preferences.py
%%DATADIR%%/lib/quick_filter.py
@@ -119,6 +124,20 @@ share/applications/griffith.desktop
%%DATADIR%%/lib/version.py
%%DATADIR%%/lib/view.py
%%DATADIR%%/lib/widgets.py
+share/locale/bg/LC_MESSAGES/griffith.mo
+share/locale/cs/LC_MESSAGES/griffith.mo
+share/locale/da/LC_MESSAGES/griffith.mo
+share/locale/de/LC_MESSAGES/griffith.mo
+share/locale/el/LC_MESSAGES/griffith.mo
+share/locale/es/LC_MESSAGES/griffith.mo
+share/locale/fr/LC_MESSAGES/griffith.mo
+share/locale/it/LC_MESSAGES/griffith.mo
+share/locale/nl/LC_MESSAGES/griffith.mo
+share/locale/pl/LC_MESSAGES/griffith.mo
+share/locale/pt/LC_MESSAGES/griffith.mo
+share/locale/pt_BR/LC_MESSAGES/griffith.mo
+share/locale/sv/LC_MESSAGES/griffith.mo
+share/locale/zh_CN/LC_MESSAGES/griffith.mo
share/pixmaps/griffith.png
share/pixmaps/griffith.xpm
@dirrm %%DATADIR%%/export_templates/csv