aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-02-14 18:59:03 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-02-14 18:59:03 +0000
commit94c98a7481f36ab6551dd0926874febad3872b8b (patch)
tree54f5a1f2a5d94b49a8a7a0ba7de9389e401514e7
parentecc14c28252a0ea3a48c7d56ffeb471238d59265 (diff)
Notes
-rw-r--r--security/Makefile2
-rw-r--r--security/p5-Crypt-OpenSSL-EC/Makefile20
-rw-r--r--security/p5-Crypt-OpenSSL-EC/distinfo2
-rw-r--r--security/p5-Crypt-OpenSSL-EC/pkg-descr6
-rw-r--r--security/p5-Crypt-OpenSSL-EC/pkg-plist4
-rw-r--r--security/p5-Crypt-OpenSSL-ECDSA/Makefile21
-rw-r--r--security/p5-Crypt-OpenSSL-ECDSA/distinfo2
-rw-r--r--security/p5-Crypt-OpenSSL-ECDSA/pkg-descr4
-rw-r--r--security/p5-Crypt-OpenSSL-ECDSA/pkg-plist4
9 files changed, 65 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 813c0fc1c66f..e08475d6e0e8 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -491,6 +491,8 @@
SUBDIR += p5-Crypt-OpenSSL-Bignum
SUBDIR += p5-Crypt-OpenSSL-CA
SUBDIR += p5-Crypt-OpenSSL-DSA
+ SUBDIR += p5-Crypt-OpenSSL-EC
+ SUBDIR += p5-Crypt-OpenSSL-ECDSA
SUBDIR += p5-Crypt-OpenSSL-RSA
SUBDIR += p5-Crypt-OpenSSL-Random
SUBDIR += p5-Crypt-OpenSSL-X509
diff --git a/security/p5-Crypt-OpenSSL-EC/Makefile b/security/p5-Crypt-OpenSSL-EC/Makefile
new file mode 100644
index 000000000000..5f853560afe3
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-EC/Makefile
@@ -0,0 +1,20 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Crypt-OpenSSL-EC
+PORTVERSION= 1.01
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MIKEM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl extension for OpenSSL EC (Elliptic Curves) library
+
+BUILD_DEPENDS= p5-Crypt-OpenSSL-Bignum>=0.04:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OpenSSL-EC/distinfo b/security/p5-Crypt-OpenSSL-EC/distinfo
new file mode 100644
index 000000000000..a42c989adeee
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-EC/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-OpenSSL-EC-1.01.tar.gz) = 79dc1949879346715246a39f77f8809e9f9e74c023f140a7d9478b2b7479450e
+SIZE (Crypt-OpenSSL-EC-1.01.tar.gz) = 68850
diff --git a/security/p5-Crypt-OpenSSL-EC/pkg-descr b/security/p5-Crypt-OpenSSL-EC/pkg-descr
new file mode 100644
index 000000000000..d6c468f0de17
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-EC/pkg-descr
@@ -0,0 +1,6 @@
+This module provides a standard (non-OO) interface to the OpenSSL EC (Elliptic
+Curve) library. Some OO Calls are supported.
+
+Most of the functions described in openssl/ec.h are supported.
+
+WWW: https://metacpan.org/pod/Crypt::OpenSSL::EC
diff --git a/security/p5-Crypt-OpenSSL-EC/pkg-plist b/security/p5-Crypt-OpenSSL-EC/pkg-plist
new file mode 100644
index 000000000000..c4c5eb5ca87d
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-EC/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_ARCH%%/Crypt/OpenSSL/EC.pm
+%%SITE_ARCH%%/auto/Crypt/OpenSSL/EC/EC.so
+%%SITE_ARCH%%/auto/Crypt/OpenSSL/EC/autosplit.ix
+%%PERL5_MAN3%%/Crypt::OpenSSL::EC.3.gz
diff --git a/security/p5-Crypt-OpenSSL-ECDSA/Makefile b/security/p5-Crypt-OpenSSL-ECDSA/Makefile
new file mode 100644
index 000000000000..daec62c2edc5
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-ECDSA/Makefile
@@ -0,0 +1,21 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Crypt-OpenSSL-ECDSA
+PORTVERSION= 0.06
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MIKEM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl extension for OpenSSL ECDSA
+
+BUILD_DEPENDS= p5-Crypt-OpenSSL-Bignum>=0.04:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum \
+ p5-Crypt-OpenSSL-EC>=0.05:${PORTSDIR}/security/p5-Crypt-OpenSSL-EC
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OpenSSL-ECDSA/distinfo b/security/p5-Crypt-OpenSSL-ECDSA/distinfo
new file mode 100644
index 000000000000..6c95ebc451a1
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-ECDSA/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-OpenSSL-ECDSA-0.06.tar.gz) = 41dc95831db5813271bb2d1edc5abe3a9b078a28980a6908a7340c2eb0e8497b
+SIZE (Crypt-OpenSSL-ECDSA-0.06.tar.gz) = 52839
diff --git a/security/p5-Crypt-OpenSSL-ECDSA/pkg-descr b/security/p5-Crypt-OpenSSL-ECDSA/pkg-descr
new file mode 100644
index 000000000000..564a7069b75b
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-ECDSA/pkg-descr
@@ -0,0 +1,4 @@
+This module provides an interface to the ECDSA (Elliptic Curve Digital
+Signature Algorithm) functions in OpenSSL.
+
+WWW: https://metacpan.org/pod/Crypt::OpenSSL::ECDSA
diff --git a/security/p5-Crypt-OpenSSL-ECDSA/pkg-plist b/security/p5-Crypt-OpenSSL-ECDSA/pkg-plist
new file mode 100644
index 000000000000..d91c8cc86a99
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-ECDSA/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_ARCH%%/Crypt/OpenSSL/ECDSA.pm
+%%SITE_ARCH%%/auto/Crypt/OpenSSL/ECDSA/ECDSA.so
+%%SITE_ARCH%%/auto/Crypt/OpenSSL/ECDSA/autosplit.ix
+%%PERL5_MAN3%%/Crypt::OpenSSL::ECDSA.3.gz