aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2016-06-25 00:18:29 +0000
committerKris Moore <kmoore@FreeBSD.org>2016-06-25 00:18:29 +0000
commit94d92a089bd32452391762ac5041a012ba4a7c44 (patch)
treed357d0c02c96036c1ad4261db83af069b72b0754
parent8783af45da214ed0f7a2dbea7cecaf94d19d01e5 (diff)
downloadports-94d92a089bd32452391762ac5041a012ba4a7c44.tar.gz
ports-94d92a089bd32452391762ac5041a012ba4a7c44.zip
Notes
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/diligent/Makefile38
-rw-r--r--net-im/diligent/distinfo3
-rw-r--r--net-im/diligent/files/diligent.desktop.in11
-rw-r--r--net-im/diligent/pkg-descr3
5 files changed, 56 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 865bf275b104..fab5fb970a54 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -15,6 +15,7 @@
SUBDIR += convey
SUBDIR += corebird
SUBDIR += cutegram
+ SUBDIR += diligent
SUBDIR += echat
SUBDIR += ejabberd
SUBDIR += ekiga
diff --git a/net-im/diligent/Makefile b/net-im/diligent/Makefile
new file mode 100644
index 000000000000..92e96c932dae
--- /dev/null
+++ b/net-im/diligent/Makefile
@@ -0,0 +1,38 @@
+# Created by: Kris Moore <kmoore@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= diligent
+PORTVERSION= 0.2.5
+DISTVERSIONPREFIX= v
+CATEGORIES= net-im
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= Unofficial Qt Slack client
+
+LICENSE= LGPL3
+
+LIB_DEPENDS= libQt5WebKitWidgets.so:www/webkit-qt5
+
+USE_LDCONFIG= yes
+USE_QT5= core gui network svg linguist \
+ buildtools x11extras widgets
+USE_GL+= gl
+USES= compiler:c++11-lang qmake tar:xz
+
+QMAKE_ARGS= CONFIG+="configure"
+
+USE_GITHUB= yes
+GH_ACCOUNT= trueos
+GH_PROJECT= diligent
+PLIST_FILES= bin/diligent \
+ share/applications/diligent.desktop \
+ share/icons/diligent.png
+SUB_FILES= diligent.desktop
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/diligent ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKDIR}/${SUB_FILES} ${STAGEDIR}${PREFIX}/share/applications/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/icons
+ ${INSTALL_DATA} ${WRKSRC}/images/png/Slack.png ${STAGEDIR}${PREFIX}/share/icons/diligent.png
+
+.include <bsd.port.mk>
diff --git a/net-im/diligent/distinfo b/net-im/diligent/distinfo
new file mode 100644
index 000000000000..f8cdb4a5e18c
--- /dev/null
+++ b/net-im/diligent/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1466813589
+SHA256 (trueos-diligent-v0.2.5_GH0.tar.gz) = d424d28bfbdcd7d1f6d92195acf284ce5143ae885b2530c19995f9a59c4c5d17
+SIZE (trueos-diligent-v0.2.5_GH0.tar.gz) = 3350897
diff --git a/net-im/diligent/files/diligent.desktop.in b/net-im/diligent/files/diligent.desktop.in
new file mode 100644
index 000000000000..e485b8d0c2d0
--- /dev/null
+++ b/net-im/diligent/files/diligent.desktop.in
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Diligent
+GenericName=Slack Client
+Comment=A simple Qt5 based Slack Client
+Exec=%%PREFIX%%/bin/diligent
+Icon=%%PREFIX%%/share/icons/diligent.png
+StartupNotify=false
+Terminal=false
+Type=Application
+Categories=Application;Network;
diff --git a/net-im/diligent/pkg-descr b/net-im/diligent/pkg-descr
new file mode 100644
index 000000000000..e35c2a4ddb24
--- /dev/null
+++ b/net-im/diligent/pkg-descr
@@ -0,0 +1,3 @@
+Diligent is unofficial cross-platform desktop client for Slack.
+
+WWW: https://github.com/trueos/diligent