aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-11 21:41:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-11 21:41:12 +0000
commit94e51b04ae3afb62cbdf5e18ec0af13ee6a81fa4 (patch)
tree03e343eb7903fbcbb3eabf6bacbd84ae10b6e896
parent774d4526f9d8b0e6bd65369301920ac96dec9507 (diff)
downloadports-94e51b04ae3afb62cbdf5e18ec0af13ee6a81fa4.tar.gz
ports-94e51b04ae3afb62cbdf5e18ec0af13ee6a81fa4.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/pear-XML_Wddx/Makefile23
-rw-r--r--textproc/pear-XML_Wddx/distinfo2
-rw-r--r--textproc/pear-XML_Wddx/pkg-descr16
4 files changed, 42 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 2e9969d0cdf9..b72fa8e983ff 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -503,6 +503,7 @@
SUBDIR += pear-Spreadsheet_Excel_Writer
SUBDIR += pear-XML_Beautifier
SUBDIR += pear-XML_HTMLSax
+ SUBDIR += pear-XML_Wddx
SUBDIR += perl2html
SUBDIR += php4-ctype
SUBDIR += php4-domxml
diff --git a/textproc/pear-XML_Wddx/Makefile b/textproc/pear-XML_Wddx/Makefile
new file mode 100644
index 000000000000..831982c72e90
--- /dev/null
+++ b/textproc/pear-XML_Wddx/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: pear-XML_Wddx
+# Date created: 30 March 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML_Wddx
+PORTVERSION= 1.0.1
+CATEGORIES= textproc devel pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR Wddx pretty serializer and deserializer
+
+BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= XML
+FILES= Wddx.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/textproc/pear-XML_Wddx/distinfo b/textproc/pear-XML_Wddx/distinfo
new file mode 100644
index 000000000000..5ac2455e0aa4
--- /dev/null
+++ b/textproc/pear-XML_Wddx/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/XML_Wddx-1.0.1.tgz) = 6512882461a3b9da49382be1baf1f1e3
+SIZE (PEAR/XML_Wddx-1.0.1.tgz) = 3911
diff --git a/textproc/pear-XML_Wddx/pkg-descr b/textproc/pear-XML_Wddx/pkg-descr
new file mode 100644
index 000000000000..997465afec04
--- /dev/null
+++ b/textproc/pear-XML_Wddx/pkg-descr
@@ -0,0 +1,16 @@
+PEAR::XML_Wddx does 2 things:
+a) a drop in replacement for the XML_Wddx extension (if it's not built in)
+b) produce an editable wddx file (with indenting etc.) and uses CDATA, rather
+ than char tags
+
+This package contains 2 static methods:
+XML_Wddx:serialize($value)
+XML_Wddx:deserialize($value)
+
+Should be 90% compatible with wddx_deserialize(), and the deserializer will
+use wddx_deserialize if it is built in.
+
+No support for recordsets is available at present in the PHP version of the
+deserializer.
+
+WWW: http://pear.php.net/package/XML_Wddx/