aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-10 00:36:03 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-10 00:36:03 +0000
commit94fc0435c74a92e627f12290575dcf1410594c2a (patch)
tree6de96cfbcf952dca63c9324cdac7251f88dcdc28
parent76028392daf22a057ab7da8804637ed36389def4 (diff)
downloadports-94fc0435c74a92e627f12290575dcf1410594c2a.tar.gz
ports-94fc0435c74a92e627f12290575dcf1410594c2a.zip
Notes
-rw-r--r--devel/p5-Data-Random/Makefile4
-rw-r--r--devel/p5-VCP-autrijus/Makefile4
-rw-r--r--devel/p5-VCP/Makefile3
-rw-r--r--www/p5-URI-Fetch/Makefile4
4 files changed, 7 insertions, 8 deletions
diff --git a/devel/p5-Data-Random/Makefile b/devel/p5-Data-Random/Makefile
index 26e50878a2f1..e39b3338abdf 100644
--- a/devel/p5-Data-Random/Makefile
+++ b/devel/p5-Data-Random/Makefile
@@ -13,6 +13,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for generating random data
+PERL_CONFIGURE= yes
+
.include <bsd.port.pre.mk>
# define WITHOUT_DATE_CALC to disable support for rand_date()
@@ -28,8 +30,6 @@ EXTRA_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
BUILD_DEPENDS+= ${EXTRA_DEPENDS}
RUN_DEPENDS+= ${EXTRA_DEPENDS}
-PERL_CONFIGURE= yes
-
MAN3= Data::Random.3 Data::Random::WordList.3
.include <bsd.port.post.mk>
diff --git a/devel/p5-VCP-autrijus/Makefile b/devel/p5-VCP-autrijus/Makefile
index 234d42967594..86300c056780 100644
--- a/devel/p5-VCP-autrijus/Makefile
+++ b/devel/p5-VCP-autrijus/Makefile
@@ -30,6 +30,8 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-X
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PERL5= yes
+PERL_CONFIGURE= yes
+
.include <bsd.port.pre.mk>
@@ -38,8 +40,6 @@ BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.endif
-PERL_CONFIGURE= yes
-
MAN1= vcp.1
MAN3= RevML::Doctype.3 \
RevML::Writer.3 \
diff --git a/devel/p5-VCP/Makefile b/devel/p5-VCP/Makefile
index da313fbb34c4..68421cddecb9 100644
--- a/devel/p5-VCP/Makefile
+++ b/devel/p5-VCP/Makefile
@@ -29,6 +29,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-X
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PERL5= yes
+PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
@@ -37,8 +38,6 @@ BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.endif
-PERL_CONFIGURE= yes
-
MAN1= vcp.1
MAN3= RevML::Doctype.3 \
RevML::Writer.3 \
diff --git a/www/p5-URI-Fetch/Makefile b/www/p5-URI-Fetch/Makefile
index 6d16d14ee424..4a106c4bbf61 100644
--- a/www/p5-URI-Fetch/Makefile
+++ b/www/p5-URI-Fetch/Makefile
@@ -25,6 +25,8 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
OPTIONS= ZLIB "GZIP Support" on \
CACHE "Caching Support" off
+PERL_MODBUILD= yes
+
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_ZLIB)
@@ -37,8 +39,6 @@ BUILD_DEPENDS+= p5-Cache>=0:${PORTSDIR}/devel/p5-Cache
RUN_DEPENDS+= p5-Cache>=0:${PORTSDIR}/devel/p5-Cache
.endif
-PERL_MODBUILD= yes
-
MAN3= URI::Fetch.3 \
URI::Fetch::Response.3