aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2022-04-11 07:56:44 +0000
committerMathieu Arnold <mat@FreeBSD.org>2022-04-11 08:21:20 +0000
commit9524f35705c0f0d346d0f0b17c9ff424ab277a5d (patch)
tree867cdf8a256806fe8ad103038eb517a7f547aff6
parentdedac46dc8a44d51a76804c3dbeba6d7f1349d3e (diff)
downloadports-9524f35705c0f0d346d0f0b17c9ff424ab277a5d.tar.gz
ports-9524f35705c0f0d346d0f0b17c9ff424ab277a5d.zip
-rw-r--r--dns/bind9-devel/Makefile19
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl16
3 files changed, 17 insertions, 24 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 084def0a1290..7e7953d76ab9 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -4,11 +4,11 @@ PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
.if defined(BIND_TOOLS_SLAVE)
# dns/bind-tools here
-PORTREVISION= 1
+PORTREVISION= 0
.else
# XXX: correct version
# dns/bind9xx here
-PORTREVISION= 1
+PORTREVISION= 0
.endif
CATEGORIES= dns net
# XXX: put the ISC master_site
@@ -49,13 +49,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= autoreconf compiler:c11 cpe libedit libtool pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.17.22a0.2022.04.01
+ISCVERSION= 9.17.22a0.2022.04.08
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= d4eef9e89a0add9e63a6939c73106125d4b58360
+GL_COMMIT= 6cdc4114cb205b44be4f1cfdf752368e64757a4a
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -95,7 +95,7 @@ MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFAULT= GSSAPI_NONE IDN JSON LMDB MANPAGES \
TCP_FASTOPEN DNSTAP
OPTIONS_DEFINE= DNSTAP DOCS FIXED_RRSET GEOIP IDN JSON LARGE_FILE LMDB \
- MANPAGES OVERRIDECACHE PORTREVISION QUERYTRACE \
+ MANPAGES OVERRIDECACHE QUERYTRACE \
START_LATE TCP_FASTOPEN
OPTIONS_SINGLE= GSSAPI
@@ -103,7 +103,7 @@ OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
.if defined(BIND_TOOLS_SLAVE)
OPTIONS_EXCLUDE= DNSTAP DOCS GEOIP LMDB \
- OVERRIDECACHE PORTREVISION QUERYTRACE START_LATE \
+ OVERRIDECACHE QUERYTRACE START_LATE \
TCP_FASTOPEN
.endif # BIND_TOOLS_SLAVE
@@ -118,7 +118,6 @@ GSSAPI_NONE_DESC= Disable
LARGE_FILE_DESC= 64-bit file support
LMDB_DESC= Use LMDB for zone management
OVERRIDECACHE_DESC= Use the override-cache patch
-PORTREVISION_DESC= Show PORTREVISION in the version string
QUERYTRACE_DESC= Enable the very verbose query tracelogging
START_LATE_DESC= Start BIND late in the boot process (see help)
TCP_FASTOPEN_DESC= RFC 7413 support
@@ -212,12 +211,6 @@ post-patch:
.endfor
.if !defined(BIND_TOOLS_SLAVE)
-. if ${PORTREVISION:N0}
-post-patch-PORTREVISION-on:
- @${REINPLACE_CMD} '/^m4_define.*bind_VERSION_EXTRA/s#)#_${PORTREVISION})#' \
- ${WRKSRC}/configure.ac
-. endif
-
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/mtree
${MKDIR} ${STAGEDIR}${ETCDIR}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 8f9482890edf..d2f09d1fea5e 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1649054912
-SHA256 (isc-projects-bind9-d4eef9e89a0add9e63a6939c73106125d4b58360_GL0.tar.gz) = ce854ab1d78cd8db7c83c4e3242412d48840fc79e859c7a527d6abbfd45da251
-SIZE (isc-projects-bind9-d4eef9e89a0add9e63a6939c73106125d4b58360_GL0.tar.gz) = 6194533
+TIMESTAMP = 1649660475
+SHA256 (isc-projects-bind9-6cdc4114cb205b44be4f1cfdf752368e64757a4a_GL0.tar.gz) = 08697d3416406dc82fa922cc147af63c4210685ba71399e09f55ad8fa92b6752
+SIZE (isc-projects-bind9-6cdc4114cb205b44be4f1cfdf752368e64757a4a_GL0.tar.gz) = 6203915
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index a382f62e56e8..cc78d545b34d 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,8 +1,8 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2022-04-01 23:48:26 UTC
+--- bin/named/config.c.orig 2022-04-08 10:15:26 UTC
+++ bin/named/config.c
-@@ -171,6 +171,7 @@ options {\n\
+@@ -181,6 +181,7 @@ options {\n\
notify-source *;\n\
notify-source-v6 *;\n\
nsec3-test-zone no;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
parental-source *;\n\
parental-source-v6 *;\n\
provide-ixfr true;\n\
---- bin/named/server.c.orig 2022-04-01 23:48:26 UTC
+--- bin/named/server.c.orig 2022-04-08 10:15:26 UTC
+++ bin/named/server.c
-@@ -4487,6 +4487,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4488,6 +4488,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2022-04-01 23:48:26 UTC
+--- lib/dns/include/dns/view.h.orig 2022-04-08 10:15:26 UTC
+++ lib/dns/include/dns/view.h
@@ -155,6 +155,7 @@ struct dns_view {
bool requestnsid;
@@ -34,7 +34,7 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2022-04-01 23:48:26 UTC
+--- lib/dns/resolver.c.orig 2022-04-08 10:15:26 UTC
+++ lib/dns/resolver.c
@@ -6113,6 +6113,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
@@ -49,9 +49,9 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2022-04-01 23:48:26 UTC
+--- lib/isccfg/namedconf.c.orig 2022-04-08 10:15:26 UTC
+++ lib/isccfg/namedconf.c
-@@ -2092,6 +2092,7 @@ static cfg_clausedef_t view_clauses[] = {
+@@ -2093,6 +2093,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
{ "max-acache-size", NULL, CFG_CLAUSEFLAG_ANCIENT },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },